Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] r1000 and r8169 don't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Cor3y
n00b
n00b


Joined: 25 May 2007
Posts: 7
Location: Poland

PostPosted: Fri May 25, 2007 3:25 pm    Post subject: [SOLVED] r1000 and r8169 don't work Reply with quote

SOLVED
Solution from user neocui, which have worked just as it should be for me :D (Thx again man)
Quote:
I have an ASUS P5B as well. Here are some tips:

1. The 2007.0 livecd should work. The driver is r8169.
2. Check the ethernet plug on the back of your computer, does it lit up?
3. If it doesn't light up, you are probably dual booting Windows* (am I correct?), and the ethernet card lights up only when you boot into windows.
4. In windows, go to control panel -> system -> hardware -> double click on the r8111b NIC, there are some advance options you can set. Find the one called Wake On Lan, and ENABLE it.
5. Now boot into linux, and it should work automatically!

So my theory is, if you disable Wake On Lan, windows shuts off the NIC when it shuts down. And the NIC has a memory of its own, and doesn't turn back up again until Windows turns it on, even across reboots (ironically if you do turn on wake on lan, the ethernet is on even when your computer is off). So make sure windows doesn't turn the NIC off when it shuts down.

Somehow, the r8169 driver in Linux doesn't know how to turn the NIC back up... Does anyone know another solution?

* If you don't have windows, try clearing the bios.


P.S. I have also used newest driver (25.05.2007) from Realtek, which replaced r1000_v1.05 driver LINK

r1000 was causing soft lockups on one of the cores of my Core 2 Duo processor. New driver works just fine (and it's only for 2.6.18 kernels and higher)

-----------------------------------------------------------

Hi.
I'm strugling with getting my NIC on my Compal HEL80 laptop to work, but I'm out of ideas for now. I was reading posts form this forum, google, wiki-gentoo and nothing seems to be working for my RTL8168/8111 Gbit PCI Express NIC.

First I've installed Gentoo from console using LiveDVD (also tried with LiveCD), (stage3 tarball, portage image and other packages was on my pendrive). Default r8169 module compiled into 2.6.19-r5 kernel from LiveCD does not work. It shows me eth0 interface, but the card is dead - no transport at all. It can't connect to the DHCP server on my network. Static address doesn't help either. I can't even ping computers on LAN, not even mention on the web. So I've unloaded r8169 module (modprobe -r r8169) and compiled r1000_v1.05 drivers from official Realtek web page using directions from readme file:
Code:

cd r1000
make clean module
make install
depmod -a

During compile process a warning message pops out, but the driver was compiled and installed without a problem:
Code:
/usr/src/r1000_v1.05/src/r1000_n.c:756: warning: passing argument 2 of 'request_irq' from incompatible pointer type


Next I have modprobed r1000 module. Ifconfig shows me, that the card is trying to transfer something, but only TX bytes are increasing, RX bytes are 0 all the time. Of course DHCP or static IP doesn't work.

I've added static IP with the commands:
Code:
ifconfig eth0 192.168.2.3 broadcast 192.168.2.255 netmask 255.255.255.0 up
route add default gw 192.168.2.1
echo "nameserver 194.204.152.34" > /etc/resolv.conf (only one time, for the file creation)


But I tried another thing - I've borrowed AP from my friend and used Ubuntu LiveDVD to install the Gentoo with internet from my Intel PRO 3945ABG wifi card (Ubuntu doesn't work with my R8168 either). I have prefformed clean install using stage3 tarball and emerging everything I needed form internet through wifi connection. I've downloaded gentoo-sources 2.6.20-r8 and compiled them manually.
I. r8169 compiled into kernel - doesn't work (DHCP and static IP)
II. r8169 compiled as a module - doesn't work (DHCP and static IP)
III. Kernel compiled without r8169 at all, and manually compiled r1000 drivers - doesn't work (only TX bytes increasing and the same warning during the compile process) (DHCP and static IP)

I've tried a few distros and LiveCD/DVD (Debian 4.0 Etch 2.6.18, Ubuntu 7.04 LiveDVD and HDD install 2.6.19, Gentoo LiveCD and LiveDVD - console install and text-based installer) and only once, at the begining Ubuntu has managed to connect to security update page and download some patches during the install. After reboot my net stopped working. Second installation of Ubuntu didn't connected to net. I'll just add, that I dual-boot with Windows XP, and the NIC is working flawessly there (with Realtek drivers).

Anyone can help me with forcing my NIC to work on Gentoo (or any other distro for that matter)? If I can't do anything about it I will buy USB or PCMCIA (RTL8139) card, but I would prefer to use my built-in components rather than adding some more cards to my laptop.

My configuration of Intel VBI (Veryfied By Intel):
Main: Compal HEL 80 15,4"
Proc: Core 2 Duo T5600 2x1,83GHz
Ram: 1GB Kingston 667MHz
GFX: GeForce 7600, 256MB dedicated RAM
HDD: 120GB Hitachi S-ATA (internal) i 320GB Segate S-ATA (USB external)
WLAN: Intel PRO 3945ABG
LAN: Realtek RTL8168/RTL8111 GigaBit PCI Express

emerge --info
Code:

Portage 2.1.2.2 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r0, 2.6.20-gentoo-r8 i686)
=================================================================
System uname: 2.6.20-gentoo-r8 i686 Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 23 May 2007 01:47:01 +0000
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.61
sys-devel/automake:  1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.po.opole.pl/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="a52 aac acl acpi alsa apm arts bash-completion berkdb bitmap-fonts bzip2 cairo cdb cdparanoia cli cracklib crypt cups dbus dri dv dvd dvdr encode evo exif fam fbcon ffmpeg firefox flac fortran ftp gd gdbm geoip gif ginac glut gmp gpm gstreamer hal iconv ieee1394 imlib ipv6 isdnlog java javascript jpeg jpeg2k kde kdeenablefinal kerberos ldap libcaca libg++ libsamplerate lm-sensors mad matroska midi mime mmx mng mp3 mpeg mplayer mudflap musepack ncurses nls nptl nptlonly odbc offensive ogg openal opengl openmp oss pam pcmcia pcntl pcre pdf perl png posix ppds pppd pulseaudio python qt3 qt4 quicktime readline recode reflection ruby samba sasl scanner sdl session shorten simplexml slp sockets speex spell spl sse sse2 ssl svg svga symlink tcpd theora threads tiff truetype truetype-fonts type1-fonts unicode usb v4l vcd videos vorbis wddx wifi win32codecs wmf x264 x86 xcomposite xine xml xorg xpm xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


ifconfig -a (right after reboot and trying to use dhcpcd)
Code:

eth0      Link encap:Ethernet  HWaddr 00:16:D4:61:D6:7D
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:2862 (2.7 Kb)
          Interrupt:19 Base address:0x3000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


If you need anything more, just let me know, I'll try to post it here. And don't be "too" advanced with gentoo terminology, because I'm learning Linux for 1,5 week only (most of the time fighting with my NIC) 8)
Back to top
View user's profile Send private message
aztec
n00b
n00b


Joined: 26 Jun 2007
Posts: 1

PostPosted: Tue Jun 26, 2007 10:05 pm    Post subject: Reply with quote

I had the same problem with r8169. My Ubuntu didn't show anything wrong but static configuration or dhcp just didnt work.

Try that:

sudo vim /etc/modprobe.d/blacklist
and uncomment last(or in your case platform not last) lines:
#blacklist r818x
#blacklist r8187

Mayby that solution you arent able to try on your platform, but I wrote with hope you will;)
And tell us if it worked, im curious:)
Back to top
View user's profile Send private message
Cor3y
n00b
n00b


Joined: 25 May 2007
Posts: 7
Location: Poland

PostPosted: Wed Jun 27, 2007 1:57 pm    Post subject: Reply with quote

Thx for answer, but I've solved this problem a month ago, and the solution is described at the beginning of the first post.
Back to top
View user's profile Send private message
eyebex
n00b
n00b


Joined: 23 Jul 2005
Posts: 65

PostPosted: Sat Jul 28, 2007 10:08 am    Post subject: Reply with quote

Enabling "Wake On LAN" in Windows worked for my Asus A8Js, too. Thanks a lot, great tip!
Back to top
View user's profile Send private message
batistuta
Veteran
Veteran


Joined: 29 Jul 2005
Posts: 1384
Location: Aachen

PostPosted: Tue Aug 21, 2007 8:23 am    Post subject: Reply with quote

This also solved it for me. Many thanks! :D
Now, I don't use wake-up on LAN and don't really wanna have it active. Why can't the Linux driver for my NIC wake-up the device, and the Linux driver can? Is this an issue with the driver itself, or something funky/non-standard that Windows does when powering down?
Back to top
View user's profile Send private message
Frumple
n00b
n00b


Joined: 08 Dec 2004
Posts: 9
Location: Rio de Janeiro - Brasil

PostPosted: Wed Nov 21, 2007 11:19 pm    Post subject: Reply with quote

Thanks!
I have an Asus A8Js with the Realtek 8169 LAN Card, enabling WOL on the Windows driver advanced tab really solved this issue.
I haven't got the time to try it on gentoo, but soon as possible I will post the results here.
Back to top
View user's profile Send private message
ruta
n00b
n00b


Joined: 01 Oct 2004
Posts: 69
Location: Canada

PostPosted: Thu Feb 07, 2008 3:11 pm    Post subject: Reply with quote

I believe this is the problem with my new computer, but it's vista. I was able to find the wake-on-lan preference, but even if I enable or disable it, there's no difference. In Linux, the light where my lan cable connects will not turn on. Does anyone have any way around this? I even left my computer unplugged all night in hopes that the lack of power would reset whatever switch Windows may have turned on.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum