Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] KDE: niente suoni. Flag use mancante?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Oct 19, 2005 9:45 am    Post subject: [risolto] KDE: niente suoni. Flag use mancante? Reply with quote

Possibile che il fatto che io non abbia incluso la USE flag ogg (oggvorbis è sconsigliata) nel make.conf non mi faccia funzionare l'audio del kde (nemmeno da root) ? Mp3 e quant'altro pare funzionare bene...
Prima di ricompilare il kde vorrei una conferma...
tnx

PS ho letto in altri post che dopo aver aggiunto la flag use ogg il risultato era sempre lo stesso.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Thu Oct 20, 2005 9:50 am; edited 2 times in total
Back to top
View user's profile Send private message
syntaxerrormmm
Guru
Guru


Joined: 17 Apr 2005
Posts: 449
Location: Romano di Lombardia - BG - ITALY

PostPosted: Wed Oct 19, 2005 9:49 am    Post subject: Reply with quote

[Edited]
Ok, sorry, avevo scritto soltanto xa22ate. Chiedo a un mod, se possibile, di levare il mio intervento.

Ciao.
[/Edit]
_________________
"Every rule can be broken, but no rule may be ignored."

Last.fm - Gentoo 2006.1 on:
Acer Aspire 1355LC - suspend2-sources-2.6.18-r3
IBM Thinkpad T30 - suspend2-sources-2.6.19-r3


Last edited by syntaxerrormmm on Wed Oct 19, 2005 9:52 am; edited 1 time in total
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Wed Oct 19, 2005 9:50 am    Post subject: Reply with quote

per caso ti manca la USE arts?
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
gutter
Bodhisattva
Bodhisattva


Joined: 13 Mar 2004
Posts: 7162
Location: Aarau, Aargau, Switzerland

PostPosted: Wed Oct 19, 2005 9:52 am    Post subject: Re: KDE: niente suoni. Flag use mancante? Reply with quote

fbcyborg wrote:
Possibile che il fatto che io non abbia incluso la USE flag ogg (oggvorbis è sconsigliata) nel make.conf non mi faccia funzionare l'audio del kde (nemmeno da root) ?


Ti riferisci ai suoni di sistema di kde?

Hai provato a dare un'occhiata ad ARTS?
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Oct 19, 2005 10:03 am    Post subject: Reply with quote

la flag use arts è presente.... (tempo fa feci la caxxata di non mettercela ed ora me la sono ricordata!)
cmq ho appena trovato un messaggio di errore...
akode: Could not open frame decoder
couldn't load file /usr/kde/3.4/share/sounds/KDE_Desktop.ogg

questi messaggi apparivano in shell dopo aver fatto killall artsd e dopo aver riavviato artsd

gutter wrote:

Ti riferisci ai suoni di sistema di kde?
Yesssss
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
makami
Guru
Guru


Joined: 10 Jul 2005
Posts: 321

PostPosted: Wed Oct 19, 2005 10:06 am    Post subject: Reply with quote

Per i suoni di sistema devi attivare il software mixing seguendo una delle tante guide presenti nel forum
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Oct 19, 2005 10:19 am    Post subject: Reply with quote

Tante guide, è vero.. ma ancora non trovo quella che fa al mio caso
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Oct 19, 2005 10:54 am    Post subject: Reply with quote

non è che tu debba specificare la use vorbis?

EDIT:
prima di installare un pacchetto ti consiglio un
Code:
emerge -pv pacchetto
e di esaminare attentamente le use che lui ( e le sue dipendenze) hanno. alcuni strumenti utili per capire cosa fanno le USE sono
Code:
euse -i elenco_use
presente in gentoolkit
e ufed
Code:
#emerge ufed

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Oct 19, 2005 11:44 am    Post subject: Reply with quote

Infatti... quello che volevo sapere prima di riaffrontare la compilazione del kde.... era proprio sapere se fosse davvero necessaria la flag ogg.

Quindi???? è necessaria?
non ci sto capendo molto... c'è chi dice di andare a vedere una guida per attivare il "software mixing", che nessuno sa dove sia... e chi parla di flag use...
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 20, 2005 9:50 am    Post subject: Reply with quote

makami wrote:
Per i suoni di sistema devi attivare il software mixing seguendo una delle tante guide presenti nel forum


non serviva assolutamente....
bastava eseguire
Code:
USE="vorbis" emerge kdemultimedia"

ora i suoni sono OK!

grazie
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2414
Location: イタリアのロディで

PostPosted: Thu Oct 20, 2005 10:28 am    Post subject: Reply with quote

Code:
USE="vorbis" emerge kdemultimedia
:wink:
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Thu Oct 20, 2005 10:32 am    Post subject: Reply with quote

Code:
echo "kde-base/kdemultimedia vorbis" >> /etc/portage/package.use


:P
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2414
Location: イタリアのロディで

PostPosted: Thu Oct 20, 2005 10:42 am    Post subject: Reply with quote

E lo sapevo che era deprecato USE=" " emerge ! Ma... meglio che me ne sto zitto... :oops:

:wink:
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 20, 2005 10:44 am    Post subject: Reply with quote

perchè deprecato? che cosa può succedere?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Thu Oct 20, 2005 11:18 am    Post subject: Reply with quote

fbcyborg wrote:
perchè deprecato? che cosa può succedere?

prova a dare un emerge -vp kdemultimedia. Come puoi vedere (se la USE vorbis non è presente in make.conf o nel tuo profilo) avrai -vorbis*, quindi a meno che tu non riemerga esplicitamente con la use vorbis, verrà ricompilato senza quel supporto.

Se inserisci la use che ti interessa in package.use, questa tua "preferenza" rimarrà per sempre ;)

Per dettagli:
Code:
man portage

_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 20, 2005 11:39 am    Post subject: Reply with quote

Ok grazie piano piano comincio a capirci qualcosa...
so che è pieno di guide a partire da www.gentoo.org. Ma per le flag use ancora devo trovare un manuale con esempi che mi faccia capire alla perfezione....
Cmq per esempio prima volevo emergere gftp ma senza installarlo con
Code:
USE="gtk" emerge gftp
il programma non partiva....
Adesso comunque ho inserito nel mio make.conf la use gtk
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Jul 12, 2007 7:47 am    Post subject: Reply with quote

Salve di nuovo,

riesumo questo thread perché sembra proprio che il suono in KDE sul mio AMD64 voglia farmi tribolare.
Ora però è un'altra Gentoo da un bel po' di tempo e non ho più kdemultimedia ma kdemultimedia-meta che non ha come flag USE locale "vorbis".
Facendo emerge --info, fra le USE flag c'è vorbis.

Gli mp3 si sentono... kde sounds nada...
Ho due schede audio, ma non credo sia quello il problema.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Jul 12, 2007 8:38 am    Post subject: Reply with quote

Segui questa discussione per configurare opportunamente KDE senza il demone sonoro ARTS (c'è anche il trucchetto per far funzionare correttamente le notifiche di sistema di KDE)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Jul 12, 2007 11:57 am    Post subject: Reply with quote

Ok, grazie, ho messo "-arts" nel make.conf e sto ricompilando tutto.. sono 204 pacchetti!

Per lo script non ho capito come fa quel file (notificheKDE.sh) a far suonare KDE.. Chi glielo dice a KDE che deve usare quello script per emettere suoni?

Devo andare in System Notifications e dopo aver cliccato su Advanced.. devo dargli il path dello script dove dice "Execute program" ?

Quando ho finito poi ti faccio sapere.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum