Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200705-19 ] PHP: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1655

PostPosted: Sat May 26, 2007 8:26 pm    Post subject: [ GLSA 200705-19 ] PHP: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 200705-19)
Severity: high
Exploitable: remote
Date: May 26, 2007
Updated: March 29, 2008
Bug(s): #169372
ID: 200705-19

Synopsis

PHP contains several vulnerabilities including buffer and integer overflows which could under certain conditions lead to the remote execution of arbitrary code.

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected Packages

Package: dev-lang/php
Vulnerable: < 5.2.2
Unaffected: >= 4.4.7 < 4.4.8
Unaffected: >= 4.4.8_pre20070816 < 4.4.9
Unaffected: >= 5.2.2
Architectures: All supported architectures


Description

Several vulnerabilities were found in PHP, most of them during the Month Of PHP Bugs (MOPB) by Stefan Esser. The most severe of these vulnerabilities are integer overflows in wbmp.c from the GD library (CVE-2007-1001) and in the substr_compare() PHP 5 function (CVE-2007-1375). Ilia Alshanetsky also reported a buffer overflow in the make_http_soap_request() and in the user_filter_factory_create() functions (CVE-2007-2510, CVE-2007-2511), and Stanislav Malyshev discovered another buffer overflow in the bundled XMLRPC library (CVE-2007-1864). Additionally, the session_regenerate_id() and the array_user_key_compare() functions contain a double-free vulnerability (CVE-2007-1484, CVE-2007-1521). Finally, there exist implementation errors in the Zend engine, in the mb_parse_str(), the unserialize() and the mail() functions and other elements.

Impact

Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.2.2"
All PHP 4 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.7"


References

CVE-2007-1001
CVE-2007-1285
CVE-2007-1286
CVE-2007-1484
CVE-2007-1521
CVE-2007-1583
CVE-2007-1700
CVE-2007-1701
CVE-2007-1711
CVE-2007-1717
CVE-2007-1718
CVE-2007-1864
CVE-2007-1900
CVE-2007-2509
CVE-2007-2510
CVE-2007-2511


Last edited by GLSA on Sat Mar 29, 2008 4:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum