Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI driver per radeon 9000
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Fri May 18, 2007 5:39 pm    Post subject: ATI driver per radeon 9000 Reply with quote

Ciao a tutti,
sono appena giunto sul forum, e sono un nuovo utente gentoo. Mi scuso in anticipo per la lunghezza del thread, ma vorrei essere il più chiaro possibile.

Ho una scheda ATI Radeon 9000 ed una scheda madre ASUS con chipset INTEL 865 e vorrei installare i driver proprietari con il supporto per l'accelerazione 3D (premetto che posso usare solo la versione dei driver 8.28.8, come specificato sul sito della ATI).

Se semplicemente do:

emerge ati-drivers

logicamente portage mi scarica l'ultima versione (incompatibile con la mia scheda, la 8.35.2). Non sapendo allora di questo problema ho dato comunque l'emerge e, avendo al momento ancora il vecchio kernel 2.6.17, portage mi ha scaricato il 2.6.20-r8, che ho dovuto ricompilare (usando genkernel all) e che comunque all'avvio mi da qualche problema dicendomi di non risucire a trovare un dispositivo: "can't load module intel-rng" o una cosa simile. Comunque riavviando con il nuovo kernel ricompilato secondo le specifiche richieste dalla guida ufficiale e anche da altre guide, e poi dando di nuovo:

emerge ati-drivers (vi ricordo che al momento non sapevo che l'ultima versione dei driver fosse incompatibile con la mia ati 9000)

prima della fine mi viene dato questo errore:


!!! ERROR: x11-drivers/ati-drivers-8.32.5 failed.
Call stack:
ebuild.sh, line 1614: Called dyn_compile
ebuild.sh, line 971: Called qa_call 'src_compile'
environment, line 4108: Called src_compile
ati-drivers-8.32.5.ebuild, line 157: Called linux-mod_src_compile
linux-mod.eclass, line 516: Called die

!!! Unable to make GCC_VER_MAJ=4 KVER=2.6.20-gentoo-r8 KDIR=/usr/src/linux kmod_build.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.32.5/temp/build.log'.


Quindi ho rimunciato ad installarli con emerge.

Allora ho scaricato il pacchetto 8.28.8.run dal sito della ati e ho dato il comando per installarli e tutto è andato a buon fine; il 2D va alla grande, ma è impossibile installare l'accelerazione 3D.

La mia domanda è dunque questa, se uso il pacchetto .run installando senza emerge è possibile poi attivare l'accelerazione 3D?
Ho letto anche i vostri topic sul forum e qualcuno parla di modifiche al make.conf, come variabile d'ambiente cosa dovrei inserire come VIDEO_CARDS="R250"? e tale variabile (ammesso che funzioni) verrebbe unicamente riconosciuta usando esclusivamente emerge, giusto?

Potrei magari dare:

emerge =ati-drivers-8.28.8

se qualcuno mi sapesse aiutare o dirmi se il problema è risolvibile ve ne sarei molto grato, ho visto che qualcuno nel forum usa una ati 8500, mi sbaglio? Funziona il 3D?

grazie a tutti,
Riccardo


P.S.: con i driver open "radeon" tutto va alla grande, anche l'accelerazione 3D, installata configurando xorg.conf con xorgconfig e poi editando la restante parte di xorg.conf come specifica il manuale gentoo.
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Fri May 18, 2007 6:42 pm    Post subject: Reply with quote

Se tin funzionano i driver open... usa quelli... se invece non puoi proprio fare a meno dei driver della ATI puoi provare a mascherare le versioni successive alla versione che puoi utilizzare:

Crea il file /etc/portage/package.mask e usa una sintassi tipo : ">nome_categoria/nome_pacchetto-versione_che_funziona", il tutto senza virgolette.

Per avere maggiori info leggi la guida completa di gentoo che trovi sul forum, trovi risposte a questa e a molte altre domande simili.

Ciao!

Marco
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Fri May 18, 2007 7:24 pm    Post subject: Reply with quote

Ciao, come specificato il problema non è nel mascherare o meno le ultime versioni. Posso tranquillamente dare un emerge =numero versione driver.

Il problema è che vorrei sapere se qualcuno è riuscito a far andare con i driver closed il 3D anche su schede vecchie come una 9000. Non devo necessariamente usare emerge, visto che posso trovare l'installer sul sito ati. Volevo solo verificare che funzionassero i closed con il 3D. Ma a qaunto pare nessuna guida ufficiale gentoo o non ufficiale non risolve il problema.

ciao e grazie,
riccardo
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Fri May 18, 2007 7:48 pm    Post subject: Reply with quote

se tu dessi un emerge =etcetc... al prossimo upgrade di sistema il pacchetto verrebbe aggioranto alla corrente versione stabile.

Per il 3d con ATI io ho una 9600xt e al tempo mi pare di essere riuscito senza troppi problemi, adesso che uso solamente il portatile ho un Nvidia e quindi non so aiutarti. Sicuro di aver abilitato tutto nel kernel?

Poi scusa sei riuscito a installare i driver con portage o ci hai rinunciato? perche' dal tuo post non ho mica capito cosa hai fatto.
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Sat May 19, 2007 5:43 am    Post subject: Reply with quote

Avevo provato prima con portage, mi scaricava però l'ultima versione, la 8.35.2, mentre la mia scheda supporta solo la 8.28.8, cmq con portage non installava nulla perchè si bloccava a quell'errore che ho riportato nel post.

Ho provato quindi ad installare gli 8.28.8 scaricandoli dal sito ati, il 2D funziona, mentre il 3d no. Forse sbaglio qualcosa nel kernel, eppure ho seguito alla lettera tutte le abilitazioni/disabilitazioni da impostare. Non so come porte fare.
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Sat May 19, 2007 7:48 am    Post subject: Reply with quote

Io avevo installato con emerge i driver closed ATI per la mia 8500.
Andavano.
I driver erano gli ultimi disponibili (8.28.8). Avevo come kernel il 2.6.17 e non ricordo se xorg era 7.0 o 7.1... ora invece non riesco più ad installarli...
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Sat May 19, 2007 9:09 am    Post subject: Reply with quote

I closed ti andavano anche con il 3D sul 2.6.17?

Io riesco ad installare gli 8.28.8 sul 2.6.20, usando però l'installer della ati e non emerge, xorg è il 7.0, però va solo il 2d, mentre il 3d è lentissimo quindi non funziona a dovere.

Probabilmente c'è qualcosa che sbagliamo a configurare nel kernel, non saprei.... All'avvio in fase di probing mi dice infati anche:

can't load module intel-rng, non so se centra con il 3d, cmq mi riporta questo errore.
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Sat May 19, 2007 9:25 am    Post subject: Reply with quote

riccardo wrote:
I closed ti andavano anche con il 3D sul 2.6.17?

Io riesco ad installare gli 8.28.8 sul 2.6.20, usando però l'installer della ati e non emerge, xorg è il 7.0, però va solo il 2d, mentre il 3d è lentissimo quindi non funziona a dovere.

Probabilmente c'è qualcosa che sbagliamo a configurare nel kernel, non saprei.... All'avvio in fase di probing mi dice infati anche:

can't load module intel-rng, non so se centra con il 3d, cmq mi riporta questo errore.


Si andavano..e anche bene.
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Sat May 19, 2007 9:53 am    Post subject: Reply with quote

Per curiosità mi puoi velocemente spiegare come hai fatto ad installarli con emerge?

e le configurazioni che hai fatto dopo?

grazie,
Riccardo
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Sat May 19, 2007 10:19 am    Post subject: Reply with quote

Avevo seguito la guida sul wiki
Più o meno:
1) aggiunto nel make.conf fglrx alla voce relativa alle schede video,
2) ricompilato x11-server
3) lanciato il tool di configurazione per X11 di Ati
4) fatto l'eselect opengl
5) lanciato X

Poi ho provato glxinfo e dava Direct Rendering Yes e i fps erano circa 2.000... andava.

Io ne avrei ancora bisogno solo per avere l'uscita TV che con gli open non va, altrimenti gli open sarebbero fantastici (compreso compiz-beryl!)
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Mon May 21, 2007 3:22 pm    Post subject: Reply with quote

Grazie per la spiegazione, provo e ti faccio sapere.

Per i driver open intendi quelli da installare con xorgconfig vero?
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Mon May 21, 2007 5:26 pm    Post subject: Reply with quote

mi sembra di si...
Quelli nel kernel
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Mon May 21, 2007 8:09 pm    Post subject: Reply with quote

i driver all'interno del kernel sono solamente per il framebuffer, non centrano assolutamente niente con Xorg. quelli vengono compilati dinamicamente a seconda del valore di VIDEO_CARDS in make.conf
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Wed May 23, 2007 9:58 am    Post subject: Reply with quote

MeMyselfAndI wrote:
i driver all'interno del kernel sono solamente per il framebuffer, non centrano assolutamente niente con Xorg. quelli vengono compilati dinamicamente a seconda del valore di VIDEO_CARDS in make.conf

Sei sicuro?
Nella sezione Direct Rendering Manager?
Nelle guide dell'accelerazione 3D dicono che ci sono i driver nel kernel....
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Sat Jun 02, 2007 10:23 am    Post subject: Ati <9500 Reply with quote

Il problema piu' grosso per quelli che hanno schede ATI di versione inferiore alla 9500 è che possono usare fglrx fino alla 8.28.8, che sono compilati per funzionare con Xorg di versione <= 7.2 (come tutti gli fglrx fino alle 8.36.5 mi pare)
E chi come me ha una ATI 9000 come fa ad usare Xorg 7.3 con accelerazione decente?
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4486
Location: Somewere around the world

PostPosted: Sat Jun 02, 2007 11:24 am    Post subject: Reply with quote

Ma la ati 9000 non va perfettamente con i driver opensource in xorg?
Prova a legere "man radeon" oppure http://wiki.x.org/wiki/radeon per vedere se è supportata... io la vedo supportata. Mi pare abbia un chip r200 quindi cade nella sezione "perfettamente supportata"

Addirittura io ho una x600 (r300) e il 3d funziona (sebbene non perfettamente) semplicemente con il driver radeon.

Se hai compilato xorg con il supporto per il driver radeon (io ad esempio l'ho compilato con VIDEO_CARDS="fbdev radeon vesa vga") dovresti poter selezionare "radeon" come driver in xorg.conf.

Addirittura pare vada il tvout con una patch che potete trovare qui:
https://bugs.gentoo.org/show_bug.cgi?id=127642
Purtroppo pare non possa essere inclusa nel driver ufficiale per problemi di licenza (GPL vs MIT/X11)
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Sat Jun 02, 2007 3:14 pm    Post subject: Reply with quote

Ho appena configurato i drivers open "radeon" e in effetti l' accelerazione sembra andare bene (mi fa 2000 FPS netti)
Però se provo a giocare a Quake3 ad esempio, pur andando veloce, ci sono problemi nel rendering delle immagini (le pareti mi escono monocromatiche o trasparenti per intenderci), non so a cosa sia dovuto..
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Sun Jun 03, 2007 8:57 am    Post subject: Reply with quote

Appena trovo un po' di tempo dopo gli esami proverò la patch per l'uscita TV siccome è l'unica cosa che potrebbe rendere utili i driver closed...
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Sun Jun 03, 2007 2:26 pm    Post subject: Reply with quote

Mi correggo: ho notato che i problemi di rendering ci sono solo da utente, da root il rendering funziona benissimo..
suppongo quindi sia una questione di permessi (anche se mi sembra di averli impostati a dovere).

E in effetti glxinfo da utente mi da:

Quote:

blackout@gentoo ~ $ glxinfo | grep rendering
direct rendering: No


mentre da root:

Quote:

root@gentoo ~ $ glxinfo | grep rendering
direct rendering: Yes


Ma se non sbaglio i permessi per il dri si configurano in xorg.conf nella sezione:

Quote:

Section "DRI"
Mode 0666
EndSection


Qualcuno ha una dritta? Grazie..
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Mon Jun 04, 2007 3:25 pm    Post subject: Reply with quote

Forse è una cavolata:
io ho così:
Code:

Section "DRI"
     Group 0
    Mode 0666
EndSection

_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Jun 04, 2007 3:53 pm    Post subject: Reply with quote

Inoltre assicurati che il tuo utente appartenga al gruppo video (vedi qua per ulteriori riferimenti).
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Mon Jun 04, 2007 5:48 pm    Post subject: Reply with quote

Ho già provato con:
Code:

Section "DRI"
     Group 0
    Mode 0666
EndSection

Con:
Code:

Section "DRI"
    Mode 0666
EndSection

Con (aggiungendo il mio utente al gruppo video):
Code:

Section "DRI"
     Group "video"
    Mode 0660
EndSection

Ma nulla =.=
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Wed Jun 06, 2007 2:29 pm    Post subject: Reply with quote

Le ho provate tutte ma non sono ancora riuscito a far andare il rendering da utente.
Provo a pastare l'out di glxinfo da utente e da root, magari qualcuno si accorge di quelcosa..

Da utente:
Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 1x x86/MMX+/3DNow!+/SSE TCL
OpenGL version string: 1.3 Mesa 6.5.2
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow


Da root:
Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 1x x86/MMX+/3DNow!+/SSE TCL
OpenGL version string: 1.3 Mesa 6.5.2
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_equation_separate,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_APPLE_packed_pixels, GL_ATI_blend_equation_separate,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_ATI_fragment_shader, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_window_pos, GL_NV_blend_square,
    GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_OES_read_format, GL_SGI_color_matrix,
    GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow


La cosa che mi insospettisce di più dal diff è:
Code:

< client glx vendor string: ATI
< client glx version string: 1.3
---
> client glx vendor string: SGI
> client glx version string: 1.4


Come ho detto nel post precedente ho provato a impostare i permessi nella sezione DRI di xorg.conf, e anche a /dev/dri/card0 ma senza risultati..
Qualcuno riesce a capire il problema? Grazie..
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
blackout
n00b
n00b


Joined: 02 Jun 2007
Posts: 6

PostPosted: Wed Jun 06, 2007 9:27 pm    Post subject: Reply with quote

Credo di aver risolto..
In pratica prima di usare i drivers Radeon Open avevo gli fglrx. Prima di provare i drivers open li avevo disinstallati ma evidentemente qualcosa era rimasto. Per concludere ho risolto con qualcosa di concettualmente simile ad un: rm -f `locate fglrx`

Grazie comunque :)
_________________
"Sapere è potere" - http://sinapsi.no-ip.info
Back to top
View user's profile Send private message
riccardo
n00b
n00b


Joined: 18 May 2007
Posts: 25
Location: Italy

PostPosted: Thu Jun 07, 2007 12:35 pm    Post subject: Reply with quote

Allora ragazzi, le ho provate tutte! ma non c'è modo di installare il 3d.

Riesco a far girare il 3d con il kernel 2.6.17-r7 solo con gli open, mentre non gira assolutamente sul kernel 2.6.20-r8, ma forse sbaglio qualcosa nel settaggio pre-compilazione.

Con i driver closed, non c'è storia:

1) con emerge ati-drivers (ho mascherato i pacchetti dopo la release 8.28.8-r1) mi da questo errore, premetto che la flag VIDEO_CARDS="fglrx vga vesa radeon fbdev"

make[1]: *** [/var/tmp/portage/x11-drivers/ati-drivers-8.28.8-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.o] Error 1
make: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-8.28.8-r1/work/common/lib/modules/fglrx/build_mod] Error 2
make: Leaving directory `/usr/src/linux-2.6.20-gentoo-r8'
* DRM module not built
>>> Source compiled.
>>> Test phase [not enabled]: x11-drivers/ati-drivers-8.28.8-r1

>>> Install ati-drivers-8.28.8-r1 into /var/tmp/portage/x11-drivers/ati-drivers-8.28.8-r1/image/ category x11-drivers
* Installing fglrx module
install: impossibile fare stat di `fglrx.ko': No such file or directory

!!! ERROR: x11-drivers/ati-drivers-8.28.8-r1 failed.
Call stack:
ebuild.sh, line 1615: Called dyn_install
ebuild.sh, line 1061: Called qa_call 'src_install'
ebuild.sh, line 44: Called src_install
ati-drivers-8.28.8-r1.ebuild, line 210: Called linux-mod_src_install
linux-mod.eclass, line 546: Called die

!!! doins fglrx.ko failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.28.8-r1/temp/build.log'.

2) se provo ad installarli manualmente scaricando l'installer dal sito della ati, mi dice:

Detected configuration:
Architecture: i686 (32-bit)
X Server: Xorg 7.2.0

Detected version of X does not have a matching 'x720' directory
You may override the detected version using the following syntax:
X_VERSION=<xdir> ./ati-driver-installer-<ver>-<arch>.run [--install]

The following values may be used for <xdir>:
x430 XFree86 4.3.x
x430_64a XFree86 4.3.x 64-bit
x680 X.Org 6.8.x
x680_64a X.Org 6.8.x 64-bit
x690 X.Org 6.9.x
x690_64a X.Org 6.9.x 64-bit
x700 X.Org 7.0.x
x700_64a X.Org 7.0.x 64-bit
x710 Unknown X Window
x710_64a Unknown X Window
Removing temporary directory: fglrx-install



A questo punto non so più cosa fare, mi terrò il 3d con un kernel 2.6.17-r7? Questo kernel è stato installato dal live cd della 2006.1, il kernel successivo il 2.6.20-r8 come vi dicevo non fa funzionare il rendering 3d, ma, vi ripeto, forse sbaglio qualcosa io in fase di configurazione.

Sapete darmi qualche altro aiuto, se non il suggerimento di cambiare scheda :-) ?

Riccardo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum