Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gentoo] Problème startx (pas résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
thana
n00b
n00b


Joined: 14 May 2007
Posts: 8

PostPosted: Mon May 14, 2007 11:54 am    Post subject: [Gentoo] Problème startx (pas résolu) Reply with quote

Bonjour,
je dispose d'un serveur dédié gentoo chez ovh depuis peu et j'aimerai installer une interface graphique afin d'effectuer une export display.
Pour cela j'ai donc voulu installer xorg-x11 grace à emerge xorg-x11 (un truc de ce genre...).
Apres coup j'ai voulu lancer un startx et j'ai obtenu ce message d'erreur :

Code:
xauth:  creating new authority file /root/.serverauth.3688


X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: Linux 2.4.33grs-bipiv-ipv4-32 i686
Current Operating System: Linux ns22361.ovh.net 2.4.33grs-bipiv-ipv4-32 #1 SMP lun oct 23 19:00:07 CEST 2006 i686
Build Date: 14 May 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 14 13:49:26 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) I810(0): No Video BIOS modes for chosen depth.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

Quel serait le moyen pour régler ce problème ?

Merci de vos conseils.


Last edited by thana on Tue May 15, 2007 4:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Mon May 14, 2007 12:17 pm    Post subject: Reply with quote

Bonjour,

Tu as configuré ton xorg ?

Il y a quelques indications dans la documentation.

Sinon ton titre n'est pas bon, peux tu le modifier comme indiqué dans ce sujet ?

Bon courage.
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Mon May 14, 2007 12:20 pm    Post subject: Reply with quote

salut,

Code:

(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) I810(0): No Video BIOS modes for chosen depth.


a priori , il te manque le support de l'agp dans le kernel:
Code:

$ zgrep AGP /proc/config.gz
CONFIG_AGP=y


mais j'ai lu pas mal de posts de personnes ayant des soucis avec le driver i810, dans l'ordre il te faudrait :
- verifier le kernel
- verifier que udev tourne comme il faut ( le contraire m'etonnerait mais on ne sait jamais )
- utiliser vesa comme driver en attendant ;)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8501
Location: ~Brussels - Belgique

PostPosted: Mon May 14, 2007 12:21 pm    Post subject: Reply with quote

bonjour,

Si j'ai bien compris, tu veux installer X sur un serveur distant afin de pouvoir lancer des applications X sur ton PC ?

Dans ce cas, pas besoin de faire startx sur le serveur, mettre DISPLAY à jour suffit (et pas nécessaire si ssh/sshd sont configurés pour faire du forward de paquets X11)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
thana
n00b
n00b


Joined: 14 May 2007
Posts: 8

PostPosted: Mon May 14, 2007 8:24 pm    Post subject: Reply with quote

XavierMiller wrote:
bonjour,

Si j'ai bien compris, tu veux installer X sur un serveur distant afin de pouvoir lancer des applications X sur ton PC ?

Dans ce cas, pas besoin de faire startx sur le serveur, mettre DISPLAY à jour suffit (et pas nécessaire si ssh/sshd sont configurés pour faire du forward de paquets X11)


Pourrais-tu expliquer comment faire pour mettre a jour DISPLAY ? je débute totalement dans le monde unix....
merci d'avance.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon May 14, 2007 10:10 pm    Post subject: Reply with quote

Salut, comme te l'as demandé _droop_, peut-tu mettre ton titre en conformité avec nos conventions stp ? (cf. ma signature ;))

Pour le DISPLAY, tu fais un simple export DISPLAY=ip:0 et ensuite tu lance tes applis graphiques. Ou alors tout simplement, tu fait un ssh -X ton_serveur qui va créer un tunnel X11 dans ta connexion SSH, et définir DISPLAY comme il faut (à condition que le ssh distant soit compilé avec le use X)
Back to top
View user's profile Send private message
thana
n00b
n00b


Joined: 14 May 2007
Posts: 8

PostPosted: Tue May 15, 2007 4:36 pm    Post subject: Reply with quote

un export DISPLAY=ip:0 ne fait rien du tout ... comment faire?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue May 15, 2007 4:59 pm    Post subject: Reply with quote

thana wrote:
un export DISPLAY=ip:0 ne fait rien du tout ... comment faire?

Remplace ip par l'ip de ta machine ... :roll:
Back to top
View user's profile Send private message
thana
n00b
n00b


Joined: 14 May 2007
Posts: 8

PostPosted: Tue May 15, 2007 5:00 pm    Post subject: Reply with quote

biensure, c'est ce que j'avais fais ... et donc ca ne fait strictement rien.
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Tue May 15, 2007 5:02 pm    Post subject: Reply with quote

Tu as peut être quelque chose de mal configuré.

Regardes par exemple ce how-to pour le forward X.
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue May 15, 2007 5:07 pm    Post subject: Reply with quote

Est ce si facile d'installer un serveur X sur les serveur OVH?
On a fréquemment vu passé des problèmes avec les serveur OVH, aux configurations apparemment complètement alambiquées...
Enfin bref, pas évident de débuter avec ça :/
Bonne chance...
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Tue May 15, 2007 5:14 pm    Post subject: Reply with quote

Temet wrote:
Est ce si facile d'installer un serveur X sur les serveur OVH?
On a fréquemment vu passé des problèmes avec les serveur OVH, aux configurations apparemment complètement alambiquées...
Enfin bref, pas évident de débuter avec ça :/
Bonne chance...


A priori tu n'as pas besoin du serveur. Les lib X sont suffisantes pour faire du forward.

Le startx est complètement inutile dans ce cas. A moins que ovh t'autorise à aller dans la salle serveur, brancher un écran...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8501
Location: ~Brussels - Belgique

PostPosted: Wed May 16, 2007 7:06 am    Post subject: Reply with quote

stp, ne mets pas de "(pas résolu)" dans le titre, mais plutôt "(en cours)"...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum