Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Java plugin for Mozilla and Seamonkey
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
vega
n00b
n00b


Joined: 01 Mar 2004
Posts: 73
Location: Vitoria - ES - Brasil

PostPosted: Fri May 11, 2007 8:13 pm    Post subject: No Java plugin for Mozilla and Seamonkey Reply with quote

Hi all!

See how strange this is, I already have "mozilla nsplugin" in my USE flags in /etc/make.conf
but even if I explicitly use USE="nsplugin mozilla" the flag is ignored:
Code:
homedir ~ # USE="nsplugin mozilla" emerge -pv dev-java/blackdown-jdk dev-java/blackdown-jre

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-java/blackdown-jdk-1.4.2.03-r12  USE="-doc (-nsplugin)" 0 kB
[ebuild   R   ] dev-java/blackdown-jre-1.4.2.03-r13  USE="(-nsplugin)" 0 kB
Any clues?
_________________
emerge -D freedom
Back to top
View user's profile Send private message
OnlyTux
Apprentice
Apprentice


Joined: 15 Mar 2007
Posts: 174

PostPosted: Fri May 11, 2007 11:32 pm    Post subject: Reply with quote

The problem is that the nsplugin flag was masked, due to great instability of the blackdown java environment.

You must unmask the flag by creating/editing the /etc/portage/package.use and put the following line:
Code:
=dev-java/blackdown-jre-1.4.2.03-r13 nsplugin


The blackdown-jdk is not required unless you are a java developer (in this case you should absolutely install the sun-java environment, though).

Note that the 2.0.0.3 version of Firefox is unusable with the blackdown plugin, whereas the 2.0.0.2 version (that should still be available in portage) worked fine for me. But java gives me no problems with Konqueror.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat May 12, 2007 3:02 am    Post subject: Reply with quote

Moved from Installing Gentoo to Portage & Programming.

You aren't on amd64 are you?
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7817

PostPosted: Sat May 12, 2007 6:41 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, as this was already discussed in the topic "nsplugin use flag being ignored".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum