Joined: 12 May 2004
|Posted: Thu May 10, 2007 7:26 pm Post subject: [ GLSA 200705-12 ] PostgreSQL: Privilege escalation
|Gentoo Linux Security Advisory
Title: PostgreSQL: Privilege escalation (GLSA 200705-12)
Date: May 10, 2007
Updated: May 28, 2009
PostgreSQL contains a vulnerability that could result in SQL privilege escalation.
PostgreSQL is an open source object-relational database management system.
Vulnerable: < 8.0.13
Unaffected: >= 8.0.13
Unaffected: >= 7.4.17 < 7.4.18
Unaffected: >= 7.3.19 < 7.3.20
Unaffected: >= 7.3.21 < 7.3.22
Unaffected: >= 7.4.19 < 7.4.20
Architectures: All supported architectures
An error involving insecure search_path settings in the SECURITY DEFINER functions has been reported in PostgreSQL.
If allowed to call a SECURITY DEFINER function, an attacker could gain the SQL privileges of the owner of the called function.
There is no known workaround at this time.
All PostgreSQL users should upgrade to the latest version and fix their SECURITY DEFINER functions:
In order to fix the SECURITY DEFINER functions, PostgreSQL users are advised to refer to the PostgreSQL documentation: http://www.postgresql.org/docs/techdocs.77
|# emerge --sync
# emerge --ask --oneshot --verbose "dev-db/postgresql"
Last edited by GLSA on Fri May 29, 2009 4:17 am; edited 1 time in total