Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] kdm won't start after xorg update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
GeKA
n00b
n00b


Joined: 27 Sep 2002
Posts: 33
Location: Graz / Styria

PostPosted: Thu Mar 15, 2007 8:51 am    Post subject: [solved] kdm won't start after xorg update Reply with quote

Hello!

Three days ago I updated to xorg 7.2. After the update kdm won't start automatically. The following error message apears:

Quote:
setting up kdm...
start-stop-daemon: option '--exec' requires an argument.


When I log in as root and start kdm manually it works. I tried to reemerge kdm, but that didn't help. Anyone an idea what to do?

thanks


Last edited by GeKA on Tue Mar 20, 2007 8:27 am; edited 1 time in total
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Mar 15, 2007 9:12 am    Post subject: Reply with quote

you have to login as user

then go to
Code:

nano -w ~/.xinitrc


and add

Code:
exec startkde



8)
Back to top
View user's profile Send private message
cvk
Guru
Guru


Joined: 06 Jan 2003
Posts: 314
Location: Our house, in the middle of our street

PostPosted: Thu Mar 15, 2007 9:24 am    Post subject: Reply with quote

Just a bunch of ideas:

Is xdm started at default runlevel?
Code:
rc-update show


Is DISPLAYMANAGER="kdm" set in conf.d/xdm?
Code:
cat /etc/conf.d/xdm


Is the following line in /etc/inittab?
Code:
x:a:once:/etc/X11/startDM.sh

_________________
Adopt an unanswered post now.
Back to top
View user's profile Send private message
GeKA
n00b
n00b


Joined: 27 Sep 2002
Posts: 33
Location: Graz / Styria

PostPosted: Thu Mar 15, 2007 4:45 pm    Post subject: Reply with quote

Hwoarang wrote:
you have to login as user
then go to
Code:
nano -w ~/.xinitrc
and add
Code:
exec startkde


This line is already in .xinitrc

cvk wrote:
Just a bunch of ideas:

Is xdm started at default runlevel?
Code:
rc-update show



Yes

Quote:

Is DISPLAYMANAGER="kdm" set in conf.d/xdm?
Code:
cat /etc/conf.d/xdm



There was "xdm", so I changed to "kdm" but it didn't help.

Quote:
Is the following line in /etc/inittab?
Code:
x:a:once:/etc/X11/startDM.sh


yes it is.

Thank you for your help.

Any[/quote] other ideas?
Back to top
View user's profile Send private message
sinate
n00b
n00b


Joined: 16 Apr 2003
Posts: 29
Location: Southampton, UK

PostPosted: Sun Mar 18, 2007 8:08 am    Post subject: Reply with quote

Hi GeKA,

I've still got the same problem you had. How did you solve it? It's driving me mad.

Thanks.
Back to top
View user's profile Send private message
GeKA
n00b
n00b


Joined: 27 Sep 2002
Posts: 33
Location: Graz / Styria

PostPosted: Mon Mar 19, 2007 9:25 am    Post subject: Reply with quote

Hi!

I haven't found a solution yet.
Back to top
View user's profile Send private message
butchie
n00b
n00b


Joined: 13 Oct 2004
Posts: 48

PostPosted: Mon Mar 19, 2007 1:18 pm    Post subject: Reply with quote

Almost same problem here, after xorg update:
Quote:
/etc/init.d/xdm start
which: no kdm in (/bin:/sbin:/usr/bin:/usr/sbin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.1:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin)
* Setting up xdm ...
/sbin/start-stop-daemon: stat /usr/bin/xdm: No such file or directory (No such file or directory)
* ERROR: could not start the Display Manager...
xdm: aucun processus tué

/etc/rc.conf, /etc/conf.d/xdm and inittab looks fine
but kdm doesn't start from /etc/init.d/xdm ... :(
Fortunately, startx works fine ;-)
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Mon Mar 19, 2007 6:48 pm    Post subject: Re: kdm won't start after xorg update Reply with quote

GeKA wrote:
Hello!

Three days ago I updated to xorg 7.2. After the update kdm won't start automatically. The following error message apears:

Quote:
setting up kdm...
start-stop-daemon: option '--exec' requires an argument.


When I log in as root and start kdm manually it works. I tried to reemerge kdm, but that didn't help. Anyone an idea what to do?

thanks


why dont you try to go back to Stable 7.1? :)
Back to top
View user's profile Send private message
tat2drod
n00b
n00b


Joined: 24 Nov 2004
Posts: 8
Location: NL

PostPosted: Mon Mar 19, 2007 9:17 pm    Post subject: Re: kdm won't start after xorg update Reply with quote

GeKA wrote:
Hello!

Three days ago I updated to xorg 7.2. After the update kdm won't start automatically. The following error message apears:

Quote:
setting up kdm...
start-stop-daemon: option '--exec' requires an argument.


When I log in as root and start kdm manually it works. I tried to reemerge kdm, but that didn't help. Anyone an idea what to do?

thanks


I'm at 7.1 and I get the same problem - doesn't matter if I try xdm or gdm.

--
Rod
Back to top
View user's profile Send private message
tat2drod
n00b
n00b


Joined: 24 Nov 2004
Posts: 8
Location: NL

PostPosted: Mon Mar 19, 2007 9:35 pm    Post subject: Re: kdm won't start after xorg update Reply with quote

tat2drod wrote:
I'm at 7.1 and I get the same problem - doesn't matter if I try xdm or gdm.


Ok, a quick shufty at /etc/X11/startDM.sh shows that EXEC and NAME aren't being set. If I set them so:
Code:
EXEC="/usr/sbin/gdm"
NAME="gdm"

then that gets me gdm at startup.

YMMV. Use at your own risk as I have absolutely no idea what the consequences of this hack are!

--
Rod
Back to top
View user's profile Send private message
GeKA
n00b
n00b


Joined: 27 Sep 2002
Posts: 33
Location: Graz / Styria

PostPosted: Tue Mar 20, 2007 8:30 am    Post subject: Reply with quote

Thanks, that solved the problem for me also.

As far, as I'm not an expert, could it be, that this problem is caused by the nvidia-driver? Because now I got the nvidia logo when X starts, which didn't come before.
Back to top
View user's profile Send private message
tat2drod
n00b
n00b


Joined: 24 Nov 2004
Posts: 8
Location: NL

PostPosted: Wed Mar 21, 2007 4:02 pm    Post subject: Reply with quote

GeKA wrote:
Thanks, that solved the problem for me also.

As far, as I'm not an expert, could it be, that this problem is caused by the nvidia-driver? Because now I got the nvidia logo when X starts, which didn't come before.


You're welcome and I have no idea! I don't see anything with nvidia so... make of that what you will.

Now, if I can only work out why shutdown -h now actually reboots my machine instead of shutting it down...

--
Rod
Back to top
View user's profile Send private message
tfbb
n00b
n00b


Joined: 18 Sep 2005
Posts: 25

PostPosted: Fri May 11, 2007 2:45 pm    Post subject: Re: kdm won't start after xorg update Reply with quote

hi,

tat2drod wrote:
Code:
EXEC="/usr/sbin/gdm"
NAME="gdm"

then that gets me gdm at startup.


thank you.

i also had to do this, and yeah - it doesn't feel right somehow. i will probably have forgotten about this in a week and run into all sorts of other problems :roll:
do you have any idea where the values of these variales are supposed to come from? i tried to put the compat-stuff after the "export SVCNAME=your-login-manager", but that didn't help ... so i guess /lib/rcsripts/sh/rc-services.sh is not to blame. then again, what could be the culprit?

with kind regards,
thoralf.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum