Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Si blocca su schermata a pixel colorati casuali [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
HoX
Guru
Guru


Joined: 11 Nov 2006
Posts: 385

PostPosted: Sun May 06, 2007 7:20 pm    Post subject: Si blocca su schermata a pixel colorati casuali [RISOLTO] Reply with quote

Ho appena preso il portatile e sto cercando di installare Gentoo 2006.1 con kernel 2.6.20-gentoo-r7.
L'avvio da LiveCD non ha dato problemi e l'installazione è riuscita tranquillamente.
Ho compilato il kernel a mano, ma quando riavvio non riesco ad avviare nulla.
Infatti se eseguo (riporto da grub.conf)
Code:
title=Gentoo Linux 2.6.20
root (hd0,0)
kernel /boot/kernel-2.6.20-gentoo-r7 root=/dev/sda1 vga=0x318 video=vesafb:mtrr,ywrap
boot

lo schermo rimane buio subito dopo aver avviato il sistema operativo.
se eseguo
Code:
title=Gentoo Linux 2.6.20 noFB
root (hd0,0)
kernel /boot/kernel-2.6.20-gentoo-r7 root=/dev/sda1
boot

lo schermo passa qualche scritta veloce (che non riesco a interpretare né stoppare) e poi si blocca su una schermata con pixel e righe colorati apparentemente casuali. La stessa cosa succede con
Code:
title=Gentoo Linux 2.6.20 (rescue)
root (hd0,0)
kernel /boot/kernel-2.6.20-gentoo-r7 root=/dev/sda1 init=/bin/bb
boot


secondo voi, quale può essere l'errore? Esiste un qualche log in cui andare a guardare tramite LiveCD?

NB: utilizzo un Intel Core 2 Duo con architettura x86_64[/code]


Last edited by HoX on Sun May 06, 2007 8:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
HoX
Guru
Guru


Joined: 11 Nov 2006
Posts: 385

PostPosted: Sun May 06, 2007 8:31 pm    Post subject: Reply with quote

Ho risolto da me... il problema era nella configurazione del kernel... infatti dopo aver usato genkernel non ho più avuto problemi. inoltre ho scoperto che le partizione sda* (come erano chiamate dal LiveCD) sono diventate hda* e quindi ho dovuto modificare le impostazioni in grub.conf e in fstab
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum