Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SATA-ICH8] optimisation et performances (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun May 06, 2007 10:02 am    Post subject: [SATA-ICH8] optimisation et performances (résolu) Reply with quote

J'ai un comportement très désagréable avec mon disque SATA-II (un samsung 400Go).
Notez que je suis en libata intégrale.

Tout semble tourner assez rapidement (lancement d'application etc...). J'ai:
Code:

# hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   2422 MB in  2.00 seconds = 1210.57 MB/sec
 Timing buffered disk reads:  162 MB in  3.04 seconds =  53.29 MB/sec

Ça me semble "correct", mais sans plus.

Je sais que le sata d'utilise pas le DMA mais j'ai cette ligne dans hdparm -iI /dev/sda :
Code:

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 udma7

Il ne semble pas utiliser le mode le plus optimisé. Et au travers d'hdparm bien entendu je n'ai aucun moyen de configurer ça.

Le comportement étrange que j'ai c'est lors de la copie disque à disque (par exemple d'un disque USB vers mon disque SATA). La copie avance rapidement (usb-2 oblige), mais par contre je n'ai plus aucune réactivité de mon disque dès que je souhaite lancer une application durant la copie par exemple. (ne serait-ce qu'une pauvre commande "eix" par exemple). C'est comme si le transfert accapparait le disque... C'est **TRÈS** agacant. (je pèse mes mots)

Une idée? :|
_________________
membre officieux du SAV Ati GEntoo


Last edited by kwenspc on Tue May 08, 2007 5:30 am; edited 1 time in total
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Sun May 06, 2007 10:09 am    Post subject: Re: [SATA-ICH8] optimisation et performances Reply with quote

kwenspc wrote:
J'ai un comportement très désagréable avec mon disque SATA-II (un samsung 400Go).
Notez que je suis en libata intégrale.

Tout semble tourner assez rapidement (lancement d'application etc...). J'ai:
Code:

# hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   2422 MB in  2.00 seconds = 1210.57 MB/sec
 Timing buffered disk reads:  162 MB in  3.04 seconds =  53.29 MB/sec

Ça me semble "correct", mais sans plus.

Je sais que le sata d'utilise pas le DMA mais j'ai cette ligne dans hdparm -iI /dev/sda :
Code:

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 udma7

Il ne semble pas utiliser le mode le plus optimisé. Et au travers d'hdparm bien entendu je n'ai aucun moyen de configurer ça.

Le comportement étrange que j'ai c'est lors de la copie disque à disque (par exemple d'un disque USB vers mon disque SATA). La copie avance rapidement (usb-2 oblige), mais par contre je n'ai plus aucune réactivité de mon disque dès que je souhaite lancer une application durant la copie par exemple. (ne serait-ce qu'une pauvre commande "eix" par exemple). C'est comme si le transfert accapparait le disque... C'est **TRÈS** agacant. (je pèse mes mots)

Une idée? :|


+1 j'ai le même soucis

[OFF]

Kwenspc = je l'ais achetée ca y est c2duo et p5b Deluxe avec 4 sata en raid0 :p j'attend le boitier avec impatience

[/OFF]
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun May 06, 2007 10:12 am    Post subject: Reply with quote

Oh une idée! Je suis en CFQ pour le I/O scheduler, je vais essayer les autres et je vous tiens au courant
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun May 06, 2007 11:05 am    Post subject: Reply with quote

Ça n'a pas l'air de changer quoique ce soit. J'en ai profiter pour passer au noyau 2.6.20 (j'étais en 2.6.19). Cette fois j'intègre tous les IO Scheduler et je tnterais de manipuler l'option au boot "iosched".

[edit]
Là je sèche. Rien à faire.
Le hdparm -tT /dev/sda me donne ça : Timing buffered disk reads: 8 MB in 3.39 seconds = 2.36 MB/sec durant la copie USB -> disque. Preuve qu'il est tout occuppé à gérer la copie et pour le reste on a droit aux miettes. :?
[/edit]
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Sun May 06, 2007 1:41 pm    Post subject: Reply with quote

kwenspc wrote:
Ça n'a pas l'air de changer quoique ce soit. J'en ai profiter pour passer au noyau 2.6.20 (j'étais en 2.6.19). Cette fois j'intègre tous les IO Scheduler et je tnterais de manipuler l'option au boot "iosched".

[edit]
Là je sèche. Rien à faire.
Le hdparm -tT /dev/sda me donne ça : Timing buffered disk reads: 8 MB in 3.39 seconds = 2.36 MB/sec durant la copie USB -> disque. Preuve qu'il est tout occuppé à gérer la copie et pour le reste on a droit aux miettes. :?
[/edit]


Justement ca ne serais pas l'usb qui bouffe tout le cpu ? .. au point d'écrouler les perfs

Que donne un ps à ce moment la ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun May 06, 2007 2:24 pm    Post subject: Reply with quote

Ben justement non, le cpu est à peine utilisé, et encore: 1 cpu sur les deux. Je me suis en effet posé la question mais ça ne semble pas être ça. Pour moi c'est à mon avis un support de l'ICH8 pas encore au point.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Sun May 06, 2007 3:21 pm    Post subject: Reply with quote

Dès que je récupère un ide viable je testerais en usb ... vu que l'on as quasimment la même configuration ..
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun May 06, 2007 4:41 pm    Post subject: Reply with quote

Erf je crois que tout ça vient en grosse partie de nautilus 8O
Déjà en faisant un cp en terminal le disque usb a l'air de bosser plus et le transfert et a priori plus rapide... Mais au moins je peux charger de nouvelles applis en beaucoup moins de temps durant le transfert. Bon Nautilus déjà -> poubelle.
_________________
membre officieux du SAV Ati GEntoo


Last edited by kwenspc on Mon May 07, 2007 9:08 am; edited 1 time in total
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Mon May 07, 2007 8:40 am    Post subject: Reply with quote

kwenspc wrote:
Erf je crois que tout ça vient en grosse partie de nautilus 8O
Déjà en faisant un cp en terminal le disque usb a l'air de bosser plus et le transfert et a priori plus rapide... Mais au moins je peus charger de nouvelles applis en beaucoup moins de temps durant le transfert. Bon Nautilus déjà -> poubelle.


Tes partitions sont en extX ou en Xfs ?
Il y avait un vieux bug avec xfs, je ne sais pas si il est résolu maintenant
Chez moi (full ext3), il se met à ramer plus que la normale lorsque je lance plusieurs copies en même temps, le reste du temps les taux de transfert sont normaux
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Mon May 07, 2007 8:51 am    Post subject: Reply with quote

kwenspc wrote:
Erf je crois que tout ça vient en grosse partie de nautilus 8O
Déjà en faisant un cp en terminal le disque usb a l'air de bosser plus et le transfert et a priori plus rapide... Mais au moins je peus charger de nouvelles applis en beaucoup moins de temps durant le transfert. Bon Nautilus déjà -> poubelle.


Je vais te traquer jusqu'à ce que tu arrêtes de porter atteinte à ma rétine!!! :twisted: :twisted:
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon May 07, 2007 9:10 am    Post subject: Reply with quote

razer wrote:

Tes partitions sont en extX ou en Xfs ?
Il y avait un vieux bug avec xfs, je ne sais pas si il est résolu maintenant
Chez moi (full ext3), il se met à ramer plus que la normale lorsque je lance plusieurs copies en même temps, le reste du temps les taux de transfert sont normaux

XFS en effet. J'ai bel et bien ce soucis qu'avec nautilus. Dans une console ça fonctionne nickel (et 1 des 2 cpus est utilisé à 50% dans ce cas là)

@Temet: corrigé, promis je vais essayer de rendre ta traque plus difficile.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
zyprexa
Apprentice
Apprentice


Joined: 26 Dec 2004
Posts: 180

PostPosted: Mon May 07, 2007 11:05 am    Post subject: Re: [SATA-ICH8] optimisation et performances Reply with quote

kwenspc wrote:
J'ai un comportement très désagréable avec mon disque SATA-II (un samsung 400Go).
Notez que je suis en libata intégrale.

Tout semble tourner assez rapidement (lancement d'application etc...). J'ai:
Code:

# hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   2422 MB in  2.00 seconds = 1210.57 MB/sec
 Timing buffered disk reads:  162 MB in  3.04 seconds =  53.29 MB/sec

Ça me semble "correct", mais sans plus.

Je sais que le sata d'utilise pas le DMA mais j'ai cette ligne dans hdparm -iI /dev/sda :
Code:

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 udma7

Il ne semble pas utiliser le mode le plus optimisé. Et au travers d'hdparm bien entendu je n'ai aucun moyen de configurer ça.

Le comportement étrange que j'ai c'est lors de la copie disque à disque (par exemple d'un disque USB vers mon disque SATA). La copie avance rapidement (usb-2 oblige), mais par contre je n'ai plus aucune réactivité de mon disque dès que je souhaite lancer une application durant la copie par exemple. (ne serait-ce qu'une pauvre commande "eix" par exemple). C'est comme si le transfert accapparait le disque... C'est **TRÈS** agacant. (je pèse mes mots)

Une idée? :|


J'avais testé également .. . Le nouveau nommage est un peu gonflant (surtout quand on est déjà bien habitué à l'ancien évidemment). En ce qui concerne hdparm, sdparm marche pas, mais j'ai lu quelque part qu'une version patchée de hdparm pouvait se trouver. Un freeze a achevé de me convaincre de revenir à l'ancien système qui fonctionne très bien.
_________________
enjoy
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Mon May 07, 2007 9:59 pm    Post subject: Reply with quote

Il y a un bug dans Gnome 2.16 qui rend les transferts XFS très très lent via Nautilus.
C'est corrigé dans Gnome 2.18.
Le bug report ici.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 08, 2007 5:30 am    Post subject: Reply with quote

OK merci, résolu donc.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum