Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ajuda com Bootloader Grub
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Debian-user
n00b
n00b


Joined: 06 May 2007
Posts: 5

PostPosted: Sun May 06, 2007 12:43 am    Post subject: Ajuda com Bootloader Grub Reply with quote

Depois de muito ver vários amigos migrarem e falarem muito bem do Gentoo, resolvi migrar para o Gentoo.
Ta depois de seguir o handbook modded que um amigo me passo neste link http://omnis.if.ufrj.br/~viniciusferrao/gentoo/gentoo.txt

tambem com algumas dicas do handbook do jackass project, depois de muito bater a cabeça consegui instalar a bagaça, muito bom, realmente de adequa ao seu próprio micro, muito massa só tenho 3 duvidas que não me deixam finalizar com chave de ouro e queria saber se vcs aqui da comunidade podem me ajudar:

1ª - tenho 2 hd´s dentro da máquina um sata que tem sda1(windows ntfs) e sda5(fat32 arquivos diversos) e outro ide que tem somente hdc1(filmes e animes ntfs) e neste mesmo hd montei as partições do gentoo sendo hdc2 (boot) , hdc3 (swap) e hdc4 /, na bios setei pro hd ide ficar por primeiro (antes era o sata com o windows), não to conseguindo fazer o grub bootar nem a pau, as vezes fica parado piscando o | outras modificações da erro 15 ta assim o grub.conf:

# Boot automatically after 30 secs.
timeout 30

# By default, boot the second entry.
default 1

# Fallback to the first entry.
fallback 0

# Use default Grub Splash image
splashimage=(hd1,1)/grub/splash.xpm.gz

# Boot Gentoo Linux (no framebuffer)
title Gentoo-2.6.15-r7
root (hd1,1)
kernel (hd1,1)/vmlinuz ro root=/dev/hda4 video=vesafb:ywrap,pmipal,1024x768-16@75

# Boot Gentoo Linux at 1024x768 framebuffer resolution
title Gentoo-2.6.15-r7, 1024x768
root (hd1,1)
kernel (hd1,1)/vmlinuz ro root=/dev/hda4 video=vesafb:ywrap,pmipal,1024x768-24@75 splash=silent,fadein,theme:emergence CONSOLE=/dev/tty1
initrd (hd1,1)/fbsplash-emergence-1024x768

# Boot Gentoo Linux at 1280x1024 framebuffer resolution
title Gentoo-2.6.15-r7, 1280x1024
root (hd1,1)
kernel (hd1,1)/vmlinuz ro root=/dev/hda4 video=vesafb:ywrap,pmipal,1280x1024-24@60 splash=silent,fadein,theme:emergence CONSOLE=/dev/tty1
initrd (hd1,1)/fbsplash-emergence-1280x1024

insto agora, mas ja tentei (hd0,1) (hd2,1) varias combinações, enfim to perdido, alguem pode me da uma luz de como configurar o grub e instalar na mbr do hd ide e não no sata??

2ª toda vez q to tentando instala algo grande q demora pra compila, por exemplo o kde, alguns pacotes com 25 a 30mb, o resolv.conf perde a configuração, que é dhcp, dai sempre tenho q edita e coloca os dns, o que pode ser?

agradeço se alguem me ajudar
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Mon May 07, 2007 6:15 pm    Post subject: Reply with quote

Boas,

Eu não sou grande perito no grub sempre confundo com a contagem dos discos e partições :oops: :oops:

Mas acho que no seu caso e comparando com o meu grub.conf devia ser algo de género :

Quote:

splashimage=(hd2,1)/grub/splash.xpm.gz /// Acho que seu splash.xpm.gz deve estar no /boot certo ????

# Boot Gentoo Linux (no framebuffer)
title Gentoo-2.6.15-r7
root (hd2,1)
kernel (hd2,1)/vmlinuz ro root=/dev/hdc4 video=vesafb:ywrap,pmipal,1024x768-16@75

Quote:

initrd (hd2,1)/boot/fbsplash-emergence-1024x768 ///Acho que seu fbsplash-emergence-1024x768 tambem deve estar no /boot certo ????



Pode ver a BOLD as alterações que fiz depois e só replicar para as outras opções ......

No disco deve começar a contar no 0 ou seja hda=0 hdb=1 hdc=2 hdd=3

E nas partições deve ser o mesmo ou seja hdc1=0 hdc2=1 hdc3=2 hdc4=3

Logo seu caso com [hdc2 (boot) , hdc3 (swap) e hdc4 /] :

hdc2 = (hd2,1)
hdc3 = (hd2,2)
hdc4 = (hd2,3)

Espero que não me esteja a enganar ....

Mas para ter a certeza de um boot com o live cd e confirma com cfdisk como e que fica identificado o disco e as partições no mesmo ...

No meu caso tenho
hda1 = NTFS ( Windows XP )
hda2 = FAT32 ( Windows 98 )
hda3 = SWAP
hda5 = /boot
hda6 = /

E tenho o grub assim :

Code:

# Splash image to show behind grub.
splashimage=(hd0,4)/boot/grub/splash.xpm.gz

# For booting Gentoo
title  Gentoo Linux 2.6 Kernel
root (hd0,4)
kernel /boot/kernel-2.6.20-gentoo-r7 root=/dev/hda6 apm=on acpi=on video=vesafb:mtrr:3,ywrap,800x600-16@75 splash=verbose,fadein,theme:gentoo console=tty1
readonly
initrd (hd0,4)/boot/fbsplash-gentoo-800x600

_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Debian-user
n00b
n00b


Joined: 06 May 2007
Posts: 5

PostPosted: Tue May 08, 2007 12:50 am    Post subject: Reply with quote

Boas

Funciono colega obrigado

mas apareceu outro problema, agora toda opção do boot cada vez q começa a arrancar depois de 2 segundos a tela toda fica escura, mas escura que so consigo ver a parte em branco e mesmo assim somente na parte de baixo do monitor, isso tem haver com framebuffer não, no kernel ta ativado o suporte a fb, o que poderia ser?
_________________
Athlon 64 X2 4200
4x 512 Kingston PC3200
Nvidia 7900GT PCI-E 256/256
Asus A8N SLI SE
SEAGATE BARRACUDA SATA 160GB 7200 RPMS
SAMSUNG IDE 160GB 7200 RPMS
MAXTOR IDE 20GB 5800 RPMS
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue May 08, 2007 8:35 am    Post subject: Reply with quote

Debian-user wrote:
Boas

Funciono colega obrigado

mas apareceu outro problema, agora toda opção do boot cada vez q começa a arrancar depois de 2 segundos a tela toda fica escura, mas escura que so consigo ver a parte em branco e mesmo assim somente na parte de baixo do monitor, isso tem haver com framebuffer não, no kernel ta ativado o suporte a fb, o que poderia ser?



Nunca tal me aconteceu ....

Não sei o que e "pmipal" no meu grub tenho mtrr:3 tente mudar isso ....

Eu no seu lugar corria os seguintes passos ....

1 - Tirar framebuffer para ver se o boot esta ok
2 - Verificar se o seu monitor/placa de video suporta realmente a resolução que esta a utilizar
3 - Experimentar outro tema do splash // eu utilizo o gentoo
4 - Experimente com uma resolução a 32 bits
5 - Utilizar vesa no kernel ou vesatng caso já esteja a utilizar vesa




Não me lembro de testar mais nada ......
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Debian-user
n00b
n00b


Joined: 06 May 2007
Posts: 5

PostPosted: Tue May 08, 2007 12:45 pm    Post subject: Reply with quote

ok amigo vou mudar, mas fora o mtrr:3, poderia dar exemplo pois ainda sou meio nb em grub e gentoo

vc diz tirar o video=vesafb e colocar o que?
_________________
Athlon 64 X2 4200
4x 512 Kingston PC3200
Nvidia 7900GT PCI-E 256/256
Asus A8N SLI SE
SEAGATE BARRACUDA SATA 160GB 7200 RPMS
SAMSUNG IDE 160GB 7200 RPMS
MAXTOR IDE 20GB 5800 RPMS
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue May 08, 2007 1:05 pm    Post subject: Reply with quote

Debian-user wrote:
ok amigo vou mudar, mas fora o mtrr:3, poderia dar exemplo pois ainda sou meio nb em grub e gentoo

vc diz tirar o video=vesafb e colocar o que?



Relativamente ao vesafb não me refiro a linha no grub mas a forma como compilou o kernel.

Eu utilizei este manual para configurar meu grub e splash http://gentoo-wiki.com/HOWTO_fbsplash

E dentro do link que lhe envio refiro-me a esta parte especifica da selecção de opções no kernel http://gentoo-wiki.com/HOWTO_fbsplash#Non-genkernel_users

Eu configurei o meu kernel manualmente seleccionei portanto todas as opções se utilizou o genkernel não sei bem como o ajudar pois sempre preparei o meu kernel manualmente ...... mas pelo que vejo no link que lhe deixo tambem ha instruções relativamente ao genkernel no entanto não estou a ver nada relativamente a vesa-tng..
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum