Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
100% CPU used by X when doing almost nothing [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dlublink
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2006
Posts: 146

PostPosted: Sat May 05, 2007 10:17 pm    Post subject: 100% CPU used by X when doing almost nothing [solved] Reply with quote

Hello,

Since a few days it seems that X uses between 60 and 100% of my cpu when I simply open firefox and open a website. I open top, and top takes 100%...

What's going on?? I haven't upgraded my kernel since 2.6.19-r5. It only started in the past day or to.

When I type 'clear' in gnome-terminal, it takes about 5 seconds to clear my terminal!!

What is going on? I tried using top to determine who is taking up the CPU but it varies depending on which application is running.

I type 'eix' and it takes like 30 seconds to display the list that once took 1 second to display.

If I switch to tty1 (alt+f1) and run eix it works fine. It seems to only do this behavior when I am in graphic mode.

Therefore I thought that it might be my video card, so I ran GLXGears. It runs very smoothly at about 320-350 FPS. So I don't think that the problem is with the graphics card.

I checked xorg-server and it looks like it was recently recompiled. Could there be something that changed signifcantly in xorg?

Anyone have any idea what's going on with my computer?

Thanks,

David


Code:
[I] x11-base/xorg-server
     Available versions:  1.1.1-r1 1.1.1-r5 1.2.0-r3 [M]-*1.2.99.0 ~1.3.0.0
     Installed versions:  1.2.0-r3(11:36:52 PM 05/03/2007)(-3dfx -debug -dmx dri -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick input_devices_keyboard -input_devices_magellan -input_devices_microtouch input_devices_mouse -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -ipv6 -kdrive minimal nptl sdl -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_i810 -video_cards_impact -video_cards_imstt -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo xorg -xprint)


Last edited by dlublink on Thu May 17, 2007 11:39 am; edited 1 time in total
Back to top
View user's profile Send private message
germanobax
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2005
Posts: 96

PostPosted: Sat May 05, 2007 10:32 pm    Post subject: Reply with quote

I gess you have Beagle indexing your files. It does that when the computer goes idle.
_________________
Life is a Sexually Transmitted Disease, with 100% mortality.
Back to top
View user's profile Send private message
dlublink
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2006
Posts: 146

PostPosted: Sat May 12, 2007 2:04 pm    Post subject: Reply with quote

[quote="germanobax"]I gess you have Beagle indexing your files. It does that when the computer goes idle.[/quote]

Beagle is not installed on my computer.

[code] 5171 root 19 0 135m 27m 10m R [b]89.0[/b] 11.0 3:42.71 X
5563 david 16 0 180m 62m 26m S 1.3 24.8 0:51.50 firefox-bin
5263 david 15 0 15448 8500 7168 S 1.0 3.3 0:02.86 metacity
5637 root 15 0 2204 1096 848 R 0.7 0.4 0:00.14 top
5274 david 15 0 47676 17m 10m S 0.3 7.1 0:03.40 gnome-terminal
1 root 15 0 1568 548 472 S 0.0 0.2 0:00.50 init [/code]

Here we see that X is using 89% of my processor. I am running firefox and a terminal window with top.

Nothing else!

[code]compaq david # eix beagle
* app-misc/beagle
Available versions: 0.2.16 0.2.16.2
Homepage: http://www.beagle-project.org/
Description: search tool that ransacks your personal information space to find whatever you're looking for

* sci-libs/beagle
Available versions: 2.2.0 ~3.0.1
Homepage: http://www.gel.ulaval.ca/~beagle/index.html
Description: Open BEAGLE, a versatile EC/GA/GP framework

* sys-fs/beaglefs
Available versions: ~1.0.3
Homepage: http://www.kernel.org/pub/linux/kernel/people/rml/fuse/beaglefs/
Description: beaglefs implements a filesystem representing a live Beagle query.

Found 3 matches.
[/code]

Any other ideas?

David
Back to top
View user's profile Send private message
dlublink
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2006
Posts: 146

PostPosted: Sat May 12, 2007 2:31 pm    Post subject: Reply with quote

Alright, I may have found the cause of the solution. I disabled transparency on my gnome-terminal, and now it doesn't take 100% processor.

Funny thing is that it used to work fine on my computer. GLXGears works great (320 fps). Why would transparency suddenly stop working?
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 456
Location: Paris, France

PostPosted: Sun May 13, 2007 4:38 pm    Post subject: Reply with quote

Seems like you are not alone getting such problems, with X taking much more CPU than it should:

https://forums.gentoo.org/viewtopic-t-556832.html

This bugs me more and more... My laptop was very silent and now the fan is running most of the time.
Back to top
View user's profile Send private message
Duke42
n00b
n00b


Joined: 11 Aug 2002
Posts: 34

PostPosted: Sun May 13, 2007 10:57 pm    Post subject: Reply with quote

Well, on my system, it helped to use Luxi Serif instead of Times... It seems to me, something in the font renderer is broken.
Back to top
View user's profile Send private message
Udasai
n00b
n00b


Joined: 20 Sep 2004
Posts: 32

PostPosted: Mon May 14, 2007 5:41 am    Post subject: Reply with quote

320 fps in glxgears is great? I get 12000+ (NVidia 6800GS, proprietary driver).
Back to top
View user's profile Send private message
dlublink
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2006
Posts: 146

PostPosted: Mon May 14, 2007 1:47 pm    Post subject: Reply with quote

Duke42 wrote:
Well, on my system, it helped to use Luxi Serif instead of Times... It seems to me, something in the font renderer is broken.


With that it still does 100% cpu. I noticed that with transparency off, it was less often using 100% but still happening. I jumped the gun in saying that it was fixed.

Luxi Serif causes 100% CPU but is less easy to read...


As for 320fps, it is good considering that when I installed gentoo it was 5 fps and my graphics card is 6 years old and is in a laptop. :D

David
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 456
Location: Paris, France

PostPosted: Wed May 16, 2007 2:13 pm    Post subject: Reply with quote

In my case it really seems to be made much worse when browsing some website... Today, X peaked around 100% cpu, and firefox went very slow, just to scroll a page which was fine before. My laptop is really not as it was before...

I noticed some errors in my xorg.conf, which I will try to investigate now (the drm thing should not be the issue: this has been broken for some time, due to cr@ppy ATI drivers):

Code:

(EE) fglrx: Failed to load module "drm" (module does not exist, 0)
(EE) fglrx: Failed to load module "drm" (module does not exist, 0)
(EE) fglrx(0): Failed to initialize GPS!
(EE) AIGLX: Screen 0 is not DRI capable
Back to top
View user's profile Send private message
dlublink
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2006
Posts: 146

PostPosted: Thu May 17, 2007 11:39 am    Post subject: Reply with quote

xavier10 wrote:
In my case it really seems to be made much worse when browsing some website... Today, X peaked around 100% cpu, and firefox went very slow, just to scroll a page which was fine before. My laptop is really not as it was before...

I noticed some errors in my xorg.conf, which I will try to investigate now (the drm thing should not be the issue: this has been broken for some time, due to cr@ppy ATI drivers):

Code:

(EE) fglrx: Failed to load module "drm" (module does not exist, 0)
(EE) fglrx: Failed to load module "drm" (module does not exist, 0)
(EE) fglrx(0): Failed to initialize GPS!
(EE) AIGLX: Screen 0 is not DRI capable


Hey,

I noticed a lot of people complaining about Xorg locking up. Several messages said disable RenderAccel in xorg.conf, I did this and it is working fine since.

I guess my computer wasn't fast enough to lockup like everyone else, that is why I thought it was a seperate issue.

David
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 456
Location: Paris, France

PostPosted: Sat May 19, 2007 3:13 pm    Post subject: Reply with quote

I disabled DRI completely now and get a faster X server. Again, desktop changes are instantaneous, and same for actions on firefox.
The fan of the laptop still often runs faster than it used to be.

Overall, I am pleased though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum