Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema comando su [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Fri May 04, 2007 1:03 pm    Post subject: Problema comando su [RISOLTO] Reply with quote

Non riesco a passare da un utente normale a root con il comando "su" ricevol'errore:

configuration error - unknown item 'GETPASS_ASTERISKS' (notify administrator)


Last edited by Karhot87 on Sun May 06, 2007 3:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri May 04, 2007 1:10 pm    Post subject: Reply with quote

quasi sicuramente non hai aggiornato correttamente i file di configurazione dopo un upgrade.

hai dato
Code:
# dispatch-conf
?

Inoltre, se tu avessi cercato nel forum come da linee guida ( :evil: ) avresti trovato questi:
1) https://forums.gentoo.org/viewtopic-t-366499-start-0.html
2) https://forums.gentoo.org/viewtopic-t-471156-highlight-getpassasterisks.html
3) https://forums.gentoo.org/viewtopic-t-498527-highlight-getpassasterisks.html
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Fri May 04, 2007 1:38 pm    Post subject: Reply with quote

Ho provato a lnaciare il comando dispatch-conf e ricevo

dispatch-conf: Error copying /etc/init.d/reboot.sh to /etc/config-archive/etc/init.d/reboot.sh: [Errno 2] No such file or directory: '/etc/init.d/reboot.sh'; fatal
dispatch-conf: Error copying /etc/init.d/shutdown.sh to /etc/config-archive/etc/init.d/shutdown.sh: [Errno 2] No such file or directory: '/etc/init.d/shutdown.sh'; fatal

hmmm non mastico molto l'inglese....
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Fri May 04, 2007 1:41 pm    Post subject: Reply with quote

hai provato anche
Code:
emerge --sync
etc-update
env-update
source /etc/profile
?
per il funzionamento di etc-update segui la guida
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"


Last edited by noice on Fri May 04, 2007 1:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri May 04, 2007 1:42 pm    Post subject: Reply with quote

lo stai lanciando da root, vero?

Se sì, prova con
Code:
# mkdir /etc/config-archive
# dispatch-conf


ti ricordo che l'aggiornamento dei file è da fare con molta attenzione.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Fri May 04, 2007 5:30 pm    Post subject: Reply with quote

niente....ho provato a fare tutte e due le cose, ma niente....
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Fri May 04, 2007 6:05 pm    Post subject: Reply with quote

Il tuo problema sembra dipendere da un vecchio problema di sys-apps/shadow.

Prova ad aggiornare il pacchetto:
Code:

emerge --oneshot -auv shadow

o commentare (mettendo un cancelletto # ad inizio riga) la voce
Code:

GETPASS_ASTERISKS

in /etc/login.defs.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
GuN_jAcK
l33t
l33t


Joined: 23 Mar 2005
Posts: 823
Location: Prague, Czech Republic

PostPosted: Fri May 04, 2007 6:48 pm    Post subject: Reply with quote

secondo me non ha dato etc-update ;) è un errore che questa settimana risolvo a due miei amici...

hai fatto update ultiamamente? :)
_________________
Rispondi in maniera intelligente anche a chi ti tratta stupidamente.
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Fri May 04, 2007 9:03 pm    Post subject: Reply with quote

no non ho fatto update, perche ho installato gentoo da poco, ho solo installato nuovi programmi....
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Sat May 05, 2007 7:31 am    Post subject: Reply with quote

va bhe, mettiamo che non abbia fatto l'etc-update, è possibilissimo che non l'abbia fatto, adesso non ricordo, come risolvo?
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat May 05, 2007 7:50 am    Post subject: Reply with quote

Karhot87 wrote:
va bhe, mettiamo che non abbia fatto l'etc-update, è possibilissimo che non l'abbia fatto, adesso non ricordo, come risolvo?


fai
Code:
etc-update
e guarda i file che vuole aggiornare ed aggiornali. verific poi che il tuo utente faccia parte del gruppo wheel.

ciao
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Sat May 05, 2007 8:30 am    Post subject: Reply with quote

Grazie crisandbea, ho rosolto il problema credo che era nel gruppo wheel....
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat May 05, 2007 9:06 am    Post subject: Reply with quote

Karhot87 wrote:
Grazie crisandbea, ho rosolto il problema credo che era nel gruppo wheel....


visto che hai risolto, edita il tuo primo post, e aggiungi il tag Risolto al titolo del post.

ciao
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum