Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Supporto formati real senza installare Real Player
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
VegetaSSJ5
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 238

PostPosted: Thu May 03, 2007 6:52 pm    Post subject: [RISOLTO] Supporto formati real senza installare Real Player Reply with quote

Ragazzi io leggo qualsiasi tipo di filmato con mplayer + w32codecs settati con le opportune use flag. Sul mio sistema è installato anche RealPlayer come dipendenza di uno dei due pacchetti che ho citato. Vorrei però togliere questo player dato che non l'ho mai utilizzato. Si può fare? Se sì, in che modo? Grazie.

Last edited by VegetaSSJ5 on Fri May 04, 2007 7:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Thu May 03, 2007 10:10 pm    Post subject: Reply with quote

fra le USE flags inserisci real e riemergi win32codec .... dovrebbe andare...
_________________
C.
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4486
Location: Somewere around the world

PostPosted: Thu May 03, 2007 10:10 pm    Post subject: Reply with quote

eliminando la USE "real" ?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
VegetaSSJ5
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 238

PostPosted: Thu May 03, 2007 10:19 pm    Post subject: Reply with quote

CarloJekko wrote:
fra le USE flags inserisci real e riemergi win32codec .... dovrebbe andare...

dunque la use real per i win32codecs c'è sempre stata. ho "unmergiato" real player ma poi vuole reinstallarlo...
Cazzantonio wrote:
eliminando la USE "real" ?

la use real non è globale ma l'ho impostata solo relativamente al pacchetto win32codec. se la rimuovo presumo che il supporto a tale formato vada a farsi benedire...
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Thu May 03, 2007 11:38 pm    Post subject: Reply with quote

VegetaSSJ5 wrote:
CarloJekko wrote:
fra le USE flags inserisci real e riemergi win32codec .... dovrebbe andare...

dunque la use real per i win32codecs c'è sempre stata. ho "unmergiato" real player ma poi vuole reinstallarlo...
Chi vuole reinstallarlo??
_________________
C.
Back to top
View user's profile Send private message
drizztbsd
Retired Dev
Retired Dev


Joined: 21 Nov 2004
Posts: 278
Location: Cesano Maderno

PostPosted: Fri May 04, 2007 7:39 am    Post subject: Reply with quote

basta mettere la use real solo per win32codecs e non per mplayer
_________________
Gentoo/Alt lead
Gentoo/*BSD and Gentoo/FreeBSD deputy lead
Paludis contributor
Back to top
View user's profile Send private message
VegetaSSJ5
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 238

PostPosted: Fri May 04, 2007 7:06 pm    Post subject: Reply with quote

Drizzt Do` Urden wrote:
basta mettere la use real solo per win32codecs e non per mplayer

in questo modo funziona! grazie! :)
Back to top
View user's profile Send private message
pingoo
Guru
Guru


Joined: 11 Jul 2006
Posts: 324

PostPosted: Sat May 05, 2007 8:46 am    Post subject: Reply with quote

A me non torna, qualcuno sa dirmi dove ho sbagliato??
Code:
emerge -pv mplayer
[ebuild   R   ] media-video/mplayer-1.0.20070321  USE="3dnow 3dnowext X aac alsa dvd encode gif gtk iconv jpeg mad mmx mmxext mp3 opengl png quicktime samba sdl sse truetype unicode vorbis win32codecs x264 xv xvid -a52 -aalib (-altivec) -amr -arts -bidi -bindist -bl -cddb -cdparanoia -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb -dvdnav -dvdread -enca -esd -fbcon -ftp -ggi -ipv6 -ivtv -jack -joystick -libcaca -lirc -live -livecd -lzo -md5sum -mp2 -musepack -nas -openal -oss -pnm -radio -rar -real -rtc -speex -srt -sse2 -svga -tga -theora -tivo -v4l -v4l2 -vidix -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Code:
 # equery d [-d] realplayer
[ Searching for packages depending on realplayer... ]
media-libs/win32codecs-20061022-r1 (real & amd64? media-video/realplayer)
media-sound/amarok-1.4.5-r1 (real? media-video/realplayer)
media-video/mplayer-1.0.20070321 (!livecd & !bindist & x86 & real? media-video/realplayer)
Le condizioni dovrebbero essere false sia per mplayer che per win32codecs dato che non sto su amd64, ma dall'output si direbbe il contrario :roll:

Ciao
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat May 05, 2007 9:05 am    Post subject: Reply with quote

pingoo wrote:
A me non torna, qualcuno sa dirmi dove ho sbagliato??
Code:
emerge -pv mplayer
[ebuild   R   ] media-video/mplayer-1.0.20070321  USE="3dnow 3dnowext X aac alsa dvd encode gif gtk iconv jpeg mad mmx mmxext mp3 opengl png quicktime samba sdl sse truetype unicode vorbis win32codecs x264 xv xvid -a52 -aalib (-altivec) -amr -arts -bidi -bindist -bl -cddb -cdparanoia -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb -dvdnav -dvdread -enca -esd -fbcon -ftp -ggi -ipv6 -ivtv -jack -joystick -libcaca -lirc -live -livecd -lzo -md5sum -mp2 -musepack -nas -openal -oss -pnm -radio -rar -real -rtc -speex -srt -sse2 -svga -tga -theora -tivo -v4l -v4l2 -vidix -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Code:
 # equery d [-d] realplayer
[ Searching for packages depending on realplayer... ]
media-libs/win32codecs-20061022-r1 (real & amd64? media-video/realplayer)
media-sound/amarok-1.4.5-r1 (real? media-video/realplayer)
media-video/mplayer-1.0.20070321 (!livecd & !bindist & x86 & real? media-video/realplayer)
Le condizioni dovrebbero essere false sia per mplayer che per win32codecs dato che non sto su amd64, ma dall'output si direbbe il contrario :roll:

Ciao

scusami ma non ho capito cosa non ti torna..... puoi essere più preciso???

grazie

ciauz
Back to top
View user's profile Send private message
pingoo
Guru
Guru


Joined: 11 Jul 2006
Posts: 324

PostPosted: Sat May 05, 2007 9:15 am    Post subject: Reply with quote

Quote:
scusami ma non ho capito cosa non ti torna..... puoi essere più preciso???

grazie

ciauz

Se non ho capito male VegetaSSJ5 è riuscito a rimuovere RealPlayer ovvero il pacchetto media-video/realplayer, ma nel mio sistema mplayer e win32codecs continuano a dipendere da esso. Poi nonostante abbia letto il manuale di equery non mi è ben chiaro quell'output, visto che le condizioni tra parentesi dovrebbero risultare false sia per win32codecs che per mplayer.
Grazie a te ;)
Back to top
View user's profile Send private message
VegetaSSJ5
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 238

PostPosted: Sat May 05, 2007 9:40 am    Post subject: Reply with quote

pingoo wrote:
Quote:
scusami ma non ho capito cosa non ti torna..... puoi essere pi� preciso???

grazie

ciauz

Se non ho capito male VegetaSSJ5 � riuscito a rimuovere RealPlayer ovvero il pacchetto media-video/realplayer, ma nel mio sistema mplayer e win32codecs continuano a dipendere da esso. Poi nonostante abbia letto il manuale di equery non mi � ben chiaro quell'output, visto che le condizioni tra parentesi dovrebbero risultare false sia per win32codecs che per mplayer.
Grazie a te ;)

io i pacchetti in questione li ho compilati con queste use flag (sono su x86):
Code:
emerge -pv mplayer win32codecs mplayerplug-in

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/mplayer-1.0.20070321  USE="3dnow 3dnowext X aac alsa amr cddb dga dvd encode gif gtk iconv jpeg mad mmx mmxext mp3 musepack openal opengl png quicktime rtc sdl sse tga truetype unicode vorbis win32codecs xv xvid xvmc -a52 -aalib (-altivec) -arts -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags -debug -directfb -doc -dts -dv -dvb -dvdnav -dvdread -enca -esd -fbcon -ftp -ggi -ipv6 -ivtv -jack -joystick -libcaca -lirc -live -livecd -lzo -md5sum -mp2 -nas -oss -pnm -radio -rar -real -samba -speex -srt -sse2 -svga -theora -tivo -v4l -v4l2 -vidix -x264 -xanim -xinerama -zoran" VIDEO_CARDS="vesa -mga -s3virge -tdfx" 0 kB
[ebuild   R   ] media-libs/win32codecs-20061022-r1  USE="quicktime real" 0 kB
[ebuild   R   ] net-www/mplayerplug-in-3.35  USE="divx gmedia gtk quicktime realmedia wmp" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 0 kB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum