Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200705-03 ] Tomcat: Information disclosure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1655

PostPosted: Tue May 01, 2007 9:26 pm    Post subject: [ GLSA 200705-03 ] Tomcat: Information disclosure Reply with quote

Gentoo Linux Security Advisory

Title: Tomcat: Information disclosure (GLSA 200705-03)
Severity: low
Exploitable: remote
Date: May 01, 2007
Bug(s): #173122
ID: 200705-03

Synopsis

A vulnerability has been discovered in Tomcat that allows for the disclosure of sensitive information.

Background

Tomcat is the Apache Jakarta Project's official implementation of Java Servlets and Java Server Pages.

Affected Packages

Package: www-servers/tomcat
Vulnerable: < 5.5.22
Unaffected: >= 5.5.22
Architectures: All supported architectures


Description

Tomcat allows special characters like slash, backslash or URL-encoded backslash as a separator, while Apache does not.

Impact

A remote attacker could send a specially crafted URL to the vulnerable Tomcat server, possibly resulting in a directory traversal and read access to arbitrary files with the privileges of the user running Tomcat. Note that this vulnerability can only be exploited when using apache proxy modules like mod_proxy, mod_rewrite or mod_jk.

Workaround

There is no known workaround at this time.

Resolution

All Tomcat users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/tomcat-5.5.22"


References

CVE-2007-0450
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum