Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sparc root partition on software raid device
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
Artello
n00b
n00b


Joined: 27 Apr 2007
Posts: 13

PostPosted: Fri Apr 27, 2007 12:09 pm    Post subject: sparc root partition on software raid device Reply with quote

Hi,

Can somebody advise me why this SPARC box won't boot? may be I' still missing something?

I've built kernel using genkernel --dmraind --initramfs all
All needed SCSI modules are included in kernel.

silo.conf:

Code:

partition = 1                                                                                                   
timeout = 10                                                                                                     
                                                                                                                                   
default = rd                                                                                                         
image = /boot/kernel-genkernel-sparc64-2.6.20-gentoo-r5-rd
        label = rd
        append = "md=1, /dev/sda1,/dev/sdb1"
        initrd = /boot/initramfs-genkernel-sparc64-2.6.20-gentoo-r5-rd 
        root = /dev/md1


Boot log:
Code:

scsi0 : sym-2.2.3
scsi 0:0:0:0: Direct-Access     SEAGATE  ST336704LSUN36G  0326 PQ: 0 ANSI: 3
 target0:0:0: tagged command queuing enabled, command queue depth 16.
 target0:0:0: Beginning Domain Validation
 target0:0:0: asynchronous
 target0:0:0: wide asynchronous
 target0:0:0: FAST-20 WIDE SCSI 40.0 MB/s ST (50 ns, offset 16)
 target0:0:0: Domain Validation skipping write tests
 target0:0:0: Ending Domain Validation
scsi 0:0:1:0: Direct-Access     SEAGATE  ST336704LSUN36G  0326 PQ: 0 ANSI: 3
 target0:0:1: tagged command queuing enabled, command queue depth 16.
 target0:0:1: Beginning Domain Validation
 target0:0:1: asynchronous
 target0:0:1: wide asynchronous
 target0:0:1: FAST-20 WIDE SCSI 40.0 MB/s ST (50 ns, offset 16)
 target0:0:1: Domain Validation skipping write tests
 target0:0:1: Ending Domain Validation
scsi 0:0:6:0: CD-ROM            TOSHIBA  DVD-ROM SD-M1401 1007 PQ: 0 ANSI: 2
 target0:0:6: Beginning Domain Validation
 target0:0:6: asynchronous
 target0:0:6: FAST-20 SCSI 20.0 MB/s ST (50 ns, offset 16)
 target0:0:6: Domain Validation skipping write tests
 target0:0:6: Ending Domain Validation
sym1: <875> rev 0x14 at pci 0001:00:03.1 irq 14
sym1: No NVRAM, ID 7, Fast-20, SE, parity checking
sym1: SCSI BUS has been reset.
scsi1 : sym-2.2.3
megasas: 00.00.03.05 Mon Oct 02 11:21:32 PDT 2006
SCSI device sda: 71132959 512-byte hdwr sectors (36420 MB)
sda: Write Protect is off
SCSI device sda: write cache: disabled, read cache: enabled, supports DPO and FUA
SCSI device sda: 71132959 512-byte hdwr sectors (36420 MB)
sda: Write Protect is off
SCSI device sda: write cache: disabled, read cache: enabled, supports DPO and FUA
 sda: sda1 sda2 sda3
sd 0:0:0:0: Attached scsi disk sda
SCSI device sdb: 71132959 512-byte hdwr sectors (36420 MB)
sdb: Write Protect is off
SCSI device sdb: write cache: disabled, read cache: enabled, supports DPO and FUA
SCSI device sdb: 71132959 512-byte hdwr sectors (36420 MB)
sdb: Write Protect is off
SCSI device sdb: write cache: disabled, read cache: enabled, supports DPO and FUA
 sdb: sdb1 sdb2 sdb3
sd 0:0:1:0: Attached scsi disk sdb
sr0: scsi3-mmc drive: 40x/40x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
Fusion MPT base driver 3.04.03
Copyright (c) 1999-2007 LSI Logic Corporation
Fusion MPT SPI Host driver 3.04.03
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator,Target}
scsi2 : ioc0: LSI53C1030, FwRev=01032700h, Ports=1, MaxQ=255, IRQ=16
scsi 2:0:4:0: Sequential-Access HP       Ultrium 3-SCSI   G29D PQ: 0 ANSI: 3
 target2:0:4: Beginning Domain Validation
 target2:0:4: Ending Domain Validation
 target2:0:4: FAST-160 WIDE SCSI 320.0 MB/s DT IU RTI PCOMP (6.25 ns, offset 64)
mptbase: Initiating ioc1 bringup
ioc1: 53C1030: Capabilities={Initiator,Target}
scsi3 : ioc1: LSI53C1030, FwRev=01032700h, Ports=1, MaxQ=255, IRQ=17
Fusion MPT FC Host driver 3.04.03
Fusion MPT SAS Host driver 3.04.03
Fusion MPT misc device (ioctl) driver 3.04.03
mptctl: Registered with Fusion MPT base driver
mptctl: /dev/mptctl @ (major,minor=10,220)
rtc_sun_init: Registered Mostek RTC driver.
mice: PS/2 mouse device common for all mice
input: Sun Mouse as /class/input/input0
md: linear personality registered for level -1
md: raid0 personality registered for level 0
md: raid1 personality registered for level 1
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
TCP cubic registered
NET: Registered protocol family 1
>> Loading modules ocol family 17
>> Activating mdev
>> Detected real_root as a md device. Setting up the device node...
>> Determining root device...
>> Mounting root...
mount: Mounting /dev/md1 on /newroot failed: Invalid argument
!! Could not mount specified ROOT, try again
!! The root block device is unspecified or not detected.
   Please specify a device to boot, or "shell" for a shell...


Thank you in advance!
Back to top
View user's profile Send private message
widan
Veteran
Veteran


Joined: 07 Jun 2005
Posts: 1512
Location: Paris, France

PostPosted: Fri Apr 27, 2007 11:37 pm    Post subject: Re: sparc root partition on software raid device Reply with quote

Code:
append = "md=1, /dev/sda1,/dev/sdb1"

The space after the "1" should not be there. Try with that instead:
Code:
append = "md=1,/dev/sda1,/dev/sdb1"
Back to top
View user's profile Send private message
Artello
n00b
n00b


Joined: 27 Apr 2007
Posts: 13

PostPosted: Thu May 03, 2007 6:57 am    Post subject: Re: sparc root partition on software raid device Reply with quote

widan wrote:
Code:
append = "md=1, /dev/sda1,/dev/sdb1"

The space after the "1" should not be there. Try with that instead:
Code:
append = "md=1,/dev/sda1,/dev/sdb1"


Just tried that - no luck :(. This sparc box stil won't boot from /dev/md1
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu May 03, 2007 8:51 am    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on Sparc.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
MerlinYoda
n00b
n00b


Joined: 23 May 2007
Posts: 8
Location: Indiana, United States, Earth, Sol System, Milky Way Galaxy, "The Universe"

PostPosted: Wed May 23, 2007 8:59 pm    Post subject: Reply with quote

EDIT: Fixed: I recompiled my kernel and now it works fine with the settings below. I must have either set one too many things to be built into the kernel last time or "genkernel --menuconfig all" wasn't set to compile the way I thought I had specified it to. Also, in the course of working out issues, I may have inadvertently compiled with the "dmraid" support the time before which could explain the conflict

Could this get moved back to Gentoo Install? Mainly because I'm having the same error on an x86 architecture with a Software RAID1 setup (all partitions are mirrored)

Specifically:
Code:

>> Detected real_root as a md device. Setting up the device node...
>> Determining root device...
>> Mounting root...
mount: Mounting /dev/md3 on /newroot failed: Invalid argument
!! Could not mount specified ROOT, try again
!! The root block device is unspecified or not detected.
   Please specify a device to boot, or "shell" for a shell...



Mirros defined:
/dev/md1 = /dev/sda1,dev/sdb1 (boot)
/dev/md2 = /dev/sda2,dev/sdb2 (swap)
/dev/md3 = /dev/sda3,dev/sdb3 (root filesystem)

Partition types on the individual drives are all "raid autodetect" (fd)

kernel was compiled (as far as I can tell) with RAID 1 and "Device Mapper Support" as built-in and not as a module when I ran "genkernel --menuconfig all". Also compiled into the kernel SATA drivers (for accessing SATA drives naturally :-))

/etc/lilo.conf
Code:

boot=/dev/md1           # Install LILO in the MBR
install=menu
prompt                  # Give the user the chance to select another section
timeout=100             # Wait 10 (ten) seconds before booting the default section
default=Gentoo          # When the timeout has passed, boot this section
raid-extra-boot=/dev/sda,/dev/sdb
lba32

# For genkernel users
image=/boot/kernel-genkernel-x86-2.6.20-gentoo-r8
  label=Gentoo
  read-only
  root=/dev/ram0
  append="init=/linuxrc ramdisk=8192 real_root=/dev/md3 udev"
  initrd=/boot/initramfs-genkernel-x86-2.6.20-gentoo-r8
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum