Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Il suono:un problemino[risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Big Boss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2006
Posts: 88

PostPosted: Thu Apr 26, 2007 6:06 pm    Post subject: Il suono:un problemino[risolto] Reply with quote

Finita la installazione di gentoo, come già mi capitò in passato, non riesco a sentire alcun audio.

Con kernel 2.6.17 se vado in system---->preferenze----->audio e schiaccio sui suoni di gnome non sento niente se alzo il volume delle casse al massimo, ma dico al massimo tanto che si sente il fischio, e schiaccio su uno dei suoni di gnome qualcosa si sente ma molto bass, questo credo sia un problema di regolazione del volume di sistema ma se schiaccio sul regolatore di volue ecco il riusltato:

Code:
The volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.

You can remove the volume control from the panel by right-clicking the speaker icon on the panel and selecting "Remove From Panel" from the menu.
... riepto qualcosina molto bassa si sente, se vado in applicazioni--->audio e video--->regolazione volume questo è il risultato:

Code:
No volume control GStreamer plugins and/or devices found


che devo fare???

Con kernel 2.6.20 stessi risultati se cerco di regolare il volume ma quando vao in sistema---->preferenze--->audio alzo al massimo le casse e schiaccio su uno dei suoni di gnome, non si sente assolutamente niente. Deduco che devo ricompilare il kernel per abilitare i supporti ma cosa abilito???

Vi posto lspic:
Code:
00:00.0 Host bridge: Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub (rev 81)
00:01.0 PCI bridge: Intel Corporation 945G/GZ/P/PL Express PCI Express Root Port (rev 81)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01) <------ eccola qui
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
01:04.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F Single Channel UDMA 133 (ASUS 8211 (ITE IT8212 ATA RAID Controller)) (rev 11)
02:00.0 Mass storage controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 15)
05:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] (rev a1)


Cosa devo abilitare nel kernel 2.6.20 per poter sentire qualcosa?


Last edited by Big Boss on Fri Apr 27, 2007 6:04 am; edited 1 time in total
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Thu Apr 26, 2007 6:10 pm    Post subject: Reply with quote

che driver usi? alsa?
alsa da ebuild o alsa come modulo del kernel?
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Thu Apr 26, 2007 6:44 pm    Post subject: Reply with quote

hai regolato i valori con alsamixer ?
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Apr 26, 2007 6:45 pm    Post subject: Reply with quote

Consiglio "a spanne": compili qualsiasi kernel recente con l'infrastruttura alsa come modulo, imposti ALSA_CARDS="hda-intel" in /etc/make.conf, emergi gli alsa-tools e lanci alsaconf da root.
Se fatto questo ancora non funziona, vuol dire probabilmente che hai qualche server sonoro arts/esd che rompe.
Prova e sappici dire.
Back to top
View user's profile Send private message
Big Boss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2006
Posts: 88

PostPosted: Thu Apr 26, 2007 7:56 pm    Post subject: Reply with quote

Quote:
che driver usi? alsa?
alsa da ebuild o alsa come modulo del kernel?


su kernel 2.6.17 uso moduli del kernel
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Apr 26, 2007 8:19 pm    Post subject: Reply with quote

Barbatrucco consigliato anche nella relativa guida ufficiale:

Se i driver nel kernel non funzionano, provare ad utilizzare il pacchetto alsa-driver (o viceversa).
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Big Boss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2006
Posts: 88

PostPosted: Fri Apr 27, 2007 6:03 am    Post subject: Reply with quote

Quote:
arbatrucco consigliato anche nella relativa guida ufficiale:

Se i driver nel kernel non funzionano, provare ad utilizzare il pacchetto alsa-driver (o viceversa).


Infatti ieri notte alle ore 23 dopo aver ricompilato il kernel disattivando il modulo alsa e installando i driver alsa con emerge le mie casse hanno iniziato a cantare :D :D . ora direi che sono apposto :D aspetto gnome 2.18 stabile :D

Grazie a tutti per avermi aiutato nei miei 4 trhead, post-installazione, ora gentoo è perfetta, suono, vede tutti gli hd e la scheda di rete funziona :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum