Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Ipw3945 wep, wpa help!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
smileone
n00b
n00b


Joined: 19 Apr 2007
Posts: 8

PostPosted: Thu May 24, 2007 10:36 am    Post subject: [SOLVED]Ipw3945 wep, wpa help!! Reply with quote

I have a laptop with wifi card ipw3945.
KERNEL -> 2.6.21-suspend2-r4
.config ->


    CONFIG_IEEE80211=m
    # CONFIG_IEEE80211_DEBUG is not set
    CONFIG_IEEE80211_CRYPT_WEP=m
    CONFIG_IEEE80211_CRYPT_CCMP=m
    CONFIG_IEEE80211_CRYPT_TKIP=m
    # CONFIG_IEEE80211_SOFTMAC is not set



/etc/modules.autoload.d/kernel-2.6


    ieee80211_crypt_ccmp
    ieee80211_crypt_tkip
    ieee80211_crypt_wep
    ieee80211
    ieee80211_crypt
    ipw3945



Code:

# ipw3945d
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:01:00.0
Daemon launched as pid 6978.  Exiting.


I have installed

    net-wireless/ipw3945 1.2.0
    net-wireless/ipw3945-ucode 1.14.2
    net-wireless/ipw3945d 1.7.22-r4
    net-wireless/wpa_supplicant-0.5.7 USE="dbus readline ssl -gnutls -gsm -madwifi -qt3 -qt4"
    net-wireless/wireless-tools-29_pre20 USE="nls -multicall"

Code:

iwconfig
eth2_rename  unassociated  ESSID:off/any
          Mode:Managed  Frequency=nan kHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:16 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


After
Code:

/etc/init.d/eth2_rename start
 * Starting eth2_rename
 *   Starting wpa_supplicant on eth2_rename ...                           [ ok ]
 *   Starting wpa_cli on eth2_rename ...                                  [ ok ]
 *     Backgrounding ...


Code:

iwconfig
eth2_rename  IEEE 802.11g  ESSID:"gentoo"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:50:18:49:5C:60   
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:4484-6E62-60   Security mode:open
          Power Management:off
          Link Quality=96/100  Signal level=-33 dBm  Noise level=-34 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:10   Missed beacon:0


But there isn't wifi connection on router's filelog.And I can't connect.
Code:

# /etc/init.d/net.eth2_rename status
* status:  inactive


Code:

#cat /proc/net/wireless
Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
 face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 22
eth2_rename: 0000   97.  228.  227.       0      0      0      0     11        0


/etc/conf.d/net

    modules=( "wpa_supplicant" )
    wpa_supplicant_eth2_rename="-Dwext -c /etc/wpa_supplicant/wpa_supplicant.conf"


/etc/wpa_supplicant/wpa_supplicant.conf

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    ap_scan=1

    network={
    ssid="gentoo"
    key_mgmt=NONE
    wep_key0=44846E6260
    wep_tx_keyidx=0
    priority=5
    }



Wifi LED is ON :(
I think that's all.
I'd try with WPA, WPA-PSK,WEP but no connection on.
I have try to connect a "wifi point without any protection", work perfectly.


Last edited by smileone on Thu Jun 07, 2007 12:32 pm; edited 2 times in total
Back to top
View user's profile Send private message
Abraxas
l33t
l33t


Joined: 25 May 2003
Posts: 807

PostPosted: Thu May 24, 2007 5:21 pm    Post subject: Reply with quote

I have the following configuration and it works. I have heard that there are issues with WEP using the ipw3945 driver so I would use WPA if you can. I used wpa_passphrase to generate the psk value in wpa_supplicant.conf


/etc/conf.d/net

wpa_supplicant_eth1=( "-Dwext" )
modules_eth1=( "wpa_supplicant" "!plug" )
config_eth1=( "dhcp" )
dhcpcd_eth1="-t 15"


/etc/wpa_supplicant/wpa_supplicant.conf

network={
ssid="AP01"
psk=6a26f90646e06f4fb049b6876c7f2c31f0cd9f3016a656343901bf9ba466fd64
key_mgmt=WPA-PSK
proto=WPA
priority=9
}
Back to top
View user's profile Send private message
DirtyHairy
l33t
l33t


Joined: 03 Jul 2006
Posts: 608
Location: Würzburg, Deutschland

PostPosted: Fri May 25, 2007 8:53 am    Post subject: Reply with quote

I never had issues with WEP and ipw3945, but I also never managed to get it to work with wpa_supplicant. Can you associate manually via iwconfig?
Back to top
View user's profile Send private message
smileone
n00b
n00b


Joined: 19 Apr 2007
Posts: 8

PostPosted: Sat May 26, 2007 12:01 am    Post subject: iwconfig Reply with quote

DirtyHairy wrote:
I never had issues with WEP and ipw3945, but I also never managed to get it to work with wpa_supplicant. Can you associate manually via iwconfig?

I try iwconfig eth2.... key (128bit key wep)
Code:
eth2_rename  IEEE 802.11g  ESSID:"gentoo" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:50:18:49:5C:60   
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:CD1B-CA58-3A97-1E64-0E8C-7C64-AC   Security mode:open
          Power Management:off
          Link Quality=94/100  Signal level=-36 dBm  Noise level=-36 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:19   Missed beacon:0

but no connection available
Back to top
View user's profile Send private message
DirtyHairy
l33t
l33t


Joined: 03 Jul 2006
Posts: 608
Location: Würzburg, Deutschland

PostPosted: Sat May 26, 2007 10:46 am    Post subject: Reply with quote

Well, it seems to associate... What are you connecting to; is there a dhcp server supposed to be running? If so, can you try to manually obtain an IP via a dhcp client like dhcpcd?
Back to top
View user's profile Send private message
smileone
n00b
n00b


Joined: 19 Apr 2007
Posts: 8

PostPosted: Sat May 26, 2007 12:06 pm    Post subject: wifi-radar Reply with quote

I try with wifi-radar, work perfectly.

Code:
#iwconfig
eth2_rename  IEEE 802.11g  ESSID:"gentoo"  Nickname:"gentoo"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:50:18:49:5C:60   
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:CD1B-CA58-3A97-1E64-0E8C-7C64-AC   Security mode:open
          Power Management:off
          Link Quality=98/100  Signal level=-26 dBm  Noise level=-26 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:179   Missed beacon:0


Configuration wifi-radar.conf
    [gentoo]
    prescript =
    use_wpa = no
    postscript =
    mode = auto
    key = CD1BCA583A971E640E8C7C64AC
    use_dhcp = yes
    security = open
    channel = auto


But wpa_suplicant continue not to work!!!
Back to top
View user's profile Send private message
smileone
n00b
n00b


Joined: 19 Apr 2007
Posts: 8

PostPosted: Thu Jun 07, 2007 12:31 pm    Post subject: Solved Reply with quote

I solved ipw3945 problem with upgrading kernel from suspend2 to gentoo-sources 2.6.20-r8.
Recompile kernel with ieee802111 built. (ieee80211, ieee80211_crypt, ieee80211_crypt_wep, ieee80211_crypt_tkip, ieee80211_ccmp)
Wpa_supplicant work perfectly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum