Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema avvio kde
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Thu Apr 26, 2007 10:19 am    Post subject: Problema avvio kde Reply with quote

Salve a tutti sono nuovo di gentoo....fino a pochi giorni fa avevo fedora, poi ho deciso di fare il grande passo e passare a gentoo. Sno riuscito ad installarlo, ho anche installato kde con il comando
"emerge kdebase kdenetwork kdeadmin". Una volta finito la compilazione e l'installazione c'era come output una cosa del genere "remerge x11-libs/qt-3* with USE="opengl" ". Ho provato ha lanciare "emerge x11-libs/qt-3* with USE="opengl" ma non trova niente, ma quando vado ad avviare il server X con startx ricevo:
xauth: creating new authority file /home/francesco.serverauth.4652
xinit: No such file or directory (errno 2) no server "X" in PATH

Come lo risolvo? Prima di lanciare startx ho anche fatto "echo "exec startkde" >~/.xinitrc"

Grazie a tutti
Back to top
View user's profile Send private message
GiRa
l33t
l33t


Joined: 07 Apr 2005
Posts: 717

PostPosted: Thu Apr 26, 2007 10:37 am    Post subject: Reply with quote

Xorg non è una dipendenza di KDE quindi devi installarlo a mano con
Code:
emerge xorg-x11
dopo aver preparato tutto il necessario: http://www.gentoo.org/doc/it/xorg-config.xml

Per KDE ti conviene usare gli split ebuild, al limite usando i metapacchetti: http://www.gentoo.org/doc/it/kde-split-ebuilds.xml

Per il tuo problema di use usa
Code:
euse -i $nome_use
per sapere se è locale o globale, nel caso sia una use globale (opengl lo è) puoi abilitarla con
Code:
euse -E $nome_use
altrimenti puoi usare /etc/portage/package.use.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Apr 26, 2007 10:41 am    Post subject: Reply with quote

Devi impostare la USE e poi ricompilare il pacchetto.
La use la puoi mettere in /etc/make.conf assieme alle altra che avrai già messo (l'hai fatto, vero?) per abilitarla globalmente per tutti i pacchetti, oppure puoi abilitarla solo per qt inserendo, nel file /etc/portage/package.use, una riga del tipo
categoria/pacchetto use.
Nel caso specifico la riga dovrebbe essere qualcosa del genere
Code:
x11-libs/qt opengl

Infine riemergere il mondo
Code:
# emerge -DuNav world


Per approfondire la questione ti consiglio una belle letta alle varie risorse, cioè
Code:
man portage
man emerge
man make.conf

e anche da qui in poi.

Byez

p.s. benvenuto a gentoo
p.p.s. intanto che hai installato ancora poco di kde ti consiglio di emergerlo utilizzando gli split ebuilds e non i monolitici che, presto, verranno tolti da portage. Link utile...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Apr 26, 2007 10:43 am    Post subject: Re: Problema avvio kde Reply with quote

Karhot87 wrote:
Ho provato ha lanciare "emerge x11-libs/qt-3* with USE="opengl" ma non trova niente, ma quando vado ad avviare il server X con startx ricevo:
...
Come lo risolvo? Prima di lanciare startx ho anche fatto "echo "exec startkde" >~/.xinitrc"


Credo che tu abbia le idee un poco confuse.
Gentoo personalizza la compilazione dei programmi utilizzando le cosiddette flag USE. In pratica, viene impostata una speciale variabile che indica quali caratteristiche del pacchetto si vogliono compilare e quali no.
Il messaggio <<emerge x11-libs/qt-3* with USE="opengl>> ti dice che devi abilitare la USE opengl per il pacchetto "x11-libs/qt-3*" (nota che l'asterisco in fondo indica in realtà una famiglia di pacchetti e non solo uno specifico).

allora, per quello che vuoi fare dovrebbe bastarti qualcosa tipo:
Code:

# echo "x11-libs/qt-3* opengl" >> /etc/portage/package.use
# emerge \=3.3.8-r2

Per capire quello che hai fatto una lettura a [url=http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2&chap=2]questa parte[/quote] del manuale é la cosa migliore... visto che spiega decisamente meglio di come potrei farlo io in un post ;-)


Se vuoi avviare X senza KDE invece dovresti eliminare la linea che hai aggiundo nell'.xinitrc, presumibilemnte il file che non trova é proprio startkde ;-)
_________________
Ciao da me!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum