Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi audio & co.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Apr 25, 2007 8:58 am    Post subject: Problemi audio & co. Reply with quote

Ciao a tutti, ho un problema ma non essendo molto ferrato non saprei quali dati fornirvi per aiutarmi a risolverlo quindi cercherò di spiegarmi al meglio.

Premetto che le casse spesso non le accendo neppure visto che non ho mai tempo per ascoltare la musica o guardare la tele al pc quindi non saprei dire esattamente quando si è presentato questo problema, di sicuro un paio di settimane fa amarok funzionava egregiamente e kaffeine mi permetteva di vedermi il digitale terrestre senza problemi.

Oggi invece essendo festa ho più tempo è ho voluto ascoltarmi un po' di musica ma amarok non faceva uscire alcun suono, si vedeva la progressione del tempo e basta. Ho provato a vedermi un canale con kaffeine e il video era a posto ma l'audio era assente. Provo a riavviare alsasound e si chiudono sia amarok che kaffeine (come penso sia giusto). Provo a rilanciare amarok e rimane fermo sullo splash screen se clicco sullo splash scompare ma ps mi mostra amarok e devo killarlo a mano. Provo a lanciare kaffeine, si apre ma quando provo a fargli lanciare un filmata (ieri sera gli ho fatto registrare supernatural) si blocca e premendo la X per chiuderlo mi appare la finestra che mi informa che il programma non risponde e mi chiede se terminarlo o lasciarlo in esecuzione. Similmente si blocca se cerco di guardare un qualsiasi canale.

Lanciando mplayer invece riesco a vedere e sentire perfettamente ogni filmato, compreso il programma che ha registrato kaffeine questa notte.

Ho provato a ricompilare xine-lib e alsa ma il risultato non cambia :(

Sapete consigliarmi ?

/EDIT:anche hydrogen funziona perfettamente, sono confuso e poco felice ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Apr 25, 2007 9:21 am    Post subject: Reply with quote

@Kernel78
hai per caso effettuato qualche aggiornamento???? cambiato profilo???

dimenticato di aggiornare qualche file di configurazione???

EDIT: che versione di amarok e kaffeine hai???
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Apr 25, 2007 9:42 am    Post subject: Reply with quote

Aggiorno giornalmente (sono su un amd64) e adesso che ci penso ho recentemente impostato il profilo 2007.0 ...
Lancio sempre dispatch-conf dopo ogni emerge (mi sono fatto uno script che lo lancia in automatico) per non rischiare di dimenticarmene :wink:

Ho installato amarok 1.4.5-r1 e kaffeine 0.8.3.

Quasi quasi provo a tornare al profilo che avevo prima ...

/EDIT:impostando il vecchio profilo ottengo
Code:
# emerge -uDpvN world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild   R   ] media-libs/libmpeg3-1.5.2-r3  USE="(-mmx*)" 0 kB
[ebuild   R   ] media-sound/jack-audio-connection-kit-0.101.1-r1  USE="alsa (-altivec) -caps (-coreaudio) -cpudetection -debug -doc -jack-tmpfs (-mmx*) -netjack -oss -portaudio -sndfile (-sse*)" 0 kB
[ebuild   R   ] media-video/mjpegtools-1.8.0-r1  USE="X png quicktime sdl v4l (-3dnow) -dga -dv -gtk (-mmx) (-sse*) -yv12" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 0 kB
io provo e vediamo cosa succede ...

/EDIT2: niente, dopo aver cambiato profilo ho aggiornato tutto e ho ricompilato kaffeine ma da gli stessi problemi :(
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Apr 25, 2007 10:23 am    Post subject: Reply with quote

OK, scusate se faccio un nuovo post invece di editare il precedente ma non ci capisco più nulla ... adesso ho provato e sia scummvm che dosbox non funzionano e devo killarli con -9 altrimenti non si smuovono ... e fino a domenica sera funzionavano correttamente e come si vede
Code:
# genlop --date 04/22/2007 -l
 * dev-util/ccache

     Sun Apr 22 09:24:58 2007 >>> dev-util/ccache-2.4-r7
     Tue Apr 24 07:35:06 2007 >>> sys-fs/dosfstools-2.11-r1
     Tue Apr 24 07:41:48 2007 >>> dev-util/cmake-2.4.6
     Wed Apr 25 09:20:13 2007 >>> media-libs/xine-lib-1.1.4-r2
     Wed Apr 25 09:24:56 2007 >>> media-video/kaffeine-0.8.3
     Wed Apr 25 10:38:48 2007 >>> media-libs/alsa-lib-1.0.14_rc1
     Wed Apr 25 10:39:23 2007 >>> media-plugins/gst-plugins-alsa-0.10.11
     Wed Apr 25 10:39:31 2007 >>> media-sound/alsa-headers-1.0.14_rc1
     Wed Apr 25 10:39:59 2007 >>> media-sound/alsa-utils-1.0.14_rc1
     Wed Apr 25 11:02:23 2007 >>> media-video/kaffeine-0.8.3
     Wed Apr 25 11:58:16 2007 >>> media-libs/libmpeg3-1.5.2-r3
     Wed Apr 25 11:59:06 2007 >>> media-sound/jack-audio-connection-kit-0.101.1-r1
     Wed Apr 25 12:01:07 2007 >>> media-video/mjpegtools-1.8.0-r1
     Wed Apr 25 12:06:10 2007 >>> media-video/kaffeine-0.8.3
da domenica sera a questa mattina ho compilato dosfstools (perchè avevo dei problemi con la chiavetta usb) e poi dando l'aggiornamento quotidiano ho aggiornato cmake poi questa mattina ho iniziato a ricompilare xine-lib e kaffeine sperando di risolvere ma senza risultati
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Apr 25, 2007 11:00 am    Post subject: Reply with quote

ti posto le mie versioni di xine-lib, kaffeine ed amarok con relative flag use abilitate, probabilmente sarà dovuto a qualche flag use
Code:

 eix -I amarok
[I] media-sound/amarok
     Available versions:  1.4.4-r3 1.4.5-r1 [M]**9999-r1
     Installed versions:  1.4.5-r1(08:20:36 04/21/07)(aac arts -daap debug -elibc_FreeBSD ifp ipod kde -linguas_af -linguas_ar -linguas_az -linguas_bg -linguas_br -linguas_ca -linguas_cs -linguas_cy -linguas_da -linguas_de -linguas_el -linguas_en_GB -linguas_es -linguas_et -linguas_fa -linguas_fi -linguas_fr -linguas_ga -linguas_gl -linguas_he -linguas_hi -linguas_hu -linguas_is linguas_it -linguas_ja -linguas_ka -linguas_km -linguas_ko -linguas_lt -linguas_ms -linguas_nb -linguas_nl -linguas_nn -linguas_pa -linguas_pl -linguas_pt -linguas_pt_BR -linguas_ro -linguas_ru -linguas_rw -linguas_se -linguas_sk -linguas_sl -linguas_sq -linguas_sr -linguas_sr@Latn -linguas_sv -linguas_ta -linguas_tg -linguas_th -linguas_tr -linguas_uk -linguas_uz -linguas_zh_CN -linguas_zh_TW mtp -musicbrainz -mysql njb noamazon opengl postgres -real visualization xinerama)
     Homepage:            http://amarok.kde.org/
     Description:         Advanced audio player based on KDE framework.

eix -I kaffeine
[I] media-video/kaffeine
     Available versions:  0.7.1-r2 0.8.3 ~0.8.4
     Installed versions:  0.8.3(00:38:00 04/23/07)(-arts -debug -dvb -elibc_FreeBSD encode gstreamer kdehiddenvisibility vorbis xinerama)
     Homepage:            http://kaffeine.sourceforge.net/
     Description:         Media player for KDE using xine and gstreamer backends.

eix -I xine-lib
[I] media-libs/xine-lib
     Available versions:  (1)  1.1.2-r3 1.1.3 1.1.4-r2 ~1.1.6
     Installed versions:  1.1.4-r2(1)(23:37:25 04/22/07)(X a52 -aac -aalib alsa -altivec -arts -debug -directfb -dts dvd dxr3 esd -fbcon flac -gnome gtk -imagemagick ipv6 -libcaca mad -mmap mng modplug -musepack nls opengl oss -pulseaudio -samba sdl -speex -theora truetype -v4l vcd vidix vorbis -wavpack win32codecs -xcb xinerama xv -xvmc)
     Homepage:            http://xine.sourceforge.net/
     Description:         Core libraries for Xine movie player

ciauz
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Apr 25, 2007 11:07 am    Post subject: Reply with quote

Vado principalmente a naso perché non ho idee "serie": prova a ricompilare i pacchetti alsa che hai sul sistema e con alsaconf risistema la configurazione; la peggiore delle idee che mi vengono in mente è quella di spazzare via le impostazioni e ricrearle, magari è qualche variabile di KDE (usi KDE, giusto?) che rovina tutto.
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Apr 25, 2007 12:10 pm    Post subject: Reply with quote

Quello che mi stranisce è che non sono cambiate USE e alsa funziona, mplayer e hydrogen funzionano alla perfezione ...
Vedrò di fare altre prove ma brancolo al buio, ad un certo punto ha smesso di funzionare :(
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Thu Apr 26, 2007 6:42 pm    Post subject: Reply with quote

Dopo un drastico
Code:
emerge -e world
738 pacchetti compilati e 20 ore macchina ho ripristinato la situazione corretta.
Tutto funziona come dovrebbe, solo due particolari offuscano una completa vittoria:
- alcune voci nel menu di kde sono finite nella sezione "Oggetti smarriti"
- in stile Gentoo mi piacerebbe capire cos'è successo e far si che la macchina faccia quello che voglio io e non dover subire lo stile windows con le reinstallazioni immotivate

Quindi preferirei non mettere [risolto] fino a quando non sarò riuscito a comprendere cosa si è rotto e cosa sarebbe bastato per sistemarlo, magari con il vostro aiuto.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Thu Apr 26, 2007 8:37 pm    Post subject: Reply with quote

Spostato dal Forum di discussione italiano al Forum italiano (Italian).

Direi che e' la sezione adatta :)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Fri Apr 27, 2007 12:51 am    Post subject: Reply with quote

Ma un revdep-rebuild prima di lanciare la ricompilazione di massa?
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Fri Apr 27, 2007 5:41 am    Post subject: Reply with quote

MeMyselfAndI wrote:
Ma un revdep-rebuild prima di lanciare la ricompilazione di massa?

Ci avevo provato ma non mi trovava nulla da ricompilare... (sarò paranoico ma nel mio script di aggiornamento c'è anche un bel revdep-rebuild -p)
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
al1ta
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2005
Posts: 77

PostPosted: Wed May 09, 2007 11:40 pm    Post subject: Reply with quote

scusate un attimo .... ma siete riusciti a utilizzare xine e kaffeine per sentire l'audio con il DVB-T ????

io ho lo stesso problema.... con xine e kaffeine vedo il video ma non sento l'audio. con mplayer mi funziona tutto.


Questo perchè come mi è stato detto con il dvb il segnale audio è assieme al video e il fatto che in kaffeine e xine non si senta l'audio dipende dalla mancanza di un codec. kaffeine si collega a xine quindi sisolto uno risolto anche l'altro

dunque non è un problema di scheda audio o configurazione alsa. E' la mancanza di un codec audio


E' un peccato perchè kaffeine è una figata... comunque se qualcuno vuole fare il gioco delle differenze... io ci sto ancora provando.....

queste è il mio mplayer dove il dvb-t funziona.....

[ebuild R ] media-video/mplayer-1.0.20070321 USE="3dnow X a52 aac alsa arts cdparanoia dga directfb dts dv dvb dvd dvdread encode esd gif gtk iconv ipv6 jpeg lzo mp3 opengl png samba sdl svga truetype unicode v4l v4l2 vorbis win32codecs x264 xinerama xv xvid -3dnowext -aalib (-altivec) -amr -bidi -bindist -bl -cddb -cpudetection -custom-cflags -debug -doc -dvdnav -enca -fbcon -ftp -ggi -ivtv -jack -joystick -libcaca -lirc -live -livecd -mad -md5sum -mmx -mmxext -mp2 -musepack -nas -openal -oss -pnm -quicktime -radio -rar -real -rtc -speex -srt -sse -sse2 -tga -theora -tivo -vidix -xanim -xvmc -zoran" VIDEO_CARDS="mga s3virge tdfx vesa" 0 kB
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Thu May 10, 2007 5:31 am    Post subject: Reply with quote

Io mi guardo e mi registro il digitale terrestre (DVB-T) con kaffeine da diversi mesi e l'unica volta che ho avuto un problema con l'audio è stato quando ho aperto questo post. Ancora purtroppo non sono riuscito a capirne le cause ma dopo una brutale ricompilazione del mondo ha ripreso ad funzionare alla meraviglia.

Se apri un'altra discussione (qui mi sa che andiamo OT) cerco di aiutarti volentieri.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum