Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: suddenly: X version mismatch -detected X.org 1.3.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 720
Location: 2074/SYD/NSW/AU

PostPosted: Tue Apr 24, 2007 9:36 pm    Post subject: [SOLVED]: suddenly: X version mismatch -detected X.org 1.3.0 Reply with quote

Hi guys,

having been running months and months on Xorg 7.2 with my mactel box using fglrx I suddenly find this morning that I can't start X!

I am getting the error:

Code:

[atiddxSetup] X version mismatch - detected X.org 1.3.0.0, required X.org 7.1.0.0
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.


I have tried to use the ati and radeon drivers in my xorg.conf but to no avail.

The X server shows X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3

When I query my Xorg I get:

Code:

equery which xorg-x11
/usr/portage/x11-base/xorg-x11/xorg-x11-7.2.ebuild


emerge -p xorg-x11 reveals that the version I have is indeed 7.2 and not in need of installing.

[ebuild R ] x11-base/xorg-x11-7.2

What has happened here? I have been doing regular world emerge updates

Sorry for less detail than normal - I have no x to cut and paste with...
_________________
\\'
ab extra
ab aeterno
a posse ad esse
ad fontes
\\'


Last edited by stardotstar on Tue Apr 24, 2007 11:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 988
Location: Bangalore, India

PostPosted: Tue Apr 24, 2007 9:57 pm    Post subject: Reply with quote

Check which version of xorg-server u have
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 720
Location: 2074/SYD/NSW/AU

PostPosted: Tue Apr 24, 2007 10:39 pm    Post subject: Reply with quote

OK correct:

equery which xorg-server
/usr/portage/x11-base/xorg-server-1.3.0.0.ebuild

emerge -p xorg-server

[ebuild R ] x11-base/xorg-server-1.3.0.0

so... do I have to reselect the version of the server I am running?? what has happened here, given that it was all working prior to my last emerge update (I can only think that that was when it all changed.)

I'm trying an emerge -C xorg-server and emerge xorg-x11 again to see what happens - doubt it;ll be any diff..
_________________
\\'
ab extra
ab aeterno
a posse ad esse
ad fontes
\\'
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 988
Location: Bangalore, India

PostPosted: Tue Apr 24, 2007 10:50 pm    Post subject: Reply with quote

Yes recently the xorg-server1.3 was released which is marked unstable but still many people like me use it
and it has some problems with problems with ati drivers i think becoz of changed versioning
There is a workaround for this in the forums.
U either have to go to the previous versions or use this workaround
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 720
Location: 2074/SYD/NSW/AU

PostPosted: Tue Apr 24, 2007 11:16 pm    Post subject: Reply with quote

Thank you and apologies for not finding the good link which is my exact problem :oops:

I am doing the major and minor opt rebuild now and will report back...

Will
_________________
\\'
ab extra
ab aeterno
a posse ad esse
ad fontes
\\'
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 720
Location: 2074/SYD/NSW/AU

PostPosted: Tue Apr 24, 2007 11:29 pm    Post subject: Reply with quote

perfect
_________________
\\'
ab extra
ab aeterno
a posse ad esse
ad fontes
\\'
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Wed Apr 25, 2007 12:13 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.

[mod]Moved in favour of this thread.[/mod]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum