Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE crash on a new system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Fri Apr 20, 2007 3:15 pm    Post subject: KDE crash on a new system Reply with quote

Hi all

I have built my new client, with KDE 3.5.5, and today was the second time in about a week or so when KDE all of a sudden crashed - I was thrown back to the prompt (I start X manually).

Here are the lines that were printed out:
Code:
Backtrace:
0: X(xf86SigHandler+0xa9) [0x80bf0b5]

Fatal server error:
Caught signal 11.  Server aborting

kmix: Fatal IO error: client killed
ksmserver: Fatal IO error: client killed
kded: Fatal IO error: client killed
kio_uiserver: Fatal IO error: client killed
klipper: Fatal IO error: client killed
yakuake: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 6707, errno = 0
kwin: Fatal IO error: client killed
kdesktop: Fatal IO error: client killed
kicker: Fatal IO error: client killed
kaccess: Fatal IO error: client killed
knotify: Fatal IO error: client killed
firefox-bin: Fatal IO error 104 (Die Verbindung wurde vom Kommunikationspartner zurüetzt) on X server :0.0.
In file kernel/qpixmap_x11.cpp, line 633: Out of memory
In file kernel/qpixmap_x11.cpp, line 633: Out of memory
In file kernel/qpixmap_x11.cpp, line 633: Out of memory
kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
ICE default IO error handler doing an exit(), pid = 7869, errno = 0
xinit:  connection to X server lost.
*** kdesktop got signal 1 (Exiting)
kicker: sighandler called
DCOP Cleaning up dead connections.
klauncher: Exiting on signal 1
kdeinit: sending SIGTERM to children.
kicker: sighandler called
GOT SIGHUP
kdeinit: Exit.


I don't have Beryl or anything else unstable on my box - well, some unstable, but only minor apps; here is emerge --info:
Code:
Portage 2.1.2.2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo-r6 i686)
=================================================================
System uname: 2.6.20-gentoo-r6 i686 Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 19 Apr 2007 15:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=nocona -pipe -fomit-frame-pointer -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-Os -march=nocona -pipe -fomit-frame-pointer -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo http://gentoo.mirror.solnet.ch "
LANG="de_CH.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa amarok apm asf audiofile bash-completion berkdb bitmap-fonts bzip2 cairo cddb cdparanoia cdr cjk cli cracklib crypt css cups curl curlwrappers dbm dbus dga directfb divx dri dts dv dvd dvdnav dvdr dvdread encode exif fam fame fbcon ffmpeg firefox flac foomaticdb fortran ftp gd gdbm gif gimpprint gmail gphoto2 gpm graphviz gstreamer hal hddtemp icons iconv iee1394 imagemagick imap imlib ipod ipv6 isdnlog ithreads jabber java javascript jpeg jpeg2k kde kdm kqemu lame latex libg++ libnotify libwww live lm_sensors logitech-mouse logrotate mad midi mikmod mime mmx mng mp3 mpeg mplayer musepack mysql ncurses nls nptl nptlonly nsplugin ntfs nvidia odbc ofx ogg opengl pam pcre pdf perl php png ppds pppd python qt3 qt4 quicktime readline real realmedia reflection samba sasl scanner sdl sensord session slang sndfile sox speex spell spl sse sse2 ssl subtitles svg svga syslog tcpd tetex theora tidy tiff toolbar truetype truetype-fonts type1-fonts unicode usb v4l vcd videos vidix vim vim-syntax vorbis webdav win32codecs wmf wmp x86 xcomposite xface xfs xine xml xorg xpm xsl xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Any ideas?
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Fri Apr 20, 2007 6:27 pm    Post subject: Reply with quote

Try running memtest86 to rule out RAM failure. Try emerging gcc or recompiling a kernel with MAKEOPTS="-j10" to stress-test the CPU.
If that doesn't crash, try re-emerging xorg-server and libX11.. If that fails, try replacing -Os with -O2 and re-emerging xorg-server and anything in the x11-base and x11-libs category.
I recommend against using -Os on a desktop - several packages have had trouble with it over time, and -O2 should perform better for desktop workloads on CPUs with sizeable level 2 caches like the Core 2 Duo. -Os makes a lot of sense on embedded and i586 architectures, as well as on SMP systems where the CPUs communicate over the FSB (not the case with Intel dual core systems).
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Fri Apr 20, 2007 6:45 pm    Post subject: Reply with quote

Thanks - I'll go for the -Os option, then, because the rest is pretty much ruled out. :)
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Tue May 01, 2007 8:55 am    Post subject: Reply with quote

Hmm - I recompiled as recommended, but today KDE crashed again with a similar message...

Any other thoughts?
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Wed May 02, 2007 6:28 pm    Post subject: Reply with quote

Again a crash!

Here's the output from the console (after I am back there):

Code:
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806fe10 ): KAccel object already contains an action name "dec_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806fe10 ): KAccel object already contains an action name "select_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806fe10 ): KAccel object already contains an action name "delete"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806fe10 ): KAccel object already contains an action name "edit"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806fe10 ): KAccel object already contains an action name "display_message"
X Error: BadWindow (invalid Window parameter) 3
Major opcode:  20
Minor opcode:  0
Resource id:  0xa00029
X Error: BadWindow (invalid Window parameter) 3
Major opcode:  20
Minor opcode:  0
Resource id:  0xa00029
X Error: BadWindow (invalid Window parameter) 3
Major opcode:  19
Minor opcode:  0
Resource id:  0xa00029
QPainter::setPen: Will be reset by begin()
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OPENSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.8: undefined symbol: OpenSSL_add_all_algorithms_conf
beryl: pixmap 0x3000477 can't be bound to texture
QPainter::restore: Empty stack error
QPainter::restore: Empty stack error
QPainter::restore: Empty stack error
kio (KIOConnection): ERROR: Could not write data
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KLauncher): ERROR: SlavePool: No communication with slave.

Backtrace:
0: X(xf86SigHandler+0x85) [0x80cc5d3]

Fatal server error:
Caught signal 11.  Server aborting

kmix: Fatal IO error: client killed



HELP! :cry:
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
firex
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 145
Location: Hamburg

PostPosted: Wed May 23, 2007 8:52 am    Post subject: Reply with quote

after update kded crashes for me too.
:-(
if i start it manualy it crashes after some time again :-(
i found out this have some problems with libcrypto.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum