Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge mysql-ruby-2.7.3 error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
gentunian
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2006
Posts: 118
Location: Río Cuarto, Argentina

PostPosted: Fri Apr 20, 2007 5:39 am    Post subject: emerge mysql-ruby-2.7.3 error Reply with quote

Hello everybody,

Well, this is weird, i never heard about the /bin/install command, do you?

Here's the error:
Quote:

>>> Install mysql-ruby-2.7.3 into /var/tmp/portage/dev-ruby/mysql-ruby-2.7.3/image/ category dev-ruby
mkdir -p /var/tmp/portage/dev-ruby/mysql-ruby-2.7.3/image//usr/lib64/ruby/site_ruby/1.8/x86_64-linux
/bin/install -c -m 0755 mysql.so /var/tmp/portage/dev-ruby/mysql-ruby-2.7.3/image//usr/lib64/ruby/site_ruby/1.8/x86_64-linux
make: /bin/install: Command not found
make: *** [/var/tmp/portage/dev-ruby/mysql-ruby-2.7.3/image//usr/lib64/ruby/site_ruby/1.8/x86_64-linux/mysql.so] Error 127

!!! ERROR: dev-ruby/mysql-ruby-2.7.3 failed.
Call stack:
ebuild.sh, line 1614: Called dyn_install
ebuild.sh, line 1060: Called qa_call 'src_install'
environment, line 3246: Called src_install
mysql-ruby-2.7.3.ebuild, line 37: Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-ruby/mysql-ruby-2.7.3/temp/build.log'.


I recently done an emerge --sync, and when i was doing the update i got the error message above. I know were the error is, i think it's too visible here, but, what the /bin/install command is? It's my first time i saw it. Maybe a makefile error? Well, if anyone could help...thanks a lot. Anyway, im not depending on that, so it's not a big deal.

Regards,
_________________
Si un pueblo tiene hambre, no le des un pez. Enséñale a pescar.
http://labombiya.com.ar
Back to top
View user's profile Send private message
gentunian
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2006
Posts: 118
Location: Río Cuarto, Argentina

PostPosted: Fri Apr 20, 2007 5:45 am    Post subject: emerge mysql-ruby-2.7.3 error [SOLVED] Reply with quote

Well, sorry for that post, here its the solution:

Code:
# which install
/usr/bin/install
# ln -s /usr/bin/install /bin/install


Anyway, i think that the scrip should do that. Thanks, and sorry for this post.
_________________
Si un pueblo tiene hambre, no le des un pez. Enséñale a pescar.
http://labombiya.com.ar
Back to top
View user's profile Send private message
SuperMe
n00b
n00b


Joined: 30 May 2005
Posts: 25
Location: London, UK

PostPosted: Sat Apr 21, 2007 4:58 pm    Post subject: Reply with quote

I had this problem as well and fixed it the same way. I think it must be a problem with mysql-ruby-2.7.3 as I haven't encountered this issue with any other ebuild.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Apr 24, 2007 7:35 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-553563.html
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum