Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] XDM Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Miatrix
n00b
n00b


Joined: 11 Apr 2007
Posts: 19

PostPosted: Fri Apr 13, 2007 7:41 pm    Post subject: [Solved] XDM Problem Reply with quote

Happy Friday 13'th to me! :evil:

I've set up gentoo with X.org and enlightenment and all that belongs.

Just as everything starts to behave and works great something odd starts to happen.

After I shut down the laptop at work (where it works perfectly) first boot from home crashes X. It starts up XDM which is default in RC which then starts entrance to login - here it still works.
Now, after logging in entrance it just refuses to start enlightenment, but enlightenment is NOT the problem.

The screen just flickers like X is starting but cant, and then restarts over and over again.

But if I delete XDM from RC and starts it manually by issuing the command /etc/init.d/xdm start , it works wonderful. starts up entrance and logging in starts up enlightenment.

This is taken from dmesg and these exact lines is write over and over again until I stop X with CTRL+C.

Code:

mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
[drm] Setting GART location based on new memory map
[drm] writeback test succeeded in 2 usecs


Whenever I stop it with CTRL+C it blinks a few times and starts up entrance in a lower resolution.

This is as much info as I have been able to get, from here im just stuck.

Any kind of help or hints are more than welcome. :?


Last edited by Miatrix on Fri Apr 13, 2007 8:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
Miatrix
n00b
n00b


Joined: 11 Apr 2007
Posts: 19

PostPosted: Fri Apr 13, 2007 8:36 pm    Post subject: Reply with quote

Solution: Change hostname back to what it was before X started crashing! :!:

It works.. but why?:?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Fri Apr 13, 2007 11:09 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, as indicated in the topic "Xorg doesn't accept new connection", specifically post 4008020.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum