Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema no CUPS impressora paralela
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
LuisCO
n00b
n00b


Joined: 09 Feb 2006
Posts: 51

PostPosted: Fri Apr 06, 2007 1:00 pm    Post subject: Problema no CUPS impressora paralela Reply with quote

Quando estou instalando a impressora "local (paralela, serial, USB)", a URI encontrada é parallel:/dev/unknown-parallel0, sigo adiante instala mas não imprime nada.
Como impressora TCP que é de fato o caso aqui já que funciona tudo via "ltsp", a paralela também não funciona.

Já tentei trocar para /dev/lp0 manualmente, a instalação termina com sucesso, mas, também não imprime nada, no log não aparecem erros, apenas mostra que foi enviado uma impressão como se tivesse acontecido a impressão.

O que notei comprando com o meu de casa é que quando coloco uma impressora paralela e vou instalar ele já reconhece que esta conectada, como se trata de uma hp igual nos dois lugares acredito que deveria ter o mesmo comportamento, apesar de a necessidade ser uma lx300 que imagino não reconheça mesmo, estou testando com a hp. Tenho o hpijs instalado nos dois micros.

Atualizei o cups para 1.2.8 e 1.2.9, não houve melhoras e apareceram alguns outros probleminhas mesmo nas impressora usb, imagino que não seja um problema com a versão então voltei à anterior.

Impressoras USB acham a "URI: usb:/dev/usb/lp0", e funcionam normalmente; instalei uma hp e uma samsung com grande facilidade.

Se alguem tiver uma dica seria otimo, se precisarem de mais informações informem.

Desde já agradeço a colaboração.
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sat Apr 07, 2007 7:05 am    Post subject: Re: Problema no CUPS impressora paralela Reply with quote

LuisCO wrote:
Quando estou instalando a impressora "local (paralela, serial, USB)", a URI encontrada é parallel:/dev/unknown-parallel0, sigo adiante instala mas não imprime nada.


Nem vai, o cups não achou a impressora.

Quote:
Como impressora TCP que é de fato o caso aqui já que funciona tudo via "ltsp", a paralela também não funciona.


Que frase confusa.

Quote:
O que notei comprando com o meu de casa é que quando coloco uma impressora paralela e vou instalar ele já reconhece que esta conectada, como se trata de uma hp igual nos dois lugares acredito que deveria ter o mesmo comportamento, apesar de a necessidade ser uma lx300 que imagino não reconheça mesmo, estou testando com a hp. Tenho o hpijs instalado nos dois micros.


Use o hplip.

Quote:
Atualizei o cups para 1.2.8 e 1.2.9, não houve melhoras e apareceram alguns outros probleminhas mesmo nas impressora usb, imagino que não seja um problema com a versão então voltei à anterior.


Minha experiência me diz que isso não é problema do cups em si.

Quote:
Impressoras USB acham a "URI: usb:/dev/usb/lp0", e funcionam normalmente; instalei uma hp e uma samsung com grande facilidade.


hm...

Isso parece ser driver.

Primeiramente veja se todos os módulos necessários para se usar uma impressora paralela estão carregados, os necessários são: lp, parport e parport_pc . Se não estão então carregueos e reinicie o cups.

Se a impressora é HP então todos os drivers necessários para elas devem estar instalados, mas tão existem os pacotes foomatic-db-ppds e o pacote gimp-print (não esqueça de habilitar a use ppds) que fornecem drivers para outras impressoras, talvez inclusive para a lx300.

Se a lx300 não tiver um driver específico teste com um driver parecido.

E, apesar de tudo que eu disse, siga isso: http://www.gentoo.org/doc/en/printing-howto.xml
_________________
Coisas que todo usuário de gentoo tem que saber:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2
http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum