Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg + ATI9250 - Problemas com Instalação e configuração
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
dltn-br
n00b
n00b


Joined: 02 Feb 2007
Posts: 3
Location: Belo Horizonte / Brasil

PostPosted: Thu Apr 05, 2007 10:24 am    Post subject: Xorg + ATI9250 - Problemas com Instalação e configuração Reply with quote

Olá pessoal,

sou novo em Linux e estou tentando instalar o Gentoo, depois de usar o Ubuntu por alguns meses. E tá difícil!
Consegui instalar o Gentoo seguinto o manual pra AMD64 e agora estou com um problema na hora de configurar o xorg. Tenho uma ATI 9250.
Cometi alguns erros na instalação que não consigo desfazer.
Erro 1: Instalei o xorg sem ter alterado no meu /etc/make.conf as flags:

Code:
INPUT_DEVICE="mouse keyboard"
VIDEO_CARDS="fglrx radeon"


Erro 2: Instalei primeiro o xorg e depois os drivers da ati, o que acho que foi errado.

Depois que eu vi que tinha feito isso, pensei que poderia desinstalar o xorg e os ati-drivers e instalar denovo.
Depois de alguns emerges e unmerges, reiniciei meu computador e vi que

1) minha resolução estava bem menor que o normal.

2) não consigo configurar o xorg usando o comando
Code:
# X -configure

que retorna um crash com signal error 11.

Tentei usar o meu xorg.conf que é usado no meu Ubuntu (só pra ver no que ia dar) e também não funcionou. Gostaria de colar os erros aqui pra vocês, mas quando dou um
comando > arquivo.txt, olho o arquivo na pasta em que o salvei e ele está vazio.

Aqui vai o xorg.conf que o X -configure criou automaticamente:
Code:

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/share/X11/rgb"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/CID/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "extmod"
   Load  "dbe"
   Load  "record"
   Load  "xtrap"
   Load  "dri"
   Load  "glx"
   Load  "freetype"
   Load  "type1"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/mouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
   Identifier  "Card0"
   Driver      "vesa"
   VendorName  "ATI Technologies Inc"
   BoardName   "RV280 [Radeon 9200 PRO]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



log:

http://pastebin.ca/425234
Se alguém puder me ajudar nessa, vou ficar muito grato!
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sat Apr 07, 2007 6:53 am    Post subject: Re: Xorg + ATI9250 - Problemas com Instalação e configura Reply with quote

dltn-br wrote:
Olá pessoal,

sou novo em Linux e estou tentando instalar o Gentoo, depois de usar o Ubuntu por alguns meses. E tá difícil!


Com calma tudo se resolve.

Quote:
Consegui instalar o Gentoo seguinto o manual pra AMD64 e agora estou com um problema na hora de configurar o xorg. Tenho uma ATI 9250.
Cometi alguns erros na instalação que não consigo desfazer.
Erro 1: Instalei o xorg sem ter alterado no meu /etc/make.conf as flags:

Code:
INPUT_DEVICE="mouse keyboard"
VIDEO_CARDS="fglrx radeon"



Não tem problema, nada que não se arrume depois.

Quote:
Erro 2: Instalei primeiro o xorg e depois os drivers da ati, o que acho que foi errado.


De madeira nenhuma, pelo contrário, que nexo tem você instalar um driver específico para o xorg se você não tem nem o xorg rodando com um driver genérico. Inclusive se você fizesse isso veria que o ati-drivers instalaria o xorg como dependência.

Quote:

Depois que eu vi que tinha feito isso, pensei que poderia desinstalar o xorg e os ati-drivers e instalar denovo.
Depois de alguns emerges e unmerges, reiniciei meu computador e vi que

1) minha resolução estava bem menor que o normal.

2) não consigo configurar o xorg usando o comando
Code:
# X -configure

que retorna um crash com signal error 11.


Que confusão, não precisava ter feito nada disso.

Quote:
Tentei usar o meu xorg.conf que é usado no meu Ubuntu (só pra ver no que ia dar) e também não funcionou. Gostaria de colar os erros aqui pra vocês, mas quando dou um
comando > arquivo.txt, olho o arquivo na pasta em que o salvei e ele está vazio.


Isso acontece porque todo programa tem uma saída padrão para as mensagens de informação ao usuário e uma para a saída de erros, e fazendo o redirecionamento ">" você redireciona apenas as mensagens comuns. Para redirecionar apenas as mensagens de erro você usa "2>". Exemplo: "X 2> erros-do-x.log". Você ainda pode fazer "emerge xorg > build.log 2> erros.log". Também é possível colocar os dois para o mesmo arquivo. Mas existe uma forma mais prática, usando o "&>". Assim todas as mensagens vão para o arquivo especificado.

Então, vejo que você se atrapalhou porque precisou usar conhecimentos que você vai adquirir lendo a parte 2 do handbook, "trabalhando com o gentoo". Veja a minha assinatura abaixo.

Rapidamente, só para reforçar o que você vai ler: para "consertar" o seu sistema você pode rodar o comando "emerge --update --deep --newuse world", isso vai fazer com que todos os pacotes que tenham alguma dependência não instalada (que é o que eu imagino que seja o caso do xorg) ou que tenham algo para habilitar que não esteja habilitado farão isso neste momento. Recomendo adicionar os parâmetros "--pretend" e "--verbose" ao rodar o comando que mencionei para ver o que o portage pretende fazer e depois retirar esses parâmetros para que ele efetivamente faça o que promete.

Quando você alterou a variável do make.conf que especifica o driver de vídeo você deveria ter rodado "emerge --update --deep --newuse xorg-x11" para que as novas dependências do xorg fossem instaladas, mas isso já vai acontecer quando você rodar esse mesmo comando para o "world".

Então é isso, tenta isso e depois volta ao howto do X pra ver se funciona. Depois tentar configurar o fglrx pelo ati-faq. Mas é imprescindível que você leia o quanto antes a parte 2 do handbook, ela vai lhe explicar coisas primordiais do funcionamento do gentoo. Depois (alguns dias depois) vá para a parte 3 para aprender mais a fundo, mas se você não entender alguma coisa não se extresse, volte outro dia e leia de novo. Qualquer coisa é só voltar no fórum.

Dica 1: Não use a documentação em português, ela está terrivelmente desatualiada. Para ver se uma tradução está desatualizada observer o canto superior direito (em cima da barra azul) de uma doc, lá terá uma observação sobre a última atualização da versão original.

Dica 2: Entre para a lista de discussão dos usuarios brasileiros de gentoo, lá o pessoal é muito bom e responde sua dúvida bem mais rápido. É só mandar um mail gentoo-user-br+subscribe@gentoo.org .

E é isso aí, qualquer coisa grita.
_________________
Coisas que todo usuário de gentoo tem que saber:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2
http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum