Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con modulo speedstep-smi [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
misterwine
Guru
Guru


Joined: 14 Nov 2005
Posts: 341
Location: Zelarino (VE)

PostPosted: Fri Mar 30, 2007 12:12 pm    Post subject: Problema con modulo speedstep-smi [Risolto] Reply with quote

Ho seguito questa guida per la gestione energetica di un ibm thinkpad t22... qualche intoppo son riuscito a superarlo, però poi mi son bloccato quando tento di caricare il modulo cpufreq per la mia cpu, ovvero speedstep-smi. A dire il vero per poterlo compilare (come modulo) ho dovuto attivare
Code:
[*] Prompt for development and/or incomplete code/drivers

nel kernel, altrimenti nella lista dei driver cpufreq non compariva quello ke mi serve.
Fatto sta che comunque quando tento di caricarlo, l' errore che mi restituisce è:
Code:
FATAL: Error inserting speedstep_smi (/lib/modules/2.6.18-suspend2-r1/kernel/arch/i386/kernel/cpu/cpufreq/speedstep-smi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

e l' output di dmesg | tail è:
Code:
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Processor [CPU] (supports 8 throttling states)
Time: acpi_pm clocksource has been installed.
speedstep_smi: Unknown symbol ist_info
speedstep_smi: Unknown symbol ist_info
speedstep_smi: Unknown symbol ist_info
speedstep_smi: Unknown symbol ist_info

Dunque, può dipendere dal fatto che devo caricare altri moduli prima di questo? Se non sbaglio dovrebbe arrangiarsi... Inoltre ho anche provato a caricare prima il modulo speedstep-lib nel seguente modo:
Code:
speedstep-lib relaxed_check=1

ma non cambia nulla. Qualche idea per caso? Perchè io le ho finite :lol:
_________________
"Se in un primo momento l' idea non è assurda,
allora non c'è nessuna speranza che si realizzi." (A.Einstein)


Last edited by misterwine on Sat Mar 31, 2007 1:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
misterwine
Guru
Guru


Joined: 14 Nov 2005
Posts: 341
Location: Zelarino (VE)

PostPosted: Sat Mar 31, 2007 1:54 pm    Post subject: Reply with quote

Vi posto come ho risolto se per caso qualcuno dovesse incappare nello stesso identico problema... semplicemente ho ricompilato il kernel attivando
Code:
Power management options (ACPI, APM) ->CPU Frequency scaling  ---> [*]   Enable CPUfreq debugging

E ovviamente non carico direttamente il modulo speedstep-smi, ma come facevo anche prima, faccio
Code:
modprobe speedstep-lib relaxed_check=1
modprobe speedstep-smi

e l' output di cpufreq-info ora è:
Code:
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Report errors and bugs to linux@brodo.de, please.
analyzing CPU 0:
  driver: speedstep-smi
  CPUs which need to switch frequency at the same time: 0
  hardware limits: 700 MHz - 900 MHz
  available frequency steps: 900 MHz, 700 MHz
  available cpufreq governors: userspace
  current policy: frequency should be within 700 MHz and 900 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 900 MHz (asserted by call to hardware).

Raga, ke dura... non pensavo ke servisse compilare nel kernel anke quell' opzione... poi cercando in giro ho visto in quache config che anke quella era posta =y e ho provato... per fortuna è andata bene! :lol:
Bye
_________________
"Se in un primo momento l' idea non è assurda,
allora non c'è nessuna speranza che si realizzi." (A.Einstein)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum