Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[dri/i915/mesa/drm/agp] drmWaitVBlank returned -1(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Mar 28, 2007 10:14 am    Post subject: [dri/i915/mesa/drm/agp] drmWaitVBlank returned -1(résolu) Reply with quote

bonjour,

j'ai un petit soucis, que la commande glxinfo va décrire beaucoup mieux que moi :
Quote:

glxinfo
name of display: :0.0
libGL warning: 3D driver claims to not support visual 0x5b
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset.

display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2


Étrange cette bête. Je tombe sur ce bug, qui n'en est pas un... :? Et oui :
Bugzilla Bug 8722do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
le commentaire #7 me dit que je suis sauvé, :
Quote:
>> We didn't update the drm and i915 module for a long time, the related kernel
output
>> [drm] Initialized drm 1.1.0 20060810
>> ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
>> PCI: Setting latency timer of device 0000:00:02.0 to 64
>> [drm] Initialized i915-mm 1.7.0 20060929 on minor 0:

>Thanks. Could you try current git master? I don't really expect it to make a
>difference though.
it works! with the current git master, it won't report these information
Thanks for the help

>Also, what does

>grep i915 /proc/interrupts

>say?
This got nothing

>> And, we didn't got those environment variables set when we run the glxinfo.

>No vblank_mode entry in /etc/drirc or ~/.drirc either?

Yeah, we don't use those files at all.

Je n'ai pas compris ce qu'il faut faire, surtout que ce bug est marqué comme étant clos, et n'étant pas un bug!!
Je vous file des infos :
lspci
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

le noayau
Code:
zgrep -i "i915" /proc/config.gz
CONFIG_DRM_I915=y
Code:
zgrep -i "i810" /proc/config.gz
# CONFIG_DRM_I810 is not set
CONFIG_I2C_I810=y
CONFIG_FB_I810=y
# CONFIG_FB_I810_GTF is not set
Code:
zgrep -i "drm" /proc/config.gz
CONFIG_DRM=y
# CONFIG_DRM_TDFX is not set
# CONFIG_DRM_R128 is not set
# CONFIG_DRM_RADEON is not set
# CONFIG_DRM_I810 is not set
# CONFIG_DRM_I830 is not set
CONFIG_DRM_I915=y
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set
# CONFIG_DRM_VIA is not set
# CONFIG_DRM_SAVAGE is not set

Logs
Code:
grep -i "drm" /var/log/dmesg
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized i915 1.5.0 20060119 on minor 0
Code:
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
Code:
grep -i "02.0" /var/log/dmesg
 BIOS-e820: 000000001f6d3400 - 0000000020000000 (reserved)
Boot video device is 0000:00:02.0
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
Code:
Mar 28 08:35:40 lab-mparis [drm] Initialized drm 1.0.1 20051102
Mar 28 08:35:40 lab-mparis [drm] Initialized i915 1.5.0 20060119 on minor 0
Code:
grep -i "i915" /var/log/Xorg.0.log
        i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, E7221 (i915),
(II) I810(0): [drm] created "i915" driver at busid "pci:0000:00:02.0"
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
(II) I810(0): [drm] created "i915" driver at busid "pci:0000:00:02.0"
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
Code:
 grep EE /var/log/Xorg.0.log
Current Operating System: Linux lab-mparis 2.6.19-suspend2-r3 #3 SMP PREEMPT Sat Mar 24 11:52:19 CET 2007 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

make.conf
Code:
 grep -i "i810" /etc/make.conf
VIDEO_CARDS="i810 vesa vga"


merci.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Thu Mar 29, 2007 7:39 am; edited 3 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Mar 28, 2007 10:22 am    Post subject: Reply with quote

J'ai eu ce problème je crois bien, le DRM ne marchait pas avec la dernière version de x11-drm. Pour corriger ça, il faut soit utiliser le kernel git, soit patcher le kernel pour avoir la dernière version de agpgart (ce que j'ai fait). J'ai pris les patchs ici : http://sturmartillerie.org/portage/mesa-cvs/kernel-patch/
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Mar 28, 2007 10:25 am    Post subject: Reply with quote

Merci geekounet, juste une petite précision, lorsque tu parles de x11-drm, tu sous-entends le drivers dans portage ou du noyau. Dans mon cas, j'ai tout mis dans le noyau.

EDIt : aï aï aï, j'ai fait le bourrain, mon kernel 2.6.19-suspend2-r3, j'ai appliqué les patchs, et boom :
Code:
make && make modules_install && make install
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  CHK     include/linux/compile.h
  CC      drivers/char/agp/backend.o
  CC      drivers/char/agp/frontend.o
  CC      drivers/char/agp/generic.o
  CC      drivers/char/agp/isoch.o
  LD      drivers/char/agp/agpgart.o
  CC      drivers/char/agp/intel-agp.o
drivers/char/agp/intel-agp.c:1440: erreur: 'intel_i830_type_to_mask_type' undeclared here (not in a function)
make[3]: *** [drivers/char/agp/intel-agp.o] Erreur 1
make[2]: *** [drivers/char/agp] Erreur 2
make[1]: *** [drivers/char] Erreur 2
make: *** [drivers] Erreur 2
Faut dire aussi que je suis pas en mode RTFM et réflexion :lol:
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Mar 28, 2007 12:00 pm    Post subject: Reply with quote

MickTux wrote:
Merci geekounet, juste une petite précision, lorsque tu parles de x11-drm, tu sous-entends le drivers dans portage ou du noyau. Dans mon cas, j'ai tout mis dans le noyau.

Ceux de portage, ils sont bien plus à jour :)
(le driver i915 du kernel date de janvier 2006)
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Mar 29, 2007 7:39 am    Post subject: Reply with quote

Merci, c'est résolu avec les git-sources. Les patch ne passaient pas avec la version 19. J tenterai ce week-end avec une version 20.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Mar 29, 2007 9:47 am    Post subject: Reply with quote

MickTux wrote:
Merci, c'est résolu avec les git-sources. Les patch ne passaient pas avec la version 19. J tenterai ce week-end avec une version 20.

Oui ya 1 ou 2 patchs qui passent pas car déjà présent, donc pas trop grave :) Ça fonctionne bien chez moi sur un 2.6.20 :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum