Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ZSNES:no available graphics devices[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Tue Mar 27, 2007 11:34 pm    Post subject: ZSNES:no available graphics devices[SOLVED] Reply with quote

user:
/usr/games/bin/zsnes
ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
Unable to poll /dev/input/event3. Make sure you have read permissions to it.
Unable to poll /dev/input/event2. Make sure you have read permissions to it.
Unable to poll /dev/input/event1. Make sure you have read permissions to it.
Unable to poll /dev/input/event0. Make sure you have read permissions to it.
ManyMouse: 0 mice detected.
Could not set 512x448 video mode: No available video device

root:
/usr/games/bin/zsnes
ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
ManyMouse: 0 mice detected.
Could not set 512x448 video mode: No available video device


Can somebody give me a hand?
_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.


Last edited by Black Zer0 on Thu Apr 05, 2007 2:50 am; edited 2 times in total
Back to top
View user's profile Send private message
john_who
n00b
n00b


Joined: 14 Sep 2004
Posts: 28

PostPosted: Wed Mar 28, 2007 1:02 am    Post subject: Reply with quote

Edit ~/.zsnes/zsnesl.cfg and change cvidmode to something better, like 16 = 1024x896 ODR WIN.
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Wed Mar 28, 2007 1:18 am    Post subject: Reply with quote

This is what my video config looks like (I edited it just now)

Code:
; Video Mode [0..3]
;   0 = 256x224      R WIN     1 = 256x224      R FULL
;   2 = 640x480     DR FULL    3 = 1024x1280   DR FULL


And I still get the same error when I try to start up
Code:
/usr/games/bin/zsnes
ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
Unable to poll /dev/input/event3. Make sure you have read permissions to it.
Unable to poll /dev/input/event2. Make sure you have read permissions to it.
Unable to poll /dev/input/event1. Make sure you have read permissions to it.
Unable to poll /dev/input/event0. Make sure you have read permissions to it.
ManyMouse: 0 mice detected.
Could not set 512x448 video mode: No available video device

_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.
Back to top
View user's profile Send private message
john_who
n00b
n00b


Joined: 14 Sep 2004
Posts: 28

PostPosted: Wed Mar 28, 2007 11:25 am    Post subject: Reply with quote

Black Zer0 wrote:
This is what my video config looks like (I edited it just now)

Code:
; Video Mode [0..3]
;   0 = 256x224      R WIN     1 = 256x224      R FULL
;   2 = 640x480     DR FULL    3 = 1024x1280   DR FULL



Lines starting with ";" are comments in zsnesl.cfg.
You have to set "cvidmode" to a windowed mode.
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Wed Mar 28, 2007 3:06 pm    Post subject: Reply with quote

When I try to do cvidmode=16 it automaticaly changes back to 2...... :cry:
_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.
Back to top
View user's profile Send private message
bLUEbYTE84
Guru
Guru


Joined: 21 Jul 2006
Posts: 566
Location: universe.tar.gz, src/earth.h, struct homo_sapiens_table

PostPosted: Wed Mar 28, 2007 5:35 pm    Post subject: Reply with quote

Are you trying to run it on X environment? Also, post the output of
Code:
emerge -vp libsdl

Indicating green use flags if any.
_________________
Advanced Signature Camouflage System®(ASCS) v0.1
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Wed Mar 28, 2007 9:41 pm    Post subject: Reply with quote

Code:
emerge -vp libsdl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-libs/libsdl-1.2.11-r2 [1.2.11-r1] USE="alsa -X -aalib -arts -dga -directfb -esd -fbcon -ggi -libcaca -nas -noaudio -noflagstrip -nojoystick -novideo -opengl -oss -svga -xinerama -xv" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.


Last edited by Black Zer0 on Sun Apr 01, 2007 3:20 am; edited 1 time in total
Back to top
View user's profile Send private message
bLUEbYTE84
Guru
Guru


Joined: 21 Jul 2006
Posts: 566
Location: universe.tar.gz, src/earth.h, struct homo_sapiens_table

PostPosted: Wed Mar 28, 2007 10:09 pm    Post subject: Reply with quote

Dude, can't you see it can't use any video driver? Reemerging is no good as long as you don't set the needed USEFLAGS.
Plus, you don't answer what I asked :roll:
Add X and opengl to your useflags then (re)emerge

P.S your use flags seem weird(nothing is enabled). I suggest you to bring them to a sane state. Also check your profile. I'm assuming this is an X-enabled system. Since you don't provide the details, I'm only guessing.
_________________
Advanced Signature Camouflage System®(ASCS) v0.1
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Sun Apr 01, 2007 3:19 am    Post subject: Reply with quote

It is X-enabled(how can you use zsnes without X)

How and why do I check my profile? :oops:

EDIT: When I emerge -auvDN zsnes

Code:
Peter peter # emerge -auvDN zsnes

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] games-emulation/zsnes-1.51  USE="opengl -ao -custom-cflags -png" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.



It appears X isn't in zsnes' use and it should be
If X wasn't in my use at all would nothing graphic be able to work?
_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.
Back to top
View user's profile Send private message
Arek75
n00b
n00b


Joined: 11 Nov 2004
Posts: 25

PostPosted: Mon Apr 02, 2007 9:44 pm    Post subject: Reply with quote

Your use flags for libsdl (SDL) say "-X" above. X isn't in zsnes' use flags because zsnes does not itself use/require X. However, SDL (the library zsnes uses for display/input on linux) can be configured to use (or not use) X as a display/input target using the X useflag. It should be enough to add X to your useflags in make.conf and rebuild SDL. Adding opengl and X and rebuilding both SDL and zsnes will result in a decent framerate boost, as well.

Hope this answers your questions.

--Arek75
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Thu Apr 05, 2007 2:22 am    Post subject: Reply with quote

By sdl you mean libsdl right?

EDIT:Thank you very much your suggestion worked.
_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.
Back to top
View user's profile Send private message
Jesse305
n00b
n00b


Joined: 06 Apr 2007
Posts: 2

PostPosted: Fri Apr 06, 2007 3:35 am    Post subject: Reply with quote

There's been a ZNES out for Linux? I didn't even know, does anyone have the link?
_________________
Want a free, legitimate way to make cash online?
Sign up with link below and make cash today!
http://www.treasuretrooper.com/251289
Back to top
View user's profile Send private message
Black Zer0
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2007
Posts: 131
Location: Almonte Ontario Canada

PostPosted: Fri Apr 06, 2007 9:43 pm    Post subject: Reply with quote

If your on gentoo emerge it, keeping in mind that 1.51 is the latest version in portage(I.O.W, if you see it emerging a older one put emerge =zsnes-1.51)

If your not just go here.
_________________
Fluxbox ROX!!!

Tux has way too many lil' helpers in my opinion.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum