Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore Xorg/Kbd [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fejfbo
Guru
Guru


Joined: 30 May 2005
Posts: 407
Location: Milano - Italy

PostPosted: Tue Mar 27, 2007 5:12 pm    Post subject: Errore Xorg/Kbd [risolto] Reply with quote

Ciao a tutti, ho appena installato Gentoo su un nuovo portatile, ma dopo aver xorg e Kde (entrambi stabili), all'avvio di xorg controllando nei log trovo che non riesce a caricare il modulo "kbd" (penso sia relativo alla tastiera) causando il mancato avvio di quest'ultimo.

Cosa potrei controllare?


Last edited by fejfbo on Wed Mar 28, 2007 4:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Tue Mar 27, 2007 5:43 pm    Post subject: Reply with quote

Controlla di aver inserito, in /etc/make.conf, la variabile INPUT_DEVICES, e di valorizzarla almeno con i valori
Code:

INPUT_DEVICES="keyboard mouse"

Tutte le potenziali voci le vedi eseguendo
Code:

# emerge -pv xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.1.1-r4  USE="dri nptl sdl xorg (-3dfx) -aiglx -debug -dmx -ipv6 -kdrive -minimal -xprint" INPUT_DEVICES="keyboard mouse penmount -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="fbdev nv nvidia vesa -apm -ark -chips -cirrus -cyrix -dummy -epson -fglrx -glint -i128 (-i740) -i810 (-impact) (-imstt) -mach64 -mga -neomagic (-newport) (-nsc) -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vga -via -vmware -voodoo" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Nel tuo caso, comunque, per risolvere velocemente il problema, verifica se hai installato il pacchetto x11-drivers/xf86-input-keyboard (se non è installato, installalo, con l'opzione --oneshot, mi raccomando :roll: )
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
fejfbo
Guru
Guru


Joined: 30 May 2005
Posts: 407
Location: Milano - Italy

PostPosted: Tue Mar 27, 2007 5:46 pm    Post subject: Reply with quote

In effetti ora sto provando a ri-emergere xorg-server, però il mio make.conf già conteneva

Code:
INPUT_DEVICES="keyboard mouse"


non risultanto però installato il supporto alla tastiera!
Mi richiede inoltre di emergere anche il supporto per Ati!

Misteri :?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum