Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba non supporta più la flag mysql?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
diego_82
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 257
Location: Londra

PostPosted: Mon Mar 26, 2007 3:52 pm    Post subject: Samba non supporta più la flag mysql? Reply with quote

Come da oggetto, seguendo questo tutorial mi viene detto di usare la flag mysql, ma quando ad emerge di andare a fare il suo lavoro esce questo:
Quote:
localhost ~ # emerge -pvt samba

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild N ] net-fs/samba-3.0.24 USE="acl cups kerberos ldap oav pam python readline -async -automount -caps -doc -examples -fam -quotas (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl" 15,376 kB

Total: 1 package (1 new), Size of downloads: 15,376 kB


Dove cappero sta la flag +mysql???
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Mon Mar 26, 2007 4:04 pm    Post subject: Reply with quote

la flag mysql, non è più utilizzata in Samba dalla versione
Code:
samba-3.0.24
, ovvero da quella che stai installando.

però potrebbe anche essere stata tolta erroneamente, al tuo posto se non hai fretta attenderei qualche giorno per vedere se cambia qualcosa.

nb: la guida non sarà aggiornata all'ultima versione di samba, ma per il resto non vedo grandi problemi.



ciao


Last edited by crisandbea on Mon Mar 26, 2007 4:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
diego_82
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 257
Location: Londra

PostPosted: Mon Mar 26, 2007 4:12 pm    Post subject: Reply with quote

Ti ringrazio per le informazioni, ma posso ugualmente usare un database per immagazzinare i dati nonostante la flag non sia più supportata?
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Mar 26, 2007 4:20 pm    Post subject: Reply with quote

Uhm... da un'occhiata veloce sembra che il maintainer del pacchetto, facendo il revbump dell'ebuild, abbia rimosso (in)volontariamente il supporto a mysql.

Bugzilla non sembra dire nulla, nemmeno i vari Changelog. Che sia da aprire un bug report? :?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
diego_82
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 257
Location: Londra

PostPosted: Mon Mar 26, 2007 4:35 pm    Post subject: Reply with quote

Effettivamente ci stavo pensando, ma non credo di esserne all'altezza...
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Mar 26, 2007 5:14 pm    Post subject: Reply with quote

Non occorre nessun bug report, il chiarimento lo si trova nei messaggi di post-installazione della versione 3.0.22:

Code:

pkg_postinst() {
...
       einfo "As of 3.0.20: New USE flags: syslog, automount, async (default: disabled)"
       einfo "As of 3.0.20b: New USE flags: ldapsam, swat (default: disabled)"
       einfo "SQL and XML backends are *experimental*: sql is being deprecated"
...

Ovvero: il backend SQL sparirà (difatti le USE mysql e postgres sono state rimosse dalla 3.0.24[/b])
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
diego_82
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 257
Location: Londra

PostPosted: Mon Mar 26, 2007 5:34 pm    Post subject: Reply with quote

Scen wrote:
Non occorre nessun bug report, il chiarimento lo si trova nei messaggi di post-installazione della versione 3.0.22:

Code:

pkg_postinst() {
...
       einfo "As of 3.0.20: New USE flags: syslog, automount, async (default: disabled)"
       einfo "As of 3.0.20b: New USE flags: ldapsam, swat (default: disabled)"
       einfo "SQL and XML backends are *experimental*: sql is being deprecated"
...

Ovvero: il backend SQL sparirà (difatti le USE mysql e postgres sono state rimosse dalla 3.0.24[/b])


Ah, e quindi se volessi immagazzinare i dati in un database non posso?
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Mar 26, 2007 5:49 pm    Post subject: Reply with quote

diego_82 wrote:
Ah, e quindi se volessi immagazzinare i dati in un database non posso?

Al momento, no. Se leggi qua:
Quote:

The passdb backend parameter no long accepts multiple passdb backends in a chained configuration. Also be aware that the SQL and XML based passdb modules have been removed in the Samba-3.0.23 release. More information regarding external support for a SQL passdb module can be found on the pdbsql web site.

Difatti c'è supporto Samba ai backend SQL funziona tramite il software Samba pdbsql, di cui, a quanto pare, non c'è ancora un ebuild.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum