Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED][IWCONFIG IPW3945] WEP Config Problème
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Thu Mar 22, 2007 10:22 am    Post subject: [SOLVED][IWCONFIG IPW3945] WEP Config Problème Reply with quote

bonjour

j'ai deux problèmes

1) j'ai configuré avec wireless-tools ma configuration wifi mais je n'arrive jamais à setter ma clé WEP.
en effet dans mon fichier /etc/conf.d/wireless j'ai indiqué ceci :

essid_eth1="wolf"
mode_eth1="Managed"
key_wolf="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX enc restricted"
preferred_aps=( "wolf" )

dans le fichier /etc/net j'ai indiqué ceci :
modules=( "iwconfig" )
key_wolf="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX enc restricted"
preferred_aps=( "wolf" )

config_eth0=( "dhcp" )
config_eth1=( "dhcp" )

et enfin j'ai le lien symbolique
net.eth1 -> net.lo

et j'ai fais
rc-update a net.eth1 default

malheureusement à chaque reboot je n'ai jamais la clé wep qui est setté.

2) quand je connecte manuellement le wifi et le dhcp j'ai au bout d'un certain temps une déconnexion de mon réseau et je suis obligé de relancé ma config manuelle à savoir :

iwconfig eth1 essid "wolf" (car je perds mon essid)
iwconfig eth1 ap auto

quelqu'un sait pourquoi j'ai cela ? y aurait il un timeout quelquepart ?

merci de vos réponses
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30


Last edited by ade05fr on Fri May 18, 2007 8:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
jul16ar
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2007
Posts: 100

PostPosted: Sat Mar 24, 2007 9:33 am    Post subject: Reply with quote

tu ne dois pas préciser "enc restricted" dans la clé, le parametre key est réservé uniquement à la clé. et de toute façon tu as pas besoin de préciser enc restrited, ça fonctionnera quand même :)

Quote:
quelqu'un sait pourquoi j'ai cela ?

Tu es trop loin de la borne peu être ?


EDIT: utilise uniquement le fichier wireless. évite la redondance avec le fichier net
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Tue Apr 17, 2007 8:31 am    Post subject: Reply with quote

hello les amis

je viens de faire une petite adaptation de mon fichier /etc/conf.d/wireless et du fichier net

essid_eth1="wolf"
mode_eth1="Managed"
key_wolf="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"
preferred_aps=( "wolf" )

dans le fichier /etc/net j'ai indiqué ceci :
config_eth0=( "dhcp" )
config_eth1=( "dhcp" )

malheureusement je n'ai toujours pas ma clé wep qui est affecté correctement alors que mon essid et bien crée avec le bon mode managed.

est ce que ce fichier est correctement utilisé ?

j'ai pas trop envie de passer par un shell script pour configurer mon réseau car cela signifie qu'il y aurait une anomalie quelque part.

une idée ?
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Tue Apr 17, 2007 8:43 am    Post subject: Reply with quote

Tu mets tout dans le fichier conf.d/net :
Quote:

modules_eth2=( "iwconfig" )
mode_eth2="managed"
channel_eth2="UnNuméro"
preferred_aps=( "UnNom" )
#associate_order="forcepreferredonly"
key_UnNom="xxxxxxxxxxxxxxx enc restricted"
dns_servers_UnNom=( "dhcp" )
dhcpcd_UnNom="-R"
et rouler
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
George Abitbol
n00b
n00b


Joined: 02 Feb 2006
Posts: 55

PostPosted: Tue Apr 17, 2007 5:54 pm    Post subject: Reply with quote

ade05fr wrote:

key_wolf="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"

une idée ?


Essaie sans les tirets pour voir.
_________________
Monde de merde
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Tue Apr 17, 2007 6:53 pm    Post subject: Reply with quote

bizarre

j'ai fais ce que vous m'avez dis mais sans succes

:-(
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Wed Apr 18, 2007 12:42 am    Post subject: Reply with quote

Bon, j'utilise aussi ipw3945 et voici ma configuration:
Ca marche sans problème de mon côté avec la wep:

le /etc/conf.d/net est vide, bon apparemment à chaque démarrage, il me dit maintenant qu'il serait peut-être temps de l'utiliser à la place de wireless.
Promis, je vais changer bientôt
En attendant, le seul truc que j'ai pour ma config, c'est dans le fichier /etc/conf.d/wireless:
Code:

key_MonEssid="xxxxxxxxxxxxxxxxxxxxxxxxxx"


Bien sûr, à la place de MonEssid tu mets le vrai nom de ton routeur et à la place des x ta vrai clé wep
(désolé pour ces précisions si elles sont inutiles, mais bon des fois ça aide)
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Wed Apr 18, 2007 12:50 am    Post subject: Reply with quote

Ah oui, au fait,
juste une précision au cas où,
deux sujets important sur le ipw3945.
Le wiki :
http://gentoo-wiki.com/HARDWARE_ipw3945

Et la discussion de recherche autour du pilote, beaucoup moins digeste, beaucoup beaucoup de pages et en Anglais, mais très intéressant :
https://forums.gentoo.org/viewtopic-t-434817-postdays-0-postorder-asc-highlight-ipw3945+wireless+drivers-start-0.html

Bon, c'est juste au cas où,

Sinon, t'es bien sûr que le module se charge bien, quelle version d' ipw3945 et d' ipw3945d t'utilise, ça pourrait éclairer ceux qui veulent t'aider, quel version de noyau?

Tchao
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Wed Apr 18, 2007 8:03 am    Post subject: Reply with quote

bonjour,

je viens de voir tes réponses alors voici ma config

Gentoo 2006-1
Kernel 2.6.20-r1
IPW3945-1.2.0
IPW3945d-1.7.22-r4

quand je dois faire
key_MonEssid="xxxxxxxxxxxxxxxxxxxxxxxxxx"
est ce que X est en code hexa ?

dans le cas que l'on m'a dis j'avais tout mis dans le fichier /etc/conf.d/net avec le fichier wireless a vide ?

je ne peux pas tester en journée car je n'ai pas mon portable mais ce soir je retente la manip.

merci encore
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Wed Apr 18, 2007 6:16 pm    Post subject: Reply with quote

je viens d'essayer

marche pas...

franchement je ne comprends rien !!
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Thu Apr 19, 2007 9:35 pm    Post subject: Reply with quote

du calme, du calme :)
c'est vrai que c'est toujours un peu énervant sous gentoo les problèmes de connexion internet, parce qu'avec une connexion, tout est quand même beaucoup plus simple.
Bon, j'avoue là que j'ai la même configuration que toi et tout fonctionne chez moi. J'ai supprimé le fichier wireless, et la seul ligne que j'ai mise dans le /usr/conf.d/net est bien celle que je t'ai refilé plus haut avec la wep en hexadécimale. Ca fonctionne sans problème.
Est-ce que le module ipw3945 se charge bien?

essaie à tout hasard :
Code:
modprobe -r ipw3945
modprobe ipw3945


il y a des problèmes avec wpasupplicant pour les clefs wep, mais normalement avec wirelesstool, ça devrait bien fonctionner.

Ah oui, juste au cas où, y'a pas un bouton pour allumer le modem, des fois ça arrive d'oublié de le mettre sur "on".

Bon, je continue à chercher encore pour toi en attendant
Allez, courage, et patience...
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Tue Apr 24, 2007 5:25 am    Post subject: Reply with quote

hello,

je reviens vers vous.
alors je vais faire un petit statut de ce que j'ai pu faire comme tests :
- Suppression du fichier wireless
- dans mon fichier net j'ai conservé mes paramètres (cf posts antérieurs)
- Mise en hexa (sans les tirets) de ma clé wep dans le fichier net
- suppression du module ipw3945 puis chargement du module

Résultats : -> marche pas.

ensuite j'ai effectué un stop des services :
- /etc/init.d/ipw3945d stop
- /etc/init.d/net.eth1 stop

puis un start de ceux ci mais quand je tente de faire un start avec net.eth1 voici ce que j'ai :
....
ifplugd does not work on wireless interfaces
Wireless radio has been killed for interface eth1
...

bref je ne comprends pas trop.

est ce que cela vous parle a vous ?

merci
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Tue Apr 24, 2007 10:07 pm    Post subject: Reply with quote

mmmm, j'espère que tu te débrouilleun peu en Anglais, sinon, on va essayer de trouver des traducteurs.
A ce que j'ai compris,
un gars a déjà eu le même problème que toi :
https://forums.gentoo.org/viewtopic-t-507347-highlight-ifplugd+wireless+interfaces+wireless+radio+killed+interface+eth1.html
Un autre gars lui a répondu que la solution était dans ce post bien compliqué à comprendre pour moi:
https://forums.gentoo.org/viewtopic-t-434817-postdays-0-postorder-asc-start-342.html

Sinon un autre a eu un problème avec un message d'erreur similaire :
https://forums.gentoo.org/viewtopic-t-452261-highlight-ifplugd+wireless+interfaces+wireless+radio+killed+interface+eth1.html
Apparemment pour ce dernier, c'est dû à un conflit avec le paquet baselayout. Il aurait résolu en updatant jusqu'au dernier paquet baselayout et hald, et en remplaçant ifplugd par netplug. Mais bon, je m'y connais pas assez là pour connaître la différence entre ifplugd et netplug, je ne sais même pas ce que c'est d'ailleurs :D

mmmm, mais ce qui me parait étrange, j'ai l'impression qu'ils utilisent wpa-supplicant.

Sinon, y'a peu être une autre possibilité, downgrader le pilote ipw3945 et utiliser un pilote ieee80211 externe au noyau. Malheureusement, sans garantie non plus. Allez, garde courage et tiens nous au courant[/post]
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Apr 25, 2007 7:33 am    Post subject: Reply with quote

Ton deuxième lien n'est pas compliqué. rmh3093 a écrit des patchs pour inclure dans le noyau les drivers ipw3945. Je les utilise et cela fonctionne très bien, de plus, plus besoin de télécharger quoique que soit depuis portage. Les patchs sont accessibles ici
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Apr 25, 2007 8:02 am    Post subject: Reply with quote

Perso le wep avec ipw3945, je lance wlassistant, le clique sur le réseau, je rentre la clé ... je clique sur "connecter" mais ça marche pas. Normal, le dhcp déconne avec wlassistant.
Donc je lance le dhcp en ldc et ça roule.
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Fri Apr 27, 2007 7:39 am    Post subject: Reply with quote

bonjour,

moi j'avoue que je comprends pas bien ce qui est dis dans les solutions et en ce qui concerne les patchs du driver ipw3945 je ne sais
pas si je dois ou non les récupérer sachant que j'ai la derniere version issue de portage.

Une autre question découle de tout ces probs : y a til un moyen d'avoir un tracing complet de ce qui se passe. parce que :
au moment du boot j'ai l'impression que tout fonctionne puisque j'ai mon daemon ntpd qui se synchronise bien avec le serveur (ce qui suppose
que j'ai fais une authentificaiton et que le dhcp fonctionne) mais ensuite quand je bascule en window manager (kdm ou gdm) là j'ai la perte
de ma wep key et du dhcp.

je voudrais bien tracer ce qui se passe entre la fin de l'initialisation de démarrage et le démarrage de mon WM.

merci encore
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Fri Apr 27, 2007 11:24 pm    Post subject: Reply with quote

je viens de voir la version de ton kernel
je ne suis pas sûr que ipw3945 fonctionne correctement dessus.
Je tourne avec les gentoo-sources 2.6.20-r6

Je viens d'essayer la version 2.6.20-r7 mais ça ne passe pas pour l'instant sur mon ordi
Essaie à tout hasard la r6, on sait jamais

Juste au cas où pour préciser une version, utilise le fichier package.keywords:
Dans /etc/portage/package.keywords:
Code:
=sys-kernel/gentoo-sources-2.6.20-r6


Puis tu emerges à nouveau les gentoo sources, tu vérifie que ton lien du noyau pointe vers la bonne version, tu recompile la nouvelle version du noyau, copie arch, system.map et .config, réemerge ipw3945, modifie /boot/grub/grub.conf et reboot sur ton nouveau noyau. J'ai rien oublié? Sinon, y'a toujours le guide pour t'aider à bien recompiler ton noyau, à lire si tu ne l'as pas lu.

Voilà, en espérant que ça te débloque un peu :)
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Sat Apr 28, 2007 10:58 am    Post subject: Reply with quote

hello

j'avais la version 2.6.20-r3 et là aussi cela ne fonctionnait pas. c'est d'ailleurs pour cela que j'ai installé la r6
et depuis ce matin je suis en 2.6.21 et toujours rien de probant.

je pense que je vais encore regarder les fichiers de config...

ceci dis ce qui me pertube c'est que le serveur ntp que j'accede fonctionne lors du bout mais ensuite avec je perds mes connexions c'est qu'il y acertainement qui reset ma config.
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Fri May 18, 2007 8:11 pm    Post subject: Reply with quote

bonsoir,

je viens vers vous afin de vous donner une solution que j'aipu apporté à mon problème.
en fait lors de mon démarrage j'avais un service qui se lancé à la fin et qui est nertworkmanager

or c'est ce service qui fait un reset de ma configuration que je sette au debut via net.eth1.
j'ai donc fais rc-update -d NetworkManager et bingo mon wifi refonctionne correctement.

merci encore pour vos posts,
bonne soirée
:wink:
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
babos
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2006
Posts: 144
Location: Martinique

PostPosted: Sat May 19, 2007 12:20 pm    Post subject: Reply with quote

eh eh, cool!!
A toi les joies du emerge --sync

Donc il semblerait que NetworkManager entre en conflit avec le module ipw3945. Il serait peut-être bon de le signaler dans un rapport de bug et au rédacteur du wiki sur ipw3945
En tous cas, heureux d'apprendre que ça a résolu ton problème
_________________
Quand le sage montre le ciel, l'idiot regarde son doigt.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum