Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Digest Verification Failed after emerge --sync
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message

Joined: 07 Aug 2005
Posts: 7

PostPosted: Wed Mar 21, 2007 8:05 pm    Post subject: Digest Verification Failed after emerge --sync Reply with quote

Hello all,

Im running gentoo on a Netra T1 105.

Ive done an emerge --sync after a long time and received a notice saying there had been an update to portage. When I try to emerge portage ( or any other package) I receive different errors depending on what options I pass to portage.


fw1 ~ # grep -v "#" /etc/make.conf
CFLAGS="-O2 -mcpu=ultrasparc"
CXXFLAGS="-O2 -mcpu=ultrasparc"
USE = "apache2 php postgres session cookies socket odbc curl logrotate"

fw1 ~ # uname -a
Linux fw1 2.4.32-sparc #1 SMP Tue Dec 13 15:50:10 Local time zone must be set--see zic  sparc64 sun4u TI UltraSparc IIi (Sabre) GNU/Linux

fw1 ~ # ls -ltrh /etc/make.profile
lrwxrwxrwx  1 root root 57 Dec 15 17:29 /etc/make.profile -> /usr/portage/profiles/default-linux/sparc/sparc64/2006.1/

fw1 ~ # emerge -av portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
Traceback (most recent call last):
  File "/usr/bin/emerge", line 3221, in ?
  File "/usr/bin/emerge", line 1646, in display
    verboseadd += create_use_string(key.upper(), cur_iuse_map[key], cur_use_map[key],
KeyError: 'crosscompile_opts'

fw1 ~ # emerge portage
Calculating dependencies... done!
>>> Emerging (1 of 13) sys-apps/sandbox- to /
>>> checksums files   ;-) sandbox-1.2.17.ebuild
>>> checksums files   ;-) sandbox-1.2.12.ebuild
>>> checksums files   ;-) sandbox-1.2.16.ebuild
>>> checksums files   ;-) sandbox-1.2.20_alpha1-r2.ebuild
>>> checksums files   ;-) sandbox-
>>> checksums files   ;-) sandbox-1.2.18.ebuild
>>> checksums files   ;-) sandbox-1.2.20_alpha2.ebuild

!!! Digest verification Failed:
!!!    /usr/portage/sys-apps/sandbox/files/digest-sandbox-1.2.12
!!! Reason: Failed on SHA256 verification
!!! Got:      7a1fcb1f51ed88f84ded15c6267769ab59f5a4f06e026a34101cf6aef9152c3c
!!! Expected: 458a2a6625d973b66b077631d56a16d875742fa5bc4fa1d950cb3033b820981b

>>> Please ensure you have sync'd properly. Please try 'emerge sync' and
>>> optionally examine the file(s) for corruption. A sync will fix most cases.

The handbook says that this can happen sometimes if there is a mistake in the portage tree and to wait a while until the portage tree gets updated. Is this the problem here or is there something else amiss.

If the SHA sum is wrong, could this mean that the make.conf link is pointing to a different profile than the portage tree that I have on disk?

Back to top
View user's profile Send private message

Joined: 10 Mar 2007
Posts: 393

PostPosted: Wed Mar 21, 2007 9:00 pm    Post subject: Reply with quote

It could mean many things, but I would either wait or remove the portage tree and install one from a mirror like in the handbook.

After that if it isn't fixed something could be wrong with your disk/partition for example. Try doing these kinds of verifications manually like using md5sum etc
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 16 Mar 2006
Posts: 149
Location: Estados Unidos De América

PostPosted: Thu Mar 22, 2007 2:31 pm    Post subject: Reply with quote

Yesterday morning I decided to upgrade my production machines (Gentoo x86) and go through the installation of Modular X. I did run an emerge-webrsync before without a glitch. The emerge xorg-x11 for the installation of the new Modular X did constantly stop with the digest verification. A subsequent emerge of the affected package worked and then emerge xorg-x11 went on until it found the next issue a few minutes later. Finally I had enough and added GENTOO_MIRRORS="" to /etc/make.conf. After that emerge xorg-x11 worked just fine to the end this morning without a single digest verification incident.
Sooner or later I should remove the empty GENTOO_MIRROR list. But it seems that a lot of people are having the same problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum