Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-session and fvwm-crystal [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Tue Mar 20, 2007 5:12 pm    Post subject: gnome-session and fvwm-crystal [solved] Reply with quote

I managed to get fvwm-crystal to work with gnome-session. The only thing that doesn't work is at the only possibility to quit is with Ctrl-Alt-Backspace. I I logout with fvwm-crystal menu, all the programs quit, but it get stuck with the wallpaper and nothing else.

What I done is at I ran gnome, changed the wm to fvwm-crystal in gnome-session-properties, removed the unneeded softwares as nautilus and gnome-panel. To start fvwm-crystal with gnome-session from gdm, it is just to start gnome. I also checked out the autosave feature in gnome-session-properties and added a menu with gnome-session-save. I will made a button for that later.

File ~/.gnome/wm-properties/Config
Code:
[Config]
Current=FVWM-Crystal


File ~/.gnome/wm-properties/FVWM-Crystal.desktop
Code:
[Desktop Entry]
Name=FVWM-Crystal
Name[fr_CH.UTF-8]=FVWM-Crystal
Exec=fvwm-crystal
Terminal=false
MultipleArgs=false

[Window Manager]
SessionManaged=true


File ~/.gnome2/session
Code:
[Default]
0,id=117f000001000117438457100000131340001
0,RestartStyleHint=1
0,Priority=20
0,Program=background-properties-capplet
0,CurrentDirectory=/home/dom
0,CloneCommand=background-properties-capplet
0,RestartCommand=background-properties-capplet --sm-client-id 117f000001000117438457100000131340001 --init-session-settings
0,Environment=GNOME_DESKTOP_ICON /usr/share/pixmaps/gnome-ccbackground.png
1,id=117f000001000117438459700000131340008
1,RestartStyleHint=1
1,Priority=20
1,Program=sound-properties
1,CurrentDirectory=/home/dom
1,CloneCommand=sound-properties
1,RestartCommand=sound-properties --sm-client-id 117f000001000117438459700000131340008 --init-session-settings
2,id=117f000001000117438828000000143060000
2,Program=claws-mail
2,CloneCommand=claws-mail
2,RestartCommand=claws-mail
3,id=117f000001000117438432800000129520000
3,RestartStyleHint=0
3,Program=qjackctl
3,RestartCommand=qjackctl -session 117f000001000117438432800000129520000_1174388750_864115
4,id=117f000001000117438231400000114940006
4,RestartStyleHint=0
4,Priority=30
4,Program=fvwm2
4,DiscardCommand=rm -f /home/dom/.fs-52kLqR
4,CloneCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0
4,RestartCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0 -clientId 117f000001000117438231400000114940006 -restore /home/dom/.fs-52kLqR
5,RestartCommand=glashctl
num_clients=6


I also try to issue a "gnome-session-save --quit", but it doesn't changed anything.

Any clue?


Last edited by Dominique_71 on Sat Apr 14, 2007 8:50 pm; edited 3 times in total
Back to top
View user's profile Send private message
ThomasAdam
Guru
Guru


Joined: 20 Mar 2005
Posts: 448
Location: England

PostPosted: Tue Mar 20, 2007 6:45 pm    Post subject: Re: gnome-session and fvwm-crystal Reply with quote

Dominique_71 wrote:
I managed to get fvwm-crystal to work with gnome-session. The only thing that doesn't work is at the only possibility to quit is with Ctrl-Alt-Backspace. I I logout with fvwm-crystal menu, all the programs quit, but it get stuck with the wallpaper and nothing else.


Because quitting the window manager isn't killing the session manager by the looks of it.

-- Thomas Adam
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Tue Mar 20, 2007 7:19 pm    Post subject: Reply with quote

Thank you for the answer Thomas.

I am looking at fvwm-crystal files. components/functions/Exit use fvwm Quit command. So I suppose at I must change it with something that test if gnome-session is running, if found, kill it, otherwise run Quit.
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Tue Mar 20, 2007 10:18 pm    Post subject: Reply with quote

I modified the Exit function as follow:
Code:
DestroyMenu /Exit
AddToMenu /Exit
Test (x xscreensaver) + '%22x22/fvwm-crystal/system-lock-screen.png%$[gt.Lock screen]' X xscreensaver-command -lock
+ '%22x22/fvwm-crystal/view-refresh.png%$[gt.Restart]' Restart
Test (EnvIsSet SESSION_MANAGER) + '%22x22/fvwm-crystal/system-log-out.png%$[gt.Logout]' QuitSession
Test (!EnvIsSet SESSION_MANAGER) + '%22x22/fvwm-crystal/system-log-out.png%$[gt.Logout]' Quit

It work well with QuitSession and gnome-session. I suppose at other session managers will also work.
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Sat Apr 14, 2007 6:41 pm    Post subject: Reply with quote

I have a new problem. I am trying to make it to work with both gnome and fvwm-crystal without to have to do anything else as to choose the session in gdm.

I modify /etc/X11/Sessions/fvwm-crystal as:
Code:
 #!/bin/sh
/usr/bin/gnome-session --choose-session=Fvwm-Crystal

and ~/.gnome2/session as:
Code:

[Fvwm-Crystal]
0,id=117f000001000117453708400000062020000
0,Program=claws-mail
0,CloneCommand=claws-mail
0,RestartCommand=claws-mail
1,id=117f000001000117438432800000129520000
1,RestartStyleHint=0
1,Program=qjackctl
1,RestartCommand=qjackctl -session 117f000001000117438432800000129520000_1174537221_969854
2,id=117f000001000117438231400000114940006
2,RestartStyleHint=0
2,Priority=30
2,Program=fvwm2
2,DiscardCommand=rm -f /home/dom/.fs-UEA9vA
2,CloneCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0
2,RestartCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0 -clientId 117f000001000117438231400000114940006 -restore /home/dom/.fs-UEA9vA
3,id=117f000001000117438828000000143060000
3,Program=claws-mail
3,CloneCommand=claws-mail
3,RestartCommand=claws-mail
4,RestartCommand=glashctl
num_clients=5

[Default]
0,id=117f000001000117655719800000134340000
0,RestartStyleHint=2
0,Priority=40
0,Program=gnome-panel
0,CurrentDirectory=/home/dom
0,CloneCommand=gnome-panel --sm-config-prefix /gnome-panel-5fEnNM/
0,RestartCommand=gnome-panel --sm-config-prefix /gnome-panel-5fEnNM/ --sm-client-id 117f000001000117655719800000134340000 --screen 0
1,id=117f000001000117655719900000134340001
1,RestartStyleHint=2
1,Priority=40
1,Program=nautilus
1,CurrentDirectory=/home/dom
1,CloneCommand=nautilus --sm-config-prefix /nautilus-phqBtP/
1,RestartCommand=nautilus --sm-config-prefix /nautilus-phqBtP/ --sm-client-id 117f000001000117655719900000134340001 --screen 0 --load-session /home/dom/.nautilus/saved6ki3Yj
num_clients=2


I try both with and without the files in ~/.gnome/wm-properties/ and get the same result.

It work well when starting gnome, but when starting fvwm-crystal, it start as expected, but the other applications doesn't start and gnome-session is killed or doesn't start. In ~/xsessions-errors, I get:
Code:
/etx/X11/gdm/Xsession: Setup done, will execute: /use/bin/ssh-agent -- fvwm-crystal

(gdmflexiserver:8158): Gdk-CRITICAL **: gdk_display_get_name: assertion `GDK_IS_DISPLAY (display)' failed


Last edited by Dominique_71 on Sun Apr 15, 2007 10:11 am; edited 1 time in total
Back to top
View user's profile Send private message
ThomasAdam
Guru
Guru


Joined: 20 Mar 2005
Posts: 448
Location: England

PostPosted: Sat Apr 14, 2007 7:07 pm    Post subject: Reply with quote

Dominique_71 wrote:
It work well when starting gnome, but when starting fvwm-crystal, it start as expected, but the other applications doesn't start and gnome-session is killed or doesn't start.


When running FVWM under a session manager, FVWM won't read StartFunction as usual, it instead looks for SessionInitFunction. Since that isn't defined in fvwm-crystal, it's no wonder certain applications aren't starting.

Note that you shouldn't start applications such as terminal emulators from it.

-- Thomas Adam
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Sat Apr 14, 2007 7:43 pm    Post subject: Reply with quote

ThomasAdam wrote:
Dominique_71 wrote:
It work well when starting gnome, but when starting fvwm-crystal, it start as expected, but the other applications doesn't start and gnome-session is killed or doesn't start.


When running FVWM under a session manager, FVWM won't read StartFunction as usual, it instead looks for SessionInitFunction. Since that isn't defined in fvwm-crystal, it's no wonder certain applications aren't starting.

Note that you shouldn't start applications such as terminal emulators from it.

-- Thomas Adam

When starting fvwm-crystal as before with gnome in gdm, fvwm-crystal was not starting the programs specified in $[FVWM_USERDIR]/preferences/startup but the programs specified in ~/.gnome2/session was started.

From the first line of my xsession-errors, it look like gdm is not using my custom /etc/X11/Sessions/fvwm-crystal but launch directly fvwm-crystal with "/usr/bin/ssh-agent -- fvwm-crystal" instead. Edit: And the programs in $[FVWM_USERDIR]/preferences/startup are started but not the ones in ~/.gnome2/session

Edit2: What I want to do is to be able to choose between 2 gnome-sessions from gdm, that is without to get the gnome-session-properties that will ask for which session to run.

Edit3: I found it. gdm is using .desktop files in /usr/share/xsessions. It is a fvwm-crystal.desktop in it that come with fvwm-crystal. All taht is needed is to edit it as follow:
Code:
# /usr/share/xsessions/fvwm-crystal.desktop
[Desktop Entry]
Encoding=UTF-8
Name=FVWM-Crystal
Comment=Umm... Nice desktop. Transparent, and all...
#Exec=fvwm-crystal
Exec=gnome-session --choose-session=Fvwm-Crystal
Terminal=False
TryExec=fvwm-crystal
Type=Application

[Window Manager]
SessionManaged=true

Now, when I choose gnome in gdm, it launch gnome, and when I choose fvwm-crystal, it launch fvwm-crystal with gnome-session management.


Last edited by Dominique_71 on Sun Apr 15, 2007 10:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1787
Location: Switzerland (Romandie)

PostPosted: Sun Apr 15, 2007 10:04 am    Post subject: Reply with quote

I find a way to start it from the "scratch". Read at it must be possible to export that config into another computer. The problem is at /usr/share/gnome/session.default cannot deal with another wm as gnome.

What is needed are /etc/X11/Sessions/fvwm-crystal and /usr/share/xsessions/fvwm-crystal.desktop as above. ~/.gnome2/session become:
Code:
[Fvwm-Crystal]
0,id=default0
0,Priority=0
0,RestartCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0
num_clients=1

[Default]
0,id=default0
0,Priority=0
0,RestartCommand=gnome-wm --default-wm gnome-wm --sm-client-id default0
1,id=default1
1,Priority=10
1,RestartCommand=gnome-panel --sm-client-id default0
2,id=default2
2,Priority=20
2,RestartCommand=nautilus --no-default-window --sm-client-id default1
num_clients=3
Fvwm-crystal was starting as usual. Gnome took a very long time to start and I was not able to close the session. But I have a very minimalistic gnome installation or maybe it was interfering with my existing ~/.gnome and ~/.gnome2 files, so I paste it anyway.

With the following session file:
Code:
[Fvwm-Crystal]
0,id=default0
0,Priority=0
0,RestartCommand=fvwm2 -f /usr/bin/../share/fvwm-crystal/fvwm/config -s 0
num_clients=1

[Default]
0,id=default0
0,Priority=10
0,RestartCommand=gnome-panel --sm-client-id default0
1,id=default1
1,Priority=20
1,RestartCommand=nautilus --no-default-window --sm-client-id default1
num_clients=2

both wm was starting very fast and working as expected.

So, one of this file must work for you. If interested, just try it and report how it work.

If you already have a ~/.gnome2/session file, what you can do is just to past the missing part ([Fvwm-Crystal] I guess) into it.

After having started one of those 2 WMs and launched your favorites applications, all you have to do is to use "gnome-session-save" as usual, and your session will be saved. You can also launch "gnome-session-properties".

Into fvwm, a function as the following will save the config:
Code:
DestroyFunc SaveDesktop
AddToFunc SaveDesktop
+ I Exec exec gnome-session-save --gui

I call it from a FvwmButton with:
Code:
# Session manager panel {{{1
All (FvwmButtons-SessionManager) Close
DestroyModuleConfig FvwmButtons-SessionManager: *
*FvwmButtons-SessionManager: Geometry +-1--1
*FvwmButtons-SessionManager: BoxSize smart
*FvwmButtons-SessionManager: ActiveColorset $[cs-panel-active]
*FvwmButtons-SessionManager: Colorset $[cs-panel-inactive]
*FvwmButtons-SessionManager: Rows 1
*FvwmButtons-SessionManager: Padding 1 1
*FvwmButtons-SessionManager: Frame 0

# SessionManager {{{2
*FvwmButtons-SessionManager: (1x1, Size 22 22, Icon "22x22/fvwm-crystal/gdm.png", \
Action (Mouse 1) SaveDesktop, \
Action (Mouse 2) Exec exec gnome-session-properties)

# 2}}}

Module FvwmButtons FvwmButtons-SessionManager
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum