Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel Panic/Bug con 2.6.19 - udev o highmem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Dun
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 172
Location: Amsterdam (NL) / Venice (IT)

PostPosted: Tue Mar 13, 2007 6:17 pm    Post subject: Kernel Panic/Bug con 2.6.19 - udev o highmem Reply with quote

Il problema e' piuttosto strano. Da quando ho compilato il 2.6.19 (arch x86) (31 gennaio in teoria) ho dei kernel panic piuttosto strani. Me ne saranno capitati circa 10 in tutto qeusto periodo. Non ho difatti trovato modo per riprodurli in modo deterministico.

All'inizio il kernel bug, facendo illuminare i led della tastiera, non mi dava neanche possibilita' di capire bene l'errore. Lo schermo infatti si riempiva di messaggi riguardanti "Spurious ack on isa etc etc". Per risolvere questo problema e avere un filo di debug in piu' ho aggiunto la stringa seguente su grub:

Code:

i8042.panicblink=0


Con questa aggiunta in effetti al successivo kernel panic sono riuscito ad estrapolare una skermata di massima. Purtroppo ad intervalli variabili venivano fuori ulteriori errori e son riuscito a prendere solo una foto (di dubbia qualita') di questi.

Il momento del boot in cui succede cio' e' esattamente quello in cui parte udev. So che dalle ultime versioni si preoccupa di fare il loading di alcuni moduli (esempio ipw2200) e non vorrei che la cosa fosse collegata.

Cmq nella schermata che son riuscito a prendere mi indica un kernel bug in highmem (?). Premetto che avendo 1 GB di memoria ho attivato l'highmem a 4GB.

Mi scuso ancora per la qualita' della foto ma e' stata presa per pura fortuna mentre ero in biblioteca grazie ad un cell di un mio amico.

Link ad immagine

Idee? Anche come incrementare il debug, ad esempio :(

Ciao!

[Update]

Ok, ho cercato di ricopiare quello che si capisce....i caratteri "#" sono numeri ma illeggibili e i "?" i caratteri.

Code:

EIP: [####] keep_atomic=#######
??note: init[####] exited with preempt_????

-------[ cut here ]------
kernel BUG at arch/i386/mm/highmem.c:42!
invalid opcode: 00000 [#53]
PREEMPT
Modules linked in:
CPU:   0
EIP:   0060:[<c0115564>]   Not tainted VLI
EFLAGS:   00010206   (2.6.19-gentoo-r5 #2)
EIP is at kmap_atomic 0x64/0x80
eax: 3F505163   ebx: 00000003   ecx: ########
esi: ########   edi: dfea1eb4   ebg: ########
ds: 087b   es: 007b:   ss: 0068
PRocess init(pid: 1, ti=dfe#####, task=df#####
Stack: [VariIndirizzi]
Call Trace:
   [########] file_read_actor?????
   [########] do_generic_mapping_read?????
   [########] generic_file_aio_read?????
   [########] file_read_actor?????
   [########] do_sync_read??????


[Update2]

Pare che il problema non sia nuovo. Anche sul forum di arch linux ne parlano: http://bbs.archlinux.org/viewtopic.php?id=28680&p=1


Last edited by Dun on Wed Mar 14, 2007 12:10 am; edited 3 times in total
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Tue Mar 13, 2007 6:23 pm    Post subject: Reply with quote

non è che riusciresti a postare un'immagine senza i riflessi della luce??? cosi non riesco a leggere nulla, sarò che sn cecato, ma si vede male :(

ciauz
Back to top
View user's profile Send private message
Dun
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 172
Location: Amsterdam (NL) / Venice (IT)

PostPosted: Tue Mar 13, 2007 6:25 pm    Post subject: Reply with quote

Lo so purtroppo, e' il massimo che son riuscito ad ottenere. Se mi dite provo a fare una trascrizione (alla fine sarebbe giusto che lo sbatti maggiore lo debba mettere io)

Update -> Fatta :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum