Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] problème de configuration. [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Ratch
n00b
n00b


Joined: 12 Mar 2007
Posts: 8

PostPosted: Mon Mar 12, 2007 11:53 am    Post subject: [Xorg] problème de configuration. [résolu] Reply with quote

Bonjour je suis nouveau ici et nouveau sur la distribution Gentoo

Ma question est la suivante quand j'exécute la commande ( startx ) j'obtient l'erreur suivant

Code:

xauth:  creating new authority file /root/.serverauth.4709


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux localhost 2.6.19-gentoo-r5 #6 SMP Mon Mar 12 00:48:55 Local time zone must be set--see zic  i686
Build Date: 05 March 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 12 07:42:37 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.



Voici mon fichier make.conf

Code:

CFLAGS="-Os -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="-arts -qt -qt3 -qt4 -kde avahi dri gnome hal gtk sis"
INPUT_DEVICES="mouse keyboard"
VIDEO_CARDS="sis"


Ainsi que mon fichier xorg.conf

Code:

Section "ServerLayout"

        Identifier     "Main Layout"
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "ServerLayout"
        Identifier     "another layout"
        Screen         "Screen 1" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "ServerLayout"
        Identifier     "simple layout"
        Screen         "Screen 1" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"

        RgbPath      "/usr/share/X11/rgb"
        FontPath     "/usr/share/fonts/local"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/CID"
        FontPath     "/usr/share/fonts/75dpi"
        FontPath     "/usr/share/fonts/100dpi"
EndSection

Section "Module"

        Load  "dbe"
        SubSection "extmod"
                Option      "omit xfree86-dga"
        EndSubSection
        Load  "type1"
        Load  "freetype"
EndSection

Section "ServerFlags"

        Option      "standby time" "20"
        Option      "suspend time" "30"
        Option      "off time" "60"
EndSection

Section "InputDevice"

        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "AutoRepeat" "500 5"
        Option      "XkbModel" "pc104"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"

        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Device" "/dev/input/mouse0"
EndSection

Section "Monitor"

        Identifier   "Generic Monitor"
        HorizSync    31.5 - 48.5
        VertRefresh  50.0 - 70.0
        ModeLine     "640x480" 25.2 640 664 760 800 480 491 493 525
EndSection

Section "Device"

        Identifier  "Generic VGA"
        Driver      "sis"
        Card        "** SiS (generic)                      [sis]"
EndSection

Section "Device"
        Identifier  "any supported Trident chip"
        Driver      "sis"
        Card        "** SiS (generic)                      [sis]"
EndSection

Section "Device"
        Identifier  "MGA Millennium I"
        Driver      "mga"
        Option      "hw cursor" "off"
        BusID       "PCI:0:10:0"
EndSection

Section "Device"
        Identifier  "MGA G200 AGP"
        Driver      "mga"
        Option      "pci retry"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"

        Identifier "Screen 1"
        Device     "Generic VGA"
        Monitor    "Generic Monitor"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual   800 600
                Depth     8
                Modes    "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1152x864"
        EndSubSection
EndSection


Le résultat (lsmod)

Code:

Module                  Size  Used by
sis                    10112  0
drm                    69652  1 sis
sis900                 23168  0


sis: est ma carte graphique intégrée supporter par drm
sis900: est ma carte réseau intégrée que j'ai mis en module

Mon écran est une 17 pouce gateway 2000


J'espère que c'est pas une erreur Fatal comme le dit mon erreur :(

Si il vous manque de l'information concernant mes configurations demander le.

J'aimerais dire un gros merci a tous ceux qui se porterons volontaires a m'aider a la réussite de mon installation Merci d'avance à vous tous.


Last edited by Ratch on Mon Mar 12, 2007 2:35 pm; edited 3 times in total
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 12, 2007 12:14 pm    Post subject: Reply with quote

Salut


Code:

emerge x11-drivers/xf86-input-mouse x11-drivers/xf86-input-keyboard



EDIT= Distrique ou distribution :p ?

Sinon pour le titre essaye plutot

[Xorg] Failed to load modules "mouse"
Back to top
View user's profile Send private message
Ratch
n00b
n00b


Joined: 12 Mar 2007
Posts: 8

PostPosted: Mon Mar 12, 2007 1:11 pm    Post subject: Reply with quote

Merci dapsaille très apprécier j'ai régler la section de ma souris et de mon clavier :)


Maintenant j'obtient cette erreur ci

Code:

startx
xauth:  creating new authority file /root/.serverauth.16521

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux localhost 2.6.19-gentoo-r5 #6 SMP Mon Mar 12 00:48:55 Local time zone must be set--see zic  i686
Build Date: 05 March 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 12 09:03:53 2007
(==) Using config file: "/etc/X11/xorg.conf"

(EE) No drivers available.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.


Voici mon fichier xorg.conf

Code:

Section "ServerLayout"

        Identifier     "Main Layout"
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "ServerLayout"
        Identifier     "another layout"
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "ServerLayout"
        Identifier     "simple layout"
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"

        RgbPath      "/usr/share/X11/rgb"
        FontPath     "/usr/share/fonts/local"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/CID"
        FontPath     "/usr/share/fonts/75dpi"
        FontPath     "/usr/share/fonts/100dpi"
EndSection

Section "Module"

        Load  "dbe"
        SubSection "extmod"
                Option      "omit xfree86-dga"
        EndSubSection
        Load  "type1"
        Load  "freetype"
EndSection

Section "ServerFlags"

        Option      "standby time" "20"
        Option      "suspend time" "30"
        Option      "off time" "60"
EndSection

Section "InputDevice"

        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "AutoRepeat" "500 5"
        Option      "XkbModel" "pc104"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"

        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Device" "/dev/input/mouse0"
EndSection

Section "Monitor"
        Identifier   "Gateway 2000"
        HorizSync    31.5 - 48.5
        VertRefresh  50.0 - 90.0
EndSection

Section "Device"
        Identifier  "Sis"
        Driver      "sis"
        Card        "** SiS (generic)                      [sis]"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Sis"
        Monitor    "Gateway 2000"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768"
        EndSubSection
EndSection


J'ai une erreur de carte graphique je crois ma carte graphique c'est : GRAPHIQUE Chipset graphique SiS Real256E 2D/3D intégré Mémoire partagée : 32/64 Mo

Lspci donne ceci

Code:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760/761 PCI/AGP VGA Display Adapter
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Mon Mar 12, 2007 1:20 pm    Post subject: Reply with quote

Bienvenue Ratch,

dapsaille wrote:
Sinon pour le titre essaye plutot

[Xorg] Failed to load modules "mouse"
Tu trouveras plus d'infos là : [IMPORTANT] Comment se servir du forum !!.

Merci.

PS : comme ton problème de souris est résolu, mets plutôt [Xorg] problème de configuration.
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Mon Mar 12, 2007 1:50 pm    Post subject: Reply with quote

Ta "Main Layout" ne contient pas de ligne Screen. Ajoute la :
Code:
        Screen         "Screen 1" 0 0


Il n'y a pas l'intérêt à avoir trois sections ServerLayout identiques. Gardes-en qu'une.
Back to top
View user's profile Send private message
Ratch
n00b
n00b


Joined: 12 Mar 2007
Posts: 8

PostPosted: Mon Mar 12, 2007 2:35 pm    Post subject: Reply with quote

Merci à tous il me manquais mon driver

x11-drivers/xf86-video-sis

Mon X part maintenant
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Mon Mar 12, 2007 2:50 pm    Post subject: Reply with quote

dapsaille wrote:
Code:

emerge x11-drivers/xf86-input-mouse x11-drivers/xf86-input-keyboard



Salut

C'est quand même pas très propre...

Il vaut mieux rajouter les lignes suivantes dans make.conf :
Code:
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="sis"


et faire un emerge -a1v xorg-server...

(Le résultat est quasi le même, pas de polution du fichier world).
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Mar 12, 2007 4:29 pm    Post subject: Reply with quote

_droop_ wrote:
dapsaille wrote:
Code:

emerge x11-drivers/xf86-input-mouse x11-drivers/xf86-input-keyboard



Salut

C'est quand même pas très propre...

Il vaut mieux rajouter les lignes suivantes dans make.conf :
Code:
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="sis"


et faire un emerge -a1v xorg-server...

(Le résultat est quasi le même, pas de polution du fichier world).


J'approuve cette remarque moi aussi :)


Last edited by d2_racing on Tue Mar 13, 2007 11:54 am; edited 1 time in total
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 12, 2007 4:49 pm    Post subject: Reply with quote

Je ne veux pas paraitre trouble fete mais si vous aviez lu le premier post vous auriez vu que c'est déja en place dans le make.conf :wink:

J'ai déja rencontré ce problème :p mais je ne sais plus de quelle facon :p
Back to top
View user's profile Send private message
Ratch
n00b
n00b


Joined: 12 Mar 2007
Posts: 8

PostPosted: Mon Mar 12, 2007 11:56 pm    Post subject: Reply with quote

Oui dapsaille ma bien aider et je vous remerci tous il me manquais simplement mes driver de souris et de clavier et dapsaille me les a donner avec générosité mais je vous remerci de votre aide à tous.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum