Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installation of kdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
donald7
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 136

PostPosted: Sat Mar 10, 2007 3:37 pm    Post subject: installation of kdm Reply with quote

hello

I just installed kdbase successfully and I am writing in this forum from Konqeror :)

Following the handbook, I wanted to have the GUI started at startup .

Code:


#emerge --ask --noreplace kdm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdebase-data-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/libkonq-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kicker-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/khotkeys-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdesu-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kcontrol-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/khelpcenter-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kcminit-3.5.3)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdm-3.5.5-r1)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdepasswd-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kcheckpass-3.5.0)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdialog-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kfind-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/konqueror-3.5.5)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdebase-kioslaves-3.5.5-r1)
[blocks B     ] =kde-base/kdebase-3.5* (is blocking kde-base/kdesktop-3.5.5-r1)
[ebuild  N    ] kde-base/kdebase-data-3.5.5  USE="-debug -kdeenablefinal -xinerama"
[ebuild  N    ] kde-base/libkonq-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kicker-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xcomposite -xinerama"
[ebuild  N    ] kde-base/khotkeys-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kdesu-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/khelpcenter-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kcminit-3.5.3  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kcontrol-3.5.5  USE="ssl -arts -debug -ieee1394 -kdeenablefinal -kdehiddenvisibility -logitech-mouse -opengl -xinerama"
[ebuild  N    ] kde-base/kdepasswd-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kdm-3.5.5-r1  USE="pam -arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kcheckpass-3.5.0  USE="pam -arts -debug -kdeenablefinal -kdehiddenvisibility -kdexdeltas -xinerama"
[ebuild  N    ] kde-base/kdialog-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kfind-3.5.5  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kdebase-kioslaves-3.5.5-r1  USE="-arts -debug -hal -kdeenablefinal -kdehiddenvisibility -ldap -openexr -samba -xinerama"
[ebuild  N    ] kde-base/konqueror-3.5.5  USE="-arts -debug -java -kdeenablefinal -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/kdesktop-3.5.5-r1  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama -xscreensaver"

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

gentoo ~ #                     


what goes wrong ? Apparently there is a problem with USE ?

thanks !

donald


PS : Here is my /etc/make.conf file if needed

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"


GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nv"
USE="-gtk -gnome qt qt3 qt4 dvd alsa cdr ha1"
LINGUAS="fr"
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2673
Location: here, there or in transit

PostPosted: Sat Mar 10, 2007 4:00 pm    Post subject: Reply with quote

kdebase is a monolithic package and blocks all the split-ebuild packages on which kdm depends.
Code:
emerge -C kde-base/kdebase
emerge -av kde-base/kdm
should get you sorted out. You may need to re-install a component or two afterwards, if kdm doesn't pull in all the same pieces as kdebase.

Incidentally, there's a typo in either your USE flags, or in your transcription thereof:
donald7 wrote:
USE="-gtk -gnome qt qt3 qt4 dvd alsa cdr ha1"
That last flag should be hal, not ha1. Last letter is lowercase L.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
donald7
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 136

PostPosted: Sat Mar 10, 2007 4:09 pm    Post subject: Reply with quote

timeBandit wrote:
kdebase is a monolithic package and blocks all the split-ebuild packages on which kdm depends.
Code:
emerge -C kde-base/kdebase
emerge -av kde-base/kdm
should get you sorted out. You may need to re-install a component or two afterwards, if kdm doesn't pull in all the same pieces as kdebase.


thanks ! I am not sure to understand why kdebase , which is already installed , blocks the installation of kdm but I will try asap your commands. 8)


timeBandit wrote:

Incidentally, there's a typo in either your USE flags, or in your transcription thereof:
donald7 wrote:
USE="-gtk -gnome qt qt3 qt4 dvd alsa cdr ha1"
That last flag should be hal, not ha1. Last letter is lowercase L.


:evil: Silly mistake !

Apparently this hal flag was needed at the build phase of kdebase to mount automatically my devices. Now than kdebase is installed, how can I correct this build error ?


donald
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2673
Location: here, there or in transit

PostPosted: Sat Mar 10, 2007 5:08 pm    Post subject: Reply with quote

Since you'll be removing kdebase to install kdm, it should sort itself out. If you want to be certain everything is rebuilt properly, use:
Code:
emerge --newuse --ask world
after you remove kdebase, and before you install kdm. Note that this could rebuild a lot of packages, depending on how much you've installed with the wrong USE flag.

Howwever, you may not need to rebuild anything, as I believe hal is enabled by default. If you have gentoolkit installed, try this:
Code:
$ euse -i hal
global use flags (searching: hal)
************************************************************
[+  D ] hal - Enable Hardware Abstraction Layer (HAL) support

local use flags (searching: hal)
************************************************************
no matching entries found
The D indicates hal is set in make.defaults, a C would mean make.conf. If the D is present you're fine, your typo caused no harm. (If you don't have gentoolkit, emerge gentoolkit to install it.)

As for why kdebase blocks kdm: last year (or maybe earlier), the so-called monolithic KDE ebuilds were split into many pieces, to allow greater control over which components get installed and improve maintainability. You can have either the monolithic package installed, or the equivalent component packages (the "split ebuilds"), but not both--because they are two different methods of installing the same programs.

kdebase is a monolithic installation of the base KDE environment: desktop, Konqueror, and all the rest. KDM depends on the separate ebuilds for all these individual components, not the monolithic ebuild. Even though the programs are already installed, Portage won't install another package that wants to claim ownership of the same files. Hence the blocks. Clear?
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8292

PostPosted: Sun Mar 18, 2007 8:36 pm    Post subject: Reply with quote

This issue has already been discussed in the topic "Blockers in KDE 3.4.1", where it was summarized by Headrush; and it is also covered in The KDE Configuration HOWTO.

Moved from Desktop Environments to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum