Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con dbus
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Fri Mar 09, 2007 7:44 pm    Post subject: Problema con dbus Reply with quote

Ciao.
Nell'installare F-Spot, ho aggiornato il pacchetto dbus alla versione.1.0.2-r1.
Dopo ho fatto rc-update, sostituendo il vecchio file di configurazione con quello nuovo.

Purtroppo, però devo aver sbagliato qualcosa perchè se provo a far partire F-Spot, mi si apre un pop-up con questo messaggio d'errore:
Code:
An unhandled exception was thrown: Unable to open the session message bus.

  at NDesk.DBus.Bus.get_Session () [0x00000]
  at NDesk.DBus.BusG.Init () [0x00000]
  at FSpot.Driver.Main (System.String[] args) [0x00000]
.NET Version: 2.0.50727.42

Assembly Version Information:

System.Data (2.0.0.0)
Mono.Data.SqliteClient (2.0.0.0)
gdk-sharp (2.10.0.0)
gnome-vfs-sharp (2.16.0.0)
NDesk.DBus.GLib (0.3.0.0)
NDesk.DBus (1.0.0.0)
System (2.0.0.0)
Mono.Posix (2.0.0.0)
atk-sharp (2.10.0.0)
gtk-sharp (2.10.0.0)
glib-sharp (2.10.0.0)
gnome-sharp (2.16.0.0)
f-spot (0.3.4.0)
Mono.GetOptions (2.0.0.0)
mscorlib (2.0.0.0)

Platform Information: Linux 2.6.18-gentoo-r6 x86_64 AuthenticAMD GNU/Linux

Distribution Information:

[/etc/gentoo-release]
Gentoo Base System release 1.12.6

Inoltre, non mi parte più neanche vlc, che mi restituisce:
Code:
vlc: error while loading shared libraries: libdbus-1.so.2: cannot open shared object file: No such file or directory

Come posso fare?
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Fri Mar 09, 2007 8:23 pm    Post subject: Reply with quote

avresti dovuto leggere le info in fondo all'emerge di dbus, che ti diceva di dare un certo comando e far andare revdep-rebuilt. ora non so prova a lanciare un revderp-rebuild (dovrai ricompilare un bel po di pacchetti) e vedi se ti risolve il problema
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Fri Mar 09, 2007 9:04 pm    Post subject: Reply with quote

mi pare di ricordare che necessitava anche -X
Code:
revdep-rebuild -X


non ci giurerei :)
_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Sat Mar 10, 2007 1:01 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-533788-highlight-dbus.html
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Sat Mar 10, 2007 2:34 pm    Post subject: Reply with quote

Ho fatto
Code:
/etc/init.d/dbus reload
revdep-rebuild -X
come indicato nella guida, ma F-Spot mi dà il messaggio d'errore di prima.

Vlc invece adesso parte...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum