Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] maledetto pitivi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pau_boex
n00b
n00b


Joined: 07 Mar 2007
Posts: 4

PostPosted: Wed Mar 07, 2007 5:51 pm    Post subject: [risolto] maledetto pitivi Reply with quote

salve a tutti...
beh da come potete vedere io sono nuovo di queste parti, ma purtroppo la mia mala ciorta (come si dice a napoli) mi porta a postare questo 3d :roll: ...
oggi mentre giravo su you tube ho sentito dentro di me la mia parte da regista holliwoodiano che premeva verso le pareti del mio cervello cercando di farsi sentire...
allora visto che avevo qualche oretta da perdere in compilazioni inutili mi son detto..."PERCHÈ NO!"..
così apro la mia consolletta faccio un bel su e scrivo ACCEPT_KEYWORDS="~x86 " emerge pitivi
...dopo un bel po di trambusto nella mia finestra, ero ormai certo di essere riuscito a trovare un mezzo per esprimere la mia arte soppressa e affossata nel più recondito organo del mio corpo...
purtroppo per il mio organo improvvisamente mi compare questo:

* pitivi-0.10.1.tar.bz2 MD5 ;-) ... [ ok ]
* pitivi-0.10.1.tar.bz2 RMD160 ;-) ... [ ok ]
* pitivi-0.10.1.tar.bz2 SHA1 ;-) ... [ ok ]
* pitivi-0.10.1.tar.bz2 SHA256 ;-) ... [ ok ]
* pitivi-0.10.1.tar.bz2 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking pitivi-0.10.1.tar.bz2 ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking pitivi-0.10.1.tar.bz2 to /var/tmp/portage/media-video/pitivi-0.10.1/work
* Fixing OMF Makefiles ... [ ok ]
* Running elibtoolize in: pitivi-0.10.1
* Applying max_cmd_len-1.5.0.patch ...
* Applying sed-1.5.6.patch ...
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-video/pitivi-0.10.1/work/pitivi-0.10.1 ...

!!! ERROR: media-video/pitivi-0.10.1 failed.
Call stack:
ebuild.sh, line 1614: Called dyn_compile
ebuild.sh, line 971: Called qa_call 'src_compile'
environment, line 1704: Called src_compile
pitivi-0.10.1.ebuild, line 32: Called addpredict '/root/.gconf' '/root/.gconfd' '/root/.gstreamer-0.10'
ebuild.sh, line 105: Called die

!!! Usage: addpredict <colon-delimited list of paths>
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-video/pitivi-0.10.1/temp/build.log'.

dopo le consuete bestemmie post stop build mi sono scervellato un pò per capire cosa era, ma tutto è stato a dir poco infruttuoso...
beh nn mi resta che confidare in voi, che sicuramente saprete aiutarmi, sopratutto coloro che animati di ottimo spirito sono riusciti ad arrivare al fondo di questa mia bizzarra storia :lol: ..

aspetto nuove allora...
grazie e ciao


Last edited by pau_boex on Sat Mar 10, 2007 12:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Mar 07, 2007 6:58 pm    Post subject: Reply with quote

Moved from Multimedia to Forum italiano (Italian).
It's all greek to me, so moved here. Hasta la vista baby.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Mar 07, 2007 7:06 pm    Post subject: Reply with quote

ciao e benvenuto :wink:

quello che hai postato è tutto quello che viene stampato in console o hai saltato qualche pezzo?
da quanto hai scritto non si capisce molto bene quale possa essere l'errore, almeno... io non lo capisco.
mi permetto solo di darti un consiglio, anzi due :lol:

1° utilizza il BBCode quando scrivi parti di codice, il tutto risulta molto più chiaro per chi legge
2° non utilizzare ACCEPT_KEYWORDS da linea di comando. crea il file in /etc/portage/package.keywords ed inserisci li dentro il nome del pacchetto che vuoi smascherare. ti eviti tanti grattacapi. :wink:

PS: la sintassi del file può essere sia:
Code:
media-video/pitivi
che
Code:
=media-video/pitivi-0.10.1


[edit] tolta s al nome del file[/edit]


Last edited by Ic3M4n on Thu Mar 08, 2007 12:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Thu Mar 08, 2007 8:41 am    Post subject: Reply with quote

tu hai detto al tuo sistema non solo di emerge il pacchetto in ~ ma anche tutte le dipendenze ed eventuali pacchetti correlati. Meglio usare portage.keywords sìsì :)
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Mar 08, 2007 12:38 pm    Post subject: Reply with quote

.:deadhead:. wrote:
Meglio usare portage.keywords sìsì :)


cioè /etc/portage/package.keywords
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Thu Mar 08, 2007 12:42 pm    Post subject: Reply with quote

Onip wrote:
.:deadhead:. wrote:
Meglio usare portage.keywords sìsì :)


cioè /etc/portage/package.keywords

già già... mi è sfuggita una s di troppo. grazie per la correzione.
Back to top
View user's profile Send private message
pau_boex
n00b
n00b


Joined: 07 Mar 2007
Posts: 4

PostPosted: Thu Mar 08, 2007 4:45 pm    Post subject: Reply with quote

grazie per i consigli li terrò a mente...
cmq l'output è così breve poichè era la seconda volta che provavo ad emergere il pacchetto e quindi dipendenze e download vari dei pacchetti sono già stati fatti...
cmq anche aggiungendo la chiave a package.keywords il risultato nn cambia..
riposto l'output in code stavolta (sbagliando si impara :D)

Code:

bambucha pau # emerge pitivi
Calculating dependencies... done!

>>> Emerging (1 of 1) media-video/pitivi-0.10.1 to /
 * pitivi-0.10.1.tar.bz2 MD5 ;-) ...                                      [ ok ]
 * pitivi-0.10.1.tar.bz2 RMD160 ;-) ...                                   [ ok ]
 * pitivi-0.10.1.tar.bz2 SHA1 ;-) ...                                     [ ok ]
 * pitivi-0.10.1.tar.bz2 SHA256 ;-) ...                                   [ ok ]
 * pitivi-0.10.1.tar.bz2 size ;-) ...                                     [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking pitivi-0.10.1.tar.bz2 ;-) ...                                 [ ok ]
>>> Unpacking source...
>>> Unpacking pitivi-0.10.1.tar.bz2 to /var/tmp/portage/media-video/pitivi-0.10.1/work
 * Fixing OMF Makefiles ...                                               [ ok ]
 * Running elibtoolize in: pitivi-0.10.1
 *   Applying max_cmd_len-1.5.0.patch ...
 *   Applying sed-1.5.6.patch ...
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-video/pitivi-0.10.1/work/pitivi-0.10.1 ...

!!! ERROR: media-video/pitivi-0.10.1 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 1704:   Called src_compile
  pitivi-0.10.1.ebuild, line 32:   Called addpredict '/root/.gconf' '/root/.gconfd' '/root/.gstreamer-0.10'
  ebuild.sh, line 105:   Called die

!!! Usage: addpredict <colon-delimited list of paths>
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-video/pitivi-0.10.1/temp/build.log'.


c'è cmq quella strana riga "!!! Usage: addpredict <colon-delimited list of paths>" che secondo me è la chiave del mistero!!:p

beh mi affido alla vostra onniscienza...

a proposito perchè non usare la variabile?? molto più versatile rispetto ad editare ogni volta un file di testo...

allora a presto...CIAO
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Mar 09, 2007 1:40 am    Post subject: Reply with quote

allora: su bugs.gentoo.org ho trovato questo: https://bugs.gentoo.org/show_bug.cgi?id=169181
inoltre hanno fatto un version bump dell'ebuild in quanto è uscita una nuova versione, quindi magari ti conviene modificare l'ebuild per prendere direttamente quella successiva.

Per quanto riguarda l'utilizzo della variabile da linea di comando i motivi sono semplici e possono essere ridotti ad 1: non scassi la tua installazione.
mi spiego meglio
Se tu metti ACCEPT_KEYWORDS dici ad emerge per _quella_ _singola_ _installazione_ di prendere software in testing. la volta successiva che lanci emerge lui non lo farà più. quindi potresti, nel caso in cui esista una versione stabile meno recente subire un downgrade del programma.
Inoltre corri il rischio di sostituire molte librerie di sistema con la rispettiva versione in testing rischiando di scassare un po' di cose.
Smascherando semplicemente il pacchetto con le relative dipendenze _strettamente necessarie_ eviti questo esponendo solo un numero limitato di programmi al problema. Volendo puoi anche selezionare una versione determinata del pacchetto in testing da installare ed emerge ne tiene traccia sempre ed in maniera trasparente.
Back to top
View user's profile Send private message
pau_boex
n00b
n00b


Joined: 07 Mar 2007
Posts: 4

PostPosted: Fri Mar 09, 2007 5:03 pm    Post subject: Reply with quote

beh a quanto ho visto il pacchetto è proprio corrotto...
cmq sono riuscito ad installare la versione precedente..ma purtroppo i guai per me(e di riflesso anche per voi:D) nn sono finiti...
quando avvio sto cavolo di pitivi guardate un pò che mi dice X...
Code:
pau@bambucha ~ $ pitivi
The program 'pitivi' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 46 error_code 3 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

uffa perchè nn me ne va bene una...
cmq da quanto ho capito è inutilizzabile sto pitivi con emerge...
beh se nn c'è altra soluzione provero a compilarmelo a manina, sperando di nn perdermi fra milioni e milioni di dipendenze...

aspetto allora un ultimo messagio di speranza...
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Mar 09, 2007 11:08 pm    Post subject: Reply with quote

io proverei con la versione successiva. ti crei un'overlay, sposti ebuild più eventuali file rinominandolo con la versione corretta. il 99% delle volte funziona senza sbattimenti, magari devi eliminare qualche patch oppure aspettare che rendano disponibile il nuovo ebuild.
Back to top
View user's profile Send private message
pau_boex
n00b
n00b


Joined: 07 Mar 2007
Posts: 4

PostPosted: Sat Mar 10, 2007 8:33 am    Post subject: Reply with quote

okok finalmente...tutto risolto...
allora per prima cosa ho modificato l'ebuild come indicato su bugzilla(solo che nn sapevo che una volta modificato l'ebuild,questo risultava corrotto finchè nn si aggiorna digest con
Code:
 ebuild /usr/portage/media-video/pitivi/pitivi-0.10.1.ebuild digest

scusatemi ma fino alla settimana scorsa ero uno slackweriano....
cmq in seguito poi, dopo essere riuscito a compilarlo, per quanto riguarda l'errore che "X" nn vuole creare la finestra è dovuto ad un bug interno di pitivi,ovviabile col comando
Code:
pitivi --sync

anche se nn ho capito bene per cosa stia quel sync...
grazie cmq per l'aiuto....al prox tred:D

ciao[/profile]
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Mar 10, 2007 11:06 am    Post subject: Reply with quote

edita il tuo primo post e metti il tag [Risolto] al titolo :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum