Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Profondità di colore per RecordMyDesktop [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Mar 06, 2007 6:07 pm    Post subject: Profondità di colore per RecordMyDesktop [Risolto] Reply with quote

Ciao a tutti.
Ho installato RecordMyDesktop, ma quando cerco di avviarlo, sia da utente normale che da root, mi dà lo stesso messaggio:
Code:
Only 24bpp color depth mode is currently supported.

Ora, nel mio xorg.conf ho impostato per l'appunto
Code:
...
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "1024x768" "800x600"
        EndSubSection
EndSection
...

E allora perchè non funge?
Si può impostare questa risoluzione anche in altri modi, ad esempio tramite il Centro di Controllo di KDE?
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)


Last edited by canduc17 on Wed Mar 07, 2007 8:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Mar 06, 2007 10:30 pm    Post subject: Reply with quote

Non conosco il programma in questione, ma che profondità colore ti servirebbero??? Non ti basta aggiungere le altre? (per esempi basta che guardi xorg.conf.example che hai nel tuo sistema)
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Tue Mar 06, 2007 10:35 pm    Post subject: Reply with quote

Peach wrote:
Non conosco il programma in questione, ma che profondità colore ti servirebbero??? Non ti basta aggiungere le altre? (per esempi basta che guardi xorg.conf.example che hai nel tuo sistema)

Scusa ma hai letto il suo post ?
Ha riportato il messaggio di errore del programma dove si legge chiaramente che il programma supporta solo i 24bpp e ha postato anche una parte di configurazione dove mostra di aver abilitato solo i 24bpp.
Lui sarebbe anche a posto ma sembra che recordmydesktop non riconosca la configurazione del sistema.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Mar 06, 2007 10:40 pm    Post subject: Reply with quote

Kernel78 wrote:
Ha riportato il messaggio di errore del programma dove si legge chiaramente che il programma supporta solo i 24bpp

:oops: /me orbo! avevo letto il contrario. Cioè che si lamentava che c'era SOLO il supporto 24bit. pardonne moi !
Cmq in che profondità colore sia X si può verificare con
Code:
# grep Depth /var/log/Xorg.0.log

in alternativa è effettivamente un problema del programma.
scusate ancora.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 7:47 am    Post subject: Reply with quote

In effetti:
Code:
candooc canduc # grep Depth /var/log/Xorg.0.log
(==) RADEON(0): Depth 16, (==) framebuffer bpp 16
(II) RADEON(0): Depth moves disabled by default

Però allora non so come impostare i 24 bit...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Mar 07, 2007 7:56 am    Post subject: Reply with quote

Che il problema sia nel framebuffer, che tu hai impostato a 16bit (65535 colori)?

Io nel mio grub.conf ho
Code:

... video=vesafb:1024x768-32@60 ...


e X.org viene impostato correttamente a 24bit
Code:

# grep -i depth /var/log/Xorg.0.log
(**) RADEON(0): Depth 24, (--) framebuffer bpp 32
(II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(--) Depth 24 pixmap format is 32 bpp
(==) RADEON(0): Using 24 bit depth buffer
(II) RADEON(0): Depth moves disabled by default
(II) RADEON(0): Will use depth buffer at offset 0x1900000

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 8:48 am    Post subject: Reply with quote

Ho modificato il mio il mio grub.conf con:
Code:
title=Gentoo Linux 2.6.18
root(hd0,1)
kernel /boot/kernel-genkernel-x86_64-2.6.18-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda4 udev video=vesafb:ywrap,mtrr,1280x1024-24@70
initrd /boot/initramfs-genkernel-x86_64-2.6.18-gentoo-r6

ma ottengo ancora
Code:
(==) RADEON(0): Depth 16, (==) framebuffer bpp 16
(II) RADEON(0): Depth moves disabled by default

Magari tu hai un certo parametro in xorg.conf che io non ho...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Mar 07, 2007 8:54 am    Post subject: Reply with quote

Metti 1280x1024-32@70, non -24. Prova così! :wink: (nel mio X.org non ho nessuna voce particolare, quindi penso sia un problemino di framebuffer, visti i messaggi del log di X.Org)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 9:05 am    Post subject: Reply with quote

Provato ma niente da fare...
La soluzione sta da un'altra parte... :( :( :(
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Mar 07, 2007 9:10 am    Post subject: Reply with quote

Nella sezione Screen di Xorg.conf hai impostato
Code:
DefaultDepth 24
:?:

PS: che scheda video radeon hai?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 9:40 am    Post subject: Reply with quote

Ok, facendo così sono riuscito ad impostare la profondità di colore a 24 bpp.
Però adesso è sorto un altro problema: non ho più disponibile in KDE la risoluzione 1280x1024.
Con la nuova profondità di colore, la risoluzione si è autosettata a 1024x768 e le altre risoluzioni disponibili nel centro di controllo sono:
Code:
800x600
640x350
640x400
720x400
640x480
832x624
1152x768

Per quale cavolo di motivo queste risoluzioni, visto che in xorg.conf ho:
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "1280x1024" "1024x768" "800x600"
        EndSubSection
EndSection


P.S.: Ho una insopportabile ATI Mobility Radeon 9700
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Mar 07, 2007 10:27 am    Post subject: Reply with quote

evidentemente la tua scheda non supporta i 24bpp @ 1280x1024.
controlla le specifiche della scheda, ma temo sia così.
Spero solo che tu abbia un monitor lcd o con refresh rate > 60Hz (lo dico per i tuoi occhi non per altro ;) )
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 10:39 am    Post subject: Reply with quote

Bene, quando si dice la fortuna...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Mar 07, 2007 8:52 pm    Post subject: Reply with quote

Ho risolto mettendo queste impostazioni in xorg.conf:
Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync   31.5 - 80.5
        VertRefresh 60 - 85
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "1280x1024" "1280x800"
        EndSubSection
EndSection


Così ad una risoluzione di 1280x800 riesco ad avere una profondità di colore di 24bpp.
Ovviamente con 1280x1024 si vede meglio, ma è accettabile per fare i filmatini di cui ho bisogno.
Bella!
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum