Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! ERROR: kde-base/krdc-3.5.5 failed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
NOVIZIO
n00b
n00b


Joined: 21 Apr 2005
Posts: 27

PostPosted: Tue Mar 06, 2007 3:39 pm    Post subject: !!! ERROR: kde-base/krdc-3.5.5 failed Reply with quote

Ho fatto l'installazione di Gentoo 2006.1 minimal, seguendo la Quick installation.
Prima di installare GRUB , che mi da' errore ( e poi anche LILO che da' anche lui errore ma mi ha salvato per il dual boot ), ho fatto l'emerge di Genkernel.
(kernel-config-x86-2.6.19-gentoo-r5)
Dopo di che ho riavviato ( without CD surely ) e non mi vedeva nè eth0 nè ssh, ma poi ( forse ) ho risolto.
Quindi sono passato ad installare KDE. -> emerge kde-meta
Ma dopo un po' :

!!! ERROR: kde-base/krdc-3.5.5 failed
Call stack
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
krdc-3.5.5.ebuild, line: 22 Called kde-meta_src_compile
kde-meta.eclass, line 379: Called kde_src_compile
kde.eclass, line 170: Called kde_src_compile 'all'
kde.eclass, line 340: Called kde_src_compile 'myconf' 'configure' 'make'
kde.eclass, line 336: Called die

!!! died running emake, kd_src_compile: make
!!! If you need support, post the topmost build error, and the call stack, if relevant.

Qualcuno sa aiutarmi ? Avviso che e' la prima installazione di Gentoo e company.

Thanks
_________________
Chiedo venia per l'user maiuscolo, ma non me ne sono accorto !!! mannagggia
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Tue Mar 06, 2007 3:44 pm    Post subject: Re: !!! ERROR: kde-base/krdc-3.5.5 failed Reply with quote

NOVIZIO wrote:
!!! If you need support, post the topmost build error, and the call stack, if relevant.


Posta un pò di righe di compilazione, in quello che hai postato manca il topmost build error
_________________
Ciao da me!
Back to top
View user's profile Send private message
NOVIZIO
n00b
n00b


Joined: 21 Apr 2005
Posts: 27

PostPosted: Tue Mar 06, 2007 3:54 pm    Post subject: Reply with quote

Scusa l'ingnoranza, non vorrei sprofondare nella vergogna assoluta, ma permettimelo visto che mi sto avvicinando a questo mondo, cos'e' il " topmost build error " e come posso trovarlo ?
_________________
Chiedo venia per l'user maiuscolo, ma non me ne sono accorto !!! mannagggia
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Mar 06, 2007 4:10 pm    Post subject: Reply with quote

è l'errore di build (= compilazione) che è scritto più in alto (topmost).
You no speak inglisc ? :wink:
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
NOVIZIO
n00b
n00b


Joined: 21 Apr 2005
Posts: 27

PostPosted: Tue Mar 06, 2007 4:30 pm    Post subject: Reply with quote

Ho provato a rilanciarlo con " emerge kde --resume --skipfirst ", ma ovviamente mi da errore, penso un altro:

!!! ERROR: kde-base/kopete-3.5.5-r2 failed
Call stack
ebuild.sh, line 1555: Called dyn_compile
ebuild.sh, line 668: Called pkg_compile
kopete-3.5.5-r2.ebuild, line 67: Called die

!!! died running emake, kd_src_compile: make
!!! If you need support, post the topmost build error, and the call stack, if relevant.


Sopra ci sono solo le linee di compilazione di cui le ultime tre con asterisco rosso riguardanti Video4Linux:

To support Video4Linux webcams in this package is required to have =x11-libs/qt-3* compiled with OpenGL support.
Please reemerge =x11-libs/qt-3* with USE="opengl"
_________________
Chiedo venia per l'user maiuscolo, ma non me ne sono accorto !!! mannagggia
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Tue Mar 06, 2007 4:59 pm    Post subject: Reply with quote

per questa volta e' sufficiente, pero' in futuro posta qualche righetta in piu', tanto il db del forum ha le spalle belle larghe e non sempre l'output di errore e' cosi' esplicito :wink:

in ogni caso direi che il messaggio e' autoesplicativo: devi riemergere le qt3 con la use opengl. Per farlo o specifichi la use globalmente in make.conf oppure la aggiungi a package.use

Perche' tutto cio'? Perche' stai installando kopete (client msn) con il supporto webcam, che richiede la use opengl attiva nelle librerie d isupporto (qt appunto). Quindi i casi sono 2: o fai come detto sopra e ricompili qt con il supporto adeguato oppure compili kopete senza la flag per il supporto alla webcam. Un emerge -pv kopete puo' essere utile per vedere le flag usate da kopete in compilazione

ah, benvenuto a bordo :P
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
NOVIZIO
n00b
n00b


Joined: 21 Apr 2005
Posts: 27

PostPosted: Tue Mar 06, 2007 5:18 pm    Post subject: Reply with quote

Scusa la domanda sicuramente elementare e stupida, quindi per compilare il tutto si puo' fare o esiste il comando:

emerge qt3 -useopengl -----> --emptytree
_________________
Chiedo venia per l'user maiuscolo, ma non me ne sono accorto !!! mannagggia
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Tue Mar 06, 2007 5:35 pm    Post subject: Reply with quote

NOVIZIO wrote:
Scusa la domanda sicuramente elementare e stupida, quindi per compilare il tutto si puo' fare o esiste il comando:

emerge qt3 -useopengl -----> --emptytree


Non ho capito cosa intendi ma non é necessario ricompilare *tutto*.

Dovrebbe bastare fare:

Code:
# echo "x11-libs/qt-3 opengl" >> /etc/portage/package.use
# emerge qt-3

_________________
Ciao da me!
Back to top
View user's profile Send private message
richard77
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 275

PostPosted: Tue Mar 06, 2007 5:52 pm    Post subject: Reply with quote

Quote:
Ho fatto l'installazione di Gentoo 2006.1 minimal, seguendo la Quick installation. [..]
Qualcuno sa aiutarmi ? Avviso che e' la prima installazione di Gentoo e company.


La guida veloce serve come riferimento a chi a già diversa esperienza nell'installazione di Gentoo e ha bisogno solo di una lista dei passaggi fondamentali.
Non è assolutamente adatta a un "NOVIZIO" alla prima installazione.

Anche la tua ultima domanda trova risposta esauriente nel manuale completo.
_________________
Fletto i muscoli e sono nel vuoto
Back to top
View user's profile Send private message
NOVIZIO
n00b
n00b


Joined: 21 Apr 2005
Posts: 27

PostPosted: Wed Mar 07, 2007 10:48 am    Post subject: Reply with quote

Rieccomi

Ho fatto:

Code:
# echo "x11-libs/qt-3 opengl" >> /etc/portage/package.use
# emerge qt-3


ma mi ha dato questo errore

Code:
--- Invalid atom in /etc/portage/package.use: x11-libs/qt-3
Calculating dependencies

!!! 'qt-3' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)


non so se interessa ho fatto anche:

Code:
emerge -p kdebase-startkde kicker | less


il risultato e' questo:

Code:
--- Invalid atom in /etc/portage/package.use: x11-libs/qt-3

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild   R   ] kde-base/kdebase-startkde-3.5.5
[ebuild   R   ] kde-base/kicker-3.5.5


:?





--- Invalid atom in /etc/portage/package.use: x11-libs/qt-3
Calculating dependencies

!!! 'qt-3' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)



These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R ] kde-base/kdebase-startkde-3.5.5
[ebuild R ] kde-base/kicker-3.5.5
_________________
Chiedo venia per l'user maiuscolo, ma non me ne sono accorto !!! mannagggia
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Mar 07, 2007 11:15 am    Post subject: Reply with quote

@NOVIZIO
ma li leggi gli errori che ti vengono fuori??? oppure come li venti te ne lavi le mani postandoli sul forum????
Code:

--- Invalid atom in /etc/portage/package.use: x11-libs/qt-3
Calculating dependencies

!!! 'qt-3' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)

ti dice che devi mettere =x11-libs/qt-3 , oppure eliminare il 3, poichè non è valid package atom.

ciao
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Mar 07, 2007 1:02 pm    Post subject: Reply with quote

guarda che qt-3 non esiste, è qt-3.3.6-rqualcosa il corrente, quindi o "<=x11-libs/qt-4.0.0 opengl" o "=x11-libs/qt-3... opengl" o semplicemente "x11-libs/qt opengl" e lo applichi a tutte le versioni.
Consiglio: non applicare pedissequamente quel che ti viene detto ma verifica sempre e documentati.
randomaze voleva dire "aggiungi la riga con la versione corrente di qt release 3", ovviamente non puoi pretendere che per ogni post si vada a verificare sul proprio pc qual è la versione esatta. Non è un helpdesk quindi è più facile che ti vengano forniti suggerimenti e non soluzioni.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum