Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ati Drivers - module not found [risolto] [conf]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Wed Mar 07, 2007 9:27 pm    Post subject: Ati Drivers - module not found [risolto] [conf] Reply with quote

stavolta dopo aver emerso ati-drivers il modulo non esiste...
Code:

IlVile ~ # modprobe fglrx
FATAL: Module fglrx not found.


Code:

IlVile ~ # emerge -pv ati-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-drivers/ati-drivers-8.34.8  USE="qt3 -acpi" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


il kernel è quello dell'ultimo livecd (2006.1)
Code:

IlVile ~ # uname -a
Linux IlVile 2.6.17-gentoo-r7 #1 SMP Wed Sep 20 14:24:14 UTC 2006 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GenuineIntel GNU/Linux


ps ho provato a compilare il gentoo-sources-2.6.20 ma mi va in panic all'avvio perchè non riesce a montare / (ext3 e supporto built-in)

e ora la domanda da niubbo: cosa ho dimenticato?
esiste una guida aggiornata tra le diverse per i driver ati? (io ho seguito sia quella del wiki sia quella del sito ati senza grossi risultATI)
_________________
sono colui che sostiene il reale


Last edited by Xet on Thu Mar 08, 2007 10:48 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4665
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Mar 07, 2007 9:39 pm    Post subject: Re: Ati Drivers - la storia infinata :) module not found Reply with quote

Xet wrote:

e ora la domanda da niubbo: cosa ho dimenticato?

non ho esperienza di ati drivers, ma la riposta da nubbio, generalmente, è: non hai fissato il link in /usr/src/linux
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Wed Mar 07, 2007 9:48 pm    Post subject: Reply with quote

io per ati ho utilizzato questa guida è più che ottima!
http://gentoo-wiki.com/HOWTO_ATI_Drivers
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Wed Mar 07, 2007 10:05 pm    Post subject: Reply with quote

Code:

IlVile ~ # ls -l /usr/src/
total 8
drwxr-xr-x  2 root root 4096 Mar  4 13:42 ati
lrwxrwxrwx  1 root root   19 Mar  6 09:04 linux -> linux-2.6.20-gentoo
drwxr-xr-x 20 root root 4096 Mar  7 23:58 linux-2.6.20-gentoo


intendevi /usr/src/linux vero?
_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Mar 07, 2007 10:25 pm    Post subject: Reply with quote

guarda... io c'ho un po' di esperienza nei stramaledetti ati-drivers
(mai più una ATI)
cmq....
per un motivo a me sconosciuto alla fine funziona così.
prendi un kernel e segui la guida che ti ha linkato xveilsidex e poi provi le diverse versioni dei driver disponibili.
uno tra quelli ti va... alla fine è sempre un terno al lotto.
sembra un assurdo ma cambi kernel e devi anche cambiare la versione del driver per poter trovare quella che va bene....
:roll:
mah, ATI... una scheda, un perchè

lo so che è un aiuto del cavolo... però alla fine la mia esperienza mi ha fatto capire questo (se cerchi sul forum ATI drivers, sicuramente vedrai tutti i miei interventi)
_________________
Darkman
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Wed Mar 07, 2007 10:34 pm    Post subject: Reply with quote

darkmanPPT wrote:
mai più una ATI


parole sante...


p.s. ma i vesa non supportano dualhead? ^_^
i mesa?
_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Wed Mar 07, 2007 11:32 pm    Post subject: Reply with quote

io ho un kernel 2.6.19-r5 con i drivers 8.32.5! per ptoerli far funzionare devi avere CONFIG_VM86=y altrimenti romper le scatole ( almeno nel mio caso )
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Thu Mar 08, 2007 12:13 am    Post subject: Reply with quote

xveilsidex wrote:
per ptoerli far funzionare devi avere CONFIG_VM86=y


celo!

Code:

IlVile ~ # cat /usr/src/linux/.config | grep CONFIG_VM86 
CONFIG_VM86=y

_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Thu Mar 08, 2007 12:28 am    Post subject: Reply with quote

update:
ho accelerazione 3d hardware con i driver closed source...
peccato che siano tornati tutti quei problemi con la tastiera e il mouse:
leggasi non funziona alt-gr (quindi non posso manco passare ai terminali) e il wheel cambia 2 virtual desktop in un movimento... :D

vabbeh ma questi adesso li caccero' dal mio sistema!

il fatto di non trovare il modulo era molto provabilmente dovuto ad un errore di config del kernel (leggasi drm built in)
al momento ho compilato agpgart, intel_agp, drm e radeon come moduli, così posso scegliere se usare ati closed o open.
una volta caricato il sistema modprobo i moduli che mi interessano e scelgo quale xorg.conf usare

grazie per il supporto :)
_________________
sono colui che sostiene il reale


Last edited by Xet on Thu Mar 08, 2007 10:47 am; edited 1 time in total
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Thu Mar 08, 2007 12:56 am    Post subject: Reply with quote

se serve ho postato la "soluzione" qui
_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum