Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OpenOffice-bin]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Sun Mar 04, 2007 6:17 pm    Post subject: [OpenOffice-bin] Reply with quote

Hello tous,
j'ai recherché mais pas de solution trouvé, OpenOffice ne se lance pas, c'est la version binaire. Ces messages d'erreurs apparaîssent :

Code:
julroy67@Gentoo-Tux ~ $ oowriter2
KCrash: Application 'soffice.bin' crashing...
KCrash cannot reach kdeinit, launching directly.


Si quelqu'un sait quelque chose, ou trouve mieux ^^, parce que j'ai bien cherché, enfin je crois.

Mon emerge --info :

Code:
Gentoo-Tux julroy67 # emerge --info
Portage 2.1.2.1 (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.5-r0, 2.6.20-gentoo i686)
=================================================================
System uname: 2.6.20-gentoo i686 AMD Athlon(tm) XP 2000+
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 04 Mar 2007 17:50:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.20-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer -ffast-math"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O3 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer -ffast-math"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ http://ftp.club-internet.fr/pub/mirrors/gentoo ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds X a52 aac alsa arts bash-completion bitmap-fonts bzip2 cairo cdparanoia cdr cegui cg cli cpudetection cracklib crypt cups curl custom-cflags dbus dri dvd dvdread encode exif ffmpeg firefox flac fortran ftp geoip gif gimp gimpprint glitz glut gphoto2 gpm gtk gtk2 gtkhtml hal iconv icq imagemagick ipod ipv6 isdnlog jabber java javascript jpeg jpeg2k kde kdehiddenvisibility kdexdeltas ladspa lame libg++ libnotify libsamplerate lm_sensors lua mad matroska md5sum midi mime mmx mmxext mng mono motif mp3 mpeg mplayer msn musepack musicbrainz ncurses nls nojoystick nptl nptlonly nsplugin ntfs ogg openal opengl oscar pam pcre pdf perl png posix ppds pppd pulseaudio python qt4 quicktime readline real reflection samplerate scanner sensord session skins speex spell spl sse ssl svg symlink tcl tcpd theora threads tiff tk truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vorbis win32codecs wmf wxwindows x86 xine xml xorg xosd xpm xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_RSYNC_EXTRA_OPTS


revdep-rebuild :

Code:
Gentoo-Tux julroy67 # revdep-rebuild
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... Nothing to rebuild

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

Dynamic linking on your system is consistent... All done.

_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux


Last edited by julroy67 on Mon Mar 05, 2007 9:12 am; edited 2 times in total
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Mar 04, 2007 9:44 pm    Post subject: Reply with quote

tu es sous kde ?
t'as pas installé openoffice avec kde dans tes use flags alors que tu l'utilises pas ?
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Sun Mar 04, 2007 10:48 pm    Post subject: Reply with quote

Hum je suis sous KDE ^^, malheureusement sa nous avance pas beaucoup. Merci quand même.
Tant qu'à faire je vais essayer une fois sans le USE kde ou java que j'ai activé.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sun Mar 04, 2007 10:58 pm    Post subject: Reply with quote

'alute

nan ça changera rien. Tu peux montrer un emerge --info stp histoire de voir si tu n'as pas joué des LDFLAGS

sinon en prenant soin de sauvegarder ce qui doit l'être au préalable tu peux essayer de supprimer/déplacer les ~/.openoffice et ~/.kde.3.x avant de relancer
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8501
Location: ~Brussels - Belgique

PostPosted: Mon Mar 05, 2007 7:11 am    Post subject: Reply with quote

et un petit
Code:
revdep-rebuild
pour arranger les dépndances cassées ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Mon Mar 05, 2007 9:14 am    Post subject: Reply with quote

boozo wrote:

... histoire de voir si tu n'as pas joué des LDFLAGS

sinon en prenant soin de sauvegarder ce qui doit l'être au préalable tu peux essayer de supprimer/déplacer les ~/.openoffice et ~/.kde.3.x avant de relancer


Humm oui j'ai des petits LDFLAGS ^^ ça joue quelque chose arff
Et euh sinon en supprimant le dossier ~/.kde.3.5 un message d'erreur s'ajoute :

Code:
julroy67@Gentoo-Tux ~ $ oowriter2
KCrash: Application 'soffice.bin' crashing...
Warning: connect() failed: : Aucun fichier ou répertoire de ce type
KCrash cannot reach kdeinit, launching directly.

_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1725
Location: 127.0.0.1

PostPosted: Mon Mar 05, 2007 12:33 pm    Post subject: Reply with quote

Apparemment tu n'es pas le seul : bug #169391
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Mon Mar 05, 2007 1:04 pm    Post subject: Reply with quote

Arfff et dans ce cas là, on fait quoi ? :lol:
Sa m'embête sa, rhooo, et le compiler moi-même, non merci, trop nul mon PC ^^
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8501
Location: ~Brussels - Belgique

PostPosted: Mon Mar 05, 2007 1:30 pm    Post subject: Reply with quote

masquer la version courante et essayer la version précédente ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Mon Mar 05, 2007 1:39 pm    Post subject: Reply with quote

Ah, pas con du tout sa ^^.
Merci, j'essaie sa dès que je peux.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Tue Mar 06, 2007 10:07 am    Post subject: Reply with quote

Hummm y'a plus la version précédente dans portage pour Openoffice-bin :S

Bon ben je me débrouillerais avec KOffice ou sinon sous mon ancienne Gentoo, parce que là-bas ça marche et c'est la même config. :?

EDIT : Chouette j'ai corrigé ma faute :lol:
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux


Last edited by julroy67 on Tue Mar 06, 2007 10:21 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8501
Location: ~Brussels - Belgique

PostPosted: Tue Mar 06, 2007 10:10 am    Post subject: Reply with quote

tiens, une petite remarque : ça s'écrit comme ça : ça :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
KlemZ
n00b
n00b


Joined: 12 Dec 2004
Posts: 46
Location: France, Nantes

PostPosted: Wed Mar 07, 2007 8:51 am    Post subject: Reply with quote

Salut,
J'ai eu le même problème il y a un bout de temps et il est difficile de retrouver la solution sur le forums
ça vient du CFLAG : -ffast-math
il faut recompiler les packets : kde-base/kdelibs kde-base/kdeartwork-styles dev-libs/openssl
sans ce flag.


https://forums.gentoo.org/viewtopic-t-467213-highlight-openoffice+kde+ffastmath.html

(j ai retrouvé le post qui en parle)
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Thu Mar 08, 2007 4:35 pm    Post subject: Reply with quote

Aaaahhhh, :evil: damned, sa va me prendre longtemps, très longtemps de recompiler KDE. :x Roooh bon alors au travail. Je vais voir sa.

EDIT: Quelqu'un pourrait me dire comment on fait pour désactiver -ffast-math pour ces paquets (une façon propre :D ), je me souvient pas avoir lu comment faire sa.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux


Last edited by julroy67 on Thu Mar 08, 2007 4:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Thu Mar 08, 2007 4:41 pm    Post subject: Reply with quote

En même temps --fast-math c'est connu pour casser des compilations...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Mar 08, 2007 5:38 pm    Post subject: Reply with quote

Regarde du côté :wink: des cflafs par paquets.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Thu Mar 08, 2007 7:42 pm    Post subject: Reply with quote

:( Hmmm malheur sur moi, sa marche toujours pas !!!
Rooo je suis maudit d'OpenOffice ^^

Même si le message d'erreur s'est raccourci
Code:
KCrash: Application 'soffice.bin' crashing...


Mais merci quand même à ceux qui m'aident.

EDIT : Et quelqu'un peut m'expliquer sa (peut-être la solution est dedans)

Code:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7eff410 in __kernel_vsyscall ()
#0  0xb7eff410 in __kernel_vsyscall ()
#1  0xb6c958e6 in nanosleep () from /lib/libc.so.6
#2  0xb6c9570f in sleep () from /lib/libc.so.6
#3  0xb5840af0 in KCrash::startDrKonqi ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#4  0xbfd06670 in ?? ()
#5  0xb64e56ac in ?? ()
#6  0xbfd05480 in ?? ()
#7  0x00d2f150 in ?? ()
#8  0x00000003 in ?? ()
#9  0x00000011 in ?? ()
#10 0xbfd07600 in ?? ()
#11 0xb6c7073b in ?? () from /lib/libc.so.6
#12 0x00006178 in ?? ()
#13 0x6f6b7264 in ?? ()
#14 0x0069716e in ?? ()
#15 0x7369642d in ?? ()
#16 0x79616c70 in ?? ()
#17 0x2e303a00 in ?? ()
#18 0x2d2d0030 in ?? ()
#19 0x6e707061 in ?? ()
#20 0x00656d61 in ?? ()
#21 0x66666f73 in ?? ()
#22 0x2e656369 in ?? ()
#23 0x006e6962 in ?? ()
#24 0x69732d2d in ?? ()
#25 0x6c616e67 in ?? ()
#26 0x00313100 in ?? ()
#27 0x69702d2d in ?? ()
#28 0x34320064 in ?? ()
#29 0x00373937 in ?? ()
#30 0x70612d2d in ?? ()
#31 0x72657670 in ?? ()
#32 0x6e6f6973 in ?? ()
#33 0x312e3100 in ?? ()
#34 0x2d00302e in ?? ()
#35 0x6f72702d in ?? ()
#36 0x6d617267 in ?? ()
#37 0x656d616e in ?? ()
#38 0x65704f00 in ?? ()
#39 0x66664f6e in ?? ()
#40 0x2e656369 in ?? ()
#41 0x0067726f in ?? ()
#42 0x75622d2d in ?? ()
#43 0x64646167 in ?? ()
#44 0x73736572 in ?? ()
#45 0x76656400 in ?? ()
#46 0x65646b40 in ?? ()
#47 0x65706f2e in ?? ()
#48 0x66666f6e in ?? ()
#49 0x2e656369 in ?? ()
#50 0x0067726f in ?? ()
#51 0x74732d2d in ?? ()
#52 0x75747261 in ?? ()
#53 0x00646970 in ?? ()
#54 0x00000030 in ?? ()
#55 0x00000000 in ?? ()


C'est les erreurs que je reçois dans KDE dès que sa crash.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Fri Mar 09, 2007 10:22 am    Post subject: Reply with quote

julroy67 wrote:

EDIT : Et quelqu'un peut m'expliquer sa (peut-être la solution est dedans)


Ca n'explique pas ton problème.

Quand une application "crash", kcrash cherche à faire un rapport sur le crash. Dans celui-ci, il va indique la pile d'appelsqui a conduit à ce crash.

Une fois qu'il a cet pile, il essaie de remplacer les adresses (0x73736572 par exemple), par le nom de la fonction qui se trouve à cette adresse. Pour celà il cherche les "debugging symbol" : 0x73736572 = fonction machin dans les bibliothèques. Dans ton cas, il ne trouve pas ces symboles (c'est normal ils ne sont pas générés par défaut).

PS: je trouve un peu bizarre que kcrash se lance pour openoffice qui n'est pas une application kde, mais c'est peut être normal...
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Fri Mar 09, 2007 10:35 am    Post subject: Reply with quote

Ah merci beaucoup pour ces explications, je me demandais toujours ce que sa voulait dire ^^ Jamais rien pigé au truc, maintenant c'est un peu plus clair.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum