Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
links -g no mouse da user
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dorian-gray84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2005
Posts: 107
Location: Ravenna

PostPosted: Fri Mar 02, 2007 12:55 pm    Post subject: links -g no mouse da user Reply with quote

Ho recuperato un portatile carrozzone dove voglio avviare X il meno possibile, solo per le cose indispensabili, visto che la ram scarseggia.
Ho configurato il framebuffer e gpm e ho installato links con il supporto a DirectFB per poterlo usare in modalita grafica.
Il problema e che se avvio links -g da root tutto funziona mentre da user viene si visualizzato il cursore del mouse ma rimane fisso al centro dello schermo.
Cercando su google ho trovato un accrocchio in cui si diceva di modificare i permessi di /dev/input/mice in rw-rw-rw- ed effettivamente con questa modifica il mouse funziona anche da user. Al successivo riavvio pero il problema si ripresentera.
Un altro modo potrebbe essere quello di settare il suid per links?
La cosa strana e che se avvio links normalmente il mouse funziona bene anche da user.
Ho anche letto in un sito francese (o almeno mi e sembrato di capire...il mio francese e molto scarno) che questo e un bug di links

PS: scusate per le lettere accentate ma nella modalita grafica tra le opzioni non ho trovato la possibilita di settare ne l apostrofo ne le accentate (altro problema che ho con sto browser...)

Grazie a chi mi sapra aiutare
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Mar 02, 2007 1:07 pm    Post subject: Re: links -g no mouse da user Reply with quote

dorian-gray84 wrote:
Un altro modo potrebbe essere quello di settare il suid per links?


Un brower in modalità root? 8O direi proprio di no. Al massimo MODE="0666" in udev.rules anche se una soluzione più corretta sarebbe attribuirlo al gruppo weel ed includerci il tuo utente.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum