Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Fazer o downgrade do php mas ñ atualizar o mysql ??
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
nuxman
n00b
n00b


Joined: 04 Feb 2004
Posts: 17
Location: Porto Velho/Brasil

PostPosted: Tue Feb 27, 2007 2:01 am    Post subject: [solved]Fazer o downgrade do php mas ñ atualizar o mysql ?? Reply with quote

Olá tenho um servidor com a versão do php 5 mas quero fazer o downgrade para a versão 4, mas tenho problemas pq tenho o mysql 4.1 e quando executo o emerge tenho o pretende de instalar o mysql 5 ... mas eu quero o mysql 4.1 e não 5 ... :-)
Code:


mx001 ~ # USE="mysql bzip2 calendar gd imap iconv pcre snmp" emerge -tpv =dev-lang/php-4.4.4-r6

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  NS   ] dev-lang/php-4.4.4-r6  USE="berkdb bzip2 calendar crypt doc gd iconv imap ldap mysql ncurses pcre readline snmp ssl zlib (-adabas) -apache -apache2 -bcmath (-birdstep) -cdb -cgi -cjk -cli -concurrentmodphp -ctype -curl (-db2) -dbase (-dbmaker) -dbx -debug -discard-path (-empress) (-empress-bcs) (-esoob) -exif -expat -fastbuild -fdftk (-filepro) -firebird -flatfile -force-cgi-redirect (-frontbase) -ftp -gd-external -gdbm -gmp -hardenedphp -hyperwave-api (-informix) -inifile -interbase -iodbc -ipv6 -java-external -java-internal -kerberos -libedit -mcal -mcve -memlimit -mhash -ming -mnogosearch -msql -mssql -nls (-oci8) (-oci8-instant-client) -odbc (-oracle7) -overload -ovrimos -pcntl (-pfpro) -pic -posix -postgres -recode -sapdb -session -sharedext -sharedmem -sockets (-solid) -spell -sqlite (-sybase) (-sybase-ct) -sysvipc -threads -tokenizer -truetype -unicode -wddx -xml -xmlrpc -xpm -xsl -yaz -zip" 4,395 kB
[ebuild     U ]  virtual/mysql-5.0 [4.1] 0 kB
[ebuild     U ]   dev-db/mysql-5.0.26-r2 [4.1.22-r1] USE="berkdb selinux ssl -big-tables -cluster -debug -embedded -extraengine -latin1* -max-idx-128% -minimal -perl -static (-raid%)" 0 kB

Total: 3 packages (2 upgrades, 1 in new slot), Size of downloads: 4,395 kB


Last edited by nuxman on Tue Feb 27, 2007 7:44 pm; edited 2 times in total
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Tue Feb 27, 2007 12:05 pm    Post subject: Re: Fazer o downgrade do php mas não atualizar o mysql ?? Reply with quote

[quote="nuxman"]Olá tenho um servidor com a versão do php 5 mas quero fazer o downgrade para a versão 4, mas tenho problemas pq tenho o mysql 4.1 e quando executo o emerge tenho o pretende de instalar o mysql 5 ... mas eu quero o mysql 4.1 e não 5 ... :-)
[code]

mx001 ~ # USE="mysql bzip2 calendar gd imap iconv pcre snmp" emerge -tpv =dev-lang/php-4.4.4-r6
[/quote]

Lamento, mas parece que o php-4.4 precisa de mysql 5, você terá que usar um php mais velho. No caso, o 4.3, que é mascarado e em breve não deve existir mais.

Mas...

[quote]mas eu quero o mysql 4.1 e não 5
[/quote]

Porque?
_________________
Coisas que todo usuário de gentoo tem que saber:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2
http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22
Back to top
View user's profile Send private message
nuxman
n00b
n00b


Joined: 04 Feb 2004
Posts: 17
Location: Porto Velho/Brasil

PostPosted: Tue Feb 27, 2007 1:00 pm    Post subject: Re: Fazer o downgrade do php mas não atualizar o mysql ?? Reply with quote

thiagonunes wrote:
nuxman wrote:
Olá tenho um servidor com a versão do php 5 mas quero fazer o downgrade para a versão 4, mas tenho problemas pq tenho o mysql 4.1 e quando executo o emerge tenho o pretende de instalar o mysql 5 ... mas eu quero o mysql 4.1 e não 5 ... :-)
[code]

mx001 ~ # USE="mysql bzip2 calendar gd imap iconv pcre snmp" emerge -tpv =dev-lang/php-4.4.4-r6


Lamento, mas parece que o php-4.4 precisa de mysql 5, você terá que usar um php mais velho. No caso, o 4.3, que é mascarado e em breve não deve existir mais.

Mas...

Quote:
mas eu quero o mysql 4.1 e não 5


Porque?


Olá ja Resolvi simplesmente tenho que colocar no arquivo /etc/portage/packages.mask as seguintes linhas abaixo
Quote:

=dev-db/mysql-5*
=virtual/mysql-5*


Assim poderei fazer o downgrade sem problemas, sobre o php 4 não importa qual versão ... o emerge sempre instala o mysql 5 ,,, um abraço
___________________________________
www.nuxro.org
NuXr0 - Comunidade SL de Rondonia
Gentoo - MASTERPIECE
http://www.youtube.com/watch?v=pqm4JuVO9Yk
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum