Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Perl 5.8.8-r2 & linuxheaders-2.6.20-r1- asm/page.h [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
_dA_CyANIDe
Apprentice
Apprentice


Joined: 30 Mar 2005
Posts: 196
Location: Czech Republic

PostPosted: Mon Feb 26, 2007 7:53 pm    Post subject: Perl 5.8.8-r2 & linuxheaders-2.6.20-r1- asm/page.h [SOLV Reply with quote

Hello,

system not compiled after some updates... i got this:

Code:


Writing Makefile for IPC::SysV
make[1]: Entering directory `/var/tmp/portage/dev-lang/perl-5.8.8-r2/work/perl-5.8.8/ext/IPC/SysV'
make[1]: Leaving directory `/var/tmp/portage/dev-lang/perl-5.8.8-r2/work/perl-5.8.8/ext/IPC/SysV'
make[1]: Entering directory `/var/tmp/portage/dev-lang/perl-5.8.8-r2/work/perl-5.8.8/ext/IPC/SysV'
cp Msg.pm ../../../lib/IPC/Msg.pm
cp Semaphore.pm ../../../lib/IPC/Semaphore.pm
cp SysV.pm ../../../lib/IPC/SysV.pm
../../../miniperl "-I../../../lib" "-I../../../lib" ../../../lib/ExtUtils/xsubpp  -typemap ../../../lib/ExtUtils/typemap  SysV.xs > SysV.xsc && mv SysV.xsc SysV.c
x86_64-pc-linux-gnu-gcc -c   -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -march=athlon64 -msse3 -msse2 -frename-registers -pipe -fomit-frame-pointer -ftree-vectorize   -DVERSION=\"1.04\" -DXS_VERSION=\"1.04\" -fPIC "-I../../.."   SysV.c
SysV.xs:7:25: error: asm/page.h: No such file or directory
make[1]: *** [SysV.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-lang/perl-5.8.8-r2/work/perl-5.8.8/ext/IPC/SysV'
make: *** [lib/auto/IPC/SysV/SysV.so] Error 2



I think, that this is caused by new linuxheaders. Any suggestions how to fix this? Without downgrading linuxheaders?
_________________
AMD64 X2 3800+, 1GB RAM, Gigabyte GF7600
-----
Firewalls cannot block stupidity!


Last edited by _dA_CyANIDe on Mon Feb 26, 2007 8:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
haven
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 141
Location: Belfast, Uk

PostPosted: Mon Feb 26, 2007 8:23 pm    Post subject: Reply with quote

Same issue, same linuxheaders. I'm tempted to try a downgrade, fortunately this system does not use perl for much ...

[Update] Downgrading linux-headers to sys-kernel/linux-headers-2.6.19.2-r2 allowed perl to compile just fine.


Last edited by haven on Mon Feb 26, 2007 8:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
MoinMan
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2007
Posts: 78
Location: Liechtenstein

PostPosted: Mon Feb 26, 2007 8:31 pm    Post subject: Reply with quote

Had the same issue while recompiling my system. Found this bug and a workaround is in Comment#4.[/url]
Back to top
View user's profile Send private message
_dA_CyANIDe
Apprentice
Apprentice


Joined: 30 Mar 2005
Posts: 196
Location: Czech Republic

PostPosted: Mon Feb 26, 2007 8:53 pm    Post subject: Reply with quote

Yes, this is exactly what i'm looking for. Thanx.
_________________
AMD64 X2 3800+, 1GB RAM, Gigabyte GF7600
-----
Firewalls cannot block stupidity!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum