Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(RISOLTO) Installazione
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Wed Feb 28, 2007 12:34 pm    Post subject: Reply with quote

Code:
rc-update del coldplug default


risultato:

Code:


(chroor) livecd / # rc-update del coldplug default
 * 'coldplug' not found in any of the specified runlevels




Code:
revdep-rebuild


risultato:

Code:


(chroor) livecd / # revdep-rebuild
bash: revdep-rebuild: command not found




Code:
emerge --sync


risultato:

Code:


(chroor) livecd / # emerge --sync
Notice: (-3, 'Temporary failure in name resolution')
>>> Starting rsync with rsync://rsync.gentoo.org/gentoo-portage...
>>> Checking server timestamp ...
rsync: getaddrinfo: rsync.gentoo.org 873: Temporary failure in name resolution
rsync error: error in socket IO (code 10) at clientserver.c(107) [receiver=2.6.8]
>>> Retrying...

Notice: (-3, 'Temporary failure in name resolution')


>>> Starting retry 1 of 3 with rsync://rsync.gentoo.org/gentoo-portage
>>> Checking server timestamp ...
rsync: getaddrinfo: rsync.gentoo.org 873: Temporary failure in name resolution
rsync error: error in socket IO (code 10) at clientserver.c(107) [receiver=2.6.8]
>>> Retrying...
Notice: (-3, 'Temporary failure in name resolution')


>>> Starting retry 2 of 3 with rsync://rsync.gentoo.org/gentoo-portage
>>> Checking server timestamp ...
rsync: getaddrinfo: rsync.gentoo.org 873: Temporary failure in name resolution
rsync error: error in socket IO (code 10) at clientserver.c(107) [receiver=2.6.8]
>>> Retrying...
Notice: (-3, 'Temporary failure in name resolution')


>>> Starting retry 3 of 3 with rsync://rsync.gentoo.org/gentoo-portage
>>> Checking server timestamp ...
rsync: getaddrinfo: rsync.gentoo.org 873: Temporary failure in name resolution
rsync error: error in socket IO (code 10) at clientserver.c(107) [receiver=2.6.8]

!!! Rsync has not successfully finished. It is recommended that you keep
!!! trying or that you use the 'emerge-webrsync' option if you are unable
!!! to use rsync due to firewall or other restrictions. This should be a
!!! temporary problem unless complications exist with your network
!!! (and possibly your system's filesystem) configuration.



Il resto tutto ok.
ciauo
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Feb 28, 2007 12:52 pm    Post subject: Reply with quote

Tutti i comandi che ti sono stati elencati devi eseguirli DENTRO al sistema Gentoo, per cui, dopo aver avviato con il livecd, devi montare le partizioni ed effettuare il chroot, come spiegato nel Manuale Gentoo.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Wed Feb 28, 2007 1:13 pm    Post subject: Reply with quote

Scen wrote:
Tutti i comandi che ti sono stati elencati devi eseguirli DENTRO al sistema Gentoo, per cui, dopo aver avviato con il livecd, devi montare le partizioni ed effettuare il chroot, come spiegato nel Manuale Gentoo.


L'ho fatto :-D infatti sono chroot quando lancio i comandi e le partizioni sono tutte installate come da manuale.
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Feb 28, 2007 1:19 pm    Post subject: Reply with quote

gatto wrote:
Scen wrote:
Tutti i comandi che ti sono stati elencati devi eseguirli DENTRO al sistema Gentoo, per cui, dopo aver avviato con il livecd, devi montare le partizioni ed effettuare il chroot, come spiegato nel Manuale Gentoo.


L'ho fatto :-D infatti sono chroot quando lancio i comandi e le partizioni sono tutte installate come da manuale.


dagli output da te postati non si direbbe vedi (chroor), e non (chroot) come dice il manuale.
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Feb 28, 2007 1:20 pm    Post subject: Reply with quote

gatto wrote:
Il resto tutto ok.

Il resto senza quei comandi (nella giusta sequenza) conta poco niente.
coldplug probabilmente è nel runlevel boot, revdep-rebuild non è installato emerge -av app-portage/gentoolkit lo installa, il problema del sync sembra dato da un problema del dns o dal nome del mirror errato.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Feb 28, 2007 1:22 pm    Post subject: Reply with quote

crisandbea wrote:
dagli output da te postati non si direbbe vedi (chroor), e non (chroot) come dice il manuale.

e come sei fiscale, li poteva anche scriverci (pincopallino) e non cambierebbe nulla, si tratta solo di una modifica al prompt per non confondersi e ricordarsi che ci si trova in un chroot
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Wed Feb 28, 2007 1:33 pm    Post subject: Reply with quote

crisandbea wrote:
gatto wrote:
Scen wrote:
Tutti i comandi che ti sono stati elencati devi eseguirli DENTRO al sistema Gentoo, per cui, dopo aver avviato con il livecd, devi montare le partizioni ed effettuare il chroot, come spiegato nel Manuale Gentoo.


L'ho fatto :-D infatti sono chroot quando lancio i comandi e le partizioni sono tutte installate come da manuale.


dagli output da te postati non si direbbe vedi (chroor), e non (chroot) come dice il manuale.


OK (chroot) ho sbagliato a digitare....

ma i comandi li ho dati comunque tutti giusti e nell'ordine indicato nel post...

E mo che faccio? Ritento?
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Wed Feb 28, 2007 1:50 pm    Post subject: Reply with quote

Kernel78 wrote:
gatto wrote:
Il resto tutto ok.

Il resto senza quei comandi (nella giusta sequenza) conta poco niente.
coldplug probabilmente � nel runlevel boot, revdep-rebuild non � installato emerge -av app-portage/gentoolkit lo installa, il problema del sync sembra dato da un problema del dns o dal nome del mirror errato.


->emerge -av app-portage/gentoolkit l

Code:


(chroot) livecd gentoo # emerge -av app-portage/gentoolkit

These are the packages that would be merged, in order:

Calculating dependencies
emerge: there are no ebuilds to satisfy "app-portage/gentoolkit".

Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Feb 28, 2007 2:02 pm    Post subject: Reply with quote

il sync lo hai completato ???

ciauz
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Wed Feb 28, 2007 3:25 pm    Post subject: Reply with quote

crisandbea wrote:
il sync lo hai completato ???

ciauz


Questo il risultato:

Code:


rsync: mkstemp "/usr/portage/xfce-extra/xfwm4-themes/files/.digest-xfwm4-themes-4.2.3.Oahpyi" failed: No space left on device (28)
rsync: mkstemp "/usr/portage/xfce-extra/xfwm4-themes/files/.digest-xfwm4-themes-4.4.0.YvKR8V" failed: No space left on device (28)

Number of files: 145023
Number of files transferred: 15755
Total file size: 165079332 bytes
Total transferred file size: 27649002 bytes
Literal data: 27649002 bytes
Matched data: 0 bytes
File list size: 3300861
File list generation time: 33.072 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 346769
Total bytes received: 31691104

sent 346769 bytes  received 31691104 bytes  63128.81 bytes/sec
total size is 165079332  speedup is 5.15
rsync error: some files could not be transferred (code 23) at main.c(1298) [generator=2.6.8]

!!! Rsync has not successfully finished. It is recommended that you keep
!!! trying or that you use the 'emerge-webrsync' option if you are unable
!!! to use rsync due to firewall or other restrictions. This should be a
!!! temporary problem unless complications exist with your network
!!! (and possibly your system's filesystem) configuration.

Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Feb 28, 2007 3:41 pm    Post subject: Reply with quote

Ti chiedo scusa se sembrerò brusco, però questa discussione si sta protraendo un pò troppo, e ho sempre di più l'impressione che nella tua installazione ci sia qualche problema di troppo.

Quell'errore di "no space left on device" mi fa pensare che ci sia qualche problema di partizionamento del tuo disco, a questo punto mi viene da consigliarti di ripartire da zero, SEGUIRE per filo e per segno il manuale Gentoo, reinstallando tutto il sistema.

Inoltre ti consiglio caldamente di cercare nella Documentazione ufficiale di Gentoo per i vari problemi/necessità che incontrerai, PRIMA di postare sul forum. Vabbè che la maggior parte degli utenti sono disponibili ad aiutare, però dall'altra parte si richiede un minimo di volontà e di impegno :wink:
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Wed Feb 28, 2007 6:01 pm    Post subject: Reply with quote

Prima fai chroot per l'ennesima volta e fai queste cose:
Code:
nano /etc/make.conf

trovi la riga SYNC e la cancelli, al suo posto metti
Code:
SYNC="rsync://rsync1.it.gentoo.org/gentoo-portage"

stessa cosa con GENTOO_MIRROR
Code:
GENTOO_MIRRORS="ftp://ftp.unina.it/pub/linux/distributions/gentoo http://ftp.snt
.utwente.nl/pub/os/linux/gentoo http://mirror.datapipe.net/gentoo http://gentoo.
zie.pg.gda.pl http://ftp.lug.ro/gentoo/ http://ftp.roedu.net/pub/mirrors/gentoo.
org/"

poi
Code:
emerge --sync

Code:
env-update && source /etc/profile

Code:
emerge -1av udev

se a questo punto se ti chiede di aggiornare dei file di configurazione tu dai
Code:
etc-update

e poi fai -5 e invio. poi prosegui
Code:
emerge -av gentoolkit

Code:
emerge -DNav world

stessa cosa di sopra, se hai dei file di conf da aggiornare
Code:
revdep-rebuild -p

vedi sempre nota file
Code:
emerge --depclean --ask

domanda per gli altri: se la partizione di root è /dev/hda3 come in questo caso, in grub.conf ci andrà root (hd0,2) non root (hd0,0) giusto?
facci sapere
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Feb 28, 2007 6:51 pm    Post subject: Reply with quote

@^stefano^
se la riga relativa
Code:
 root (hd0,0)
non è la vera partizione di root ma la boot.

ciauz
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Thu Mar 01, 2007 3:02 pm    Post subject: Reply with quote

[quote="^Stefano^"]

Code:
emerge --sync


ad un certo punto ho dovuto dare <ctrl>+<c>

perche' sullo schermo cominciavano ad apparire scritte tipo:

Code:


rsync: mkstemp "/usr/portage/sys-fs/udev/files/.udev.rules-084.8xzcab" failed: No space left on device (28)



------------------------------------

Come diceva il buon Scen forse devo ripartire da zero :-(

Il problema che io mi pongo e' questo:

Ok, riparto da zero, e come lui dice "seguo il manuale alla lettera" ma io questo l'ho gia' fatto
utiizzando la guida presente in questo indirizzo.

Ho seguito la guida pedisequamente.

Per generre il kernenel ho utilizzato Genkernel.

----

Ora...

alcune questioni:

1) esiste una guida per utenti davvero "idioti" come penso di essere io?

2) nel file /etc/modules.autoload.d/kernel-2.6 ci vanno i moduli caricati automaticamente, posso, per non sbagliare, lasciare vuoto quel file?

------------------------------------

GRAZIE A TUTTI!
Back to top
View user's profile Send private message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Thu Mar 01, 2007 3:08 pm    Post subject: Reply with quote

allora; si, il file /etc/modules.autoload.d/kernel-2.6 è per i moduli ma con le nuove versioni di udev non serve più da quello che vedo. carica tutto lui, almeno da me 8O
dal messaggio di errore che riporti sembra che non riesca a memorizzare i file per mancanza di spazio. é possibile che hai fatto qualche castroneria con le partizioni? :?
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Mar 01, 2007 3:34 pm    Post subject: Reply with quote

gatto wrote:
1) esiste una guida per utenti davvero "idioti" come penso di essere io?

Tranquillo, :wink: nessuno mette in dubbio la tua buona volontà e attenzione nel seguire la guida, probabilmente hai commesso qualche errore (partizionamento, come suppone anche ^Stefano^) in uno dei tanti passaggi. Sapessi io quante volte ho rifatto l'installazione (a volte, avendo a disposizione un secondo pc da maltrattare, l'ho fatto solo per impararmela bene). :roll:

Pwe il partizionamento, se crei un'unica partizione, riservagli almeno 2-3 G, altrimenti corri il rischio di incorrere nuovamente in errori simili a quello che riscontri in fase di sync.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Thu Mar 01, 2007 3:52 pm    Post subject: Reply with quote

^Stefano^ wrote:

dal messaggio di errore che riporti sembra che non riesca a memorizzare i file per mancanza di spazio. � possibile che hai fatto qualche castroneria con le partizioni? :?


In realta' e' quello che ho pensato anch'io ma avevo seguito il manuale alla lettera, pedissequamente...

comunque questo e' lo schhema delle mie partizioni:

Code:


(chroot) livecd # fdisk -l

Disk /dev/hda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1           5       40131   83  Linux
/dev/hda2               6        2200    17631337+  82  Linux swap / Solaris
/dev/hda3            2201       12161    80011732+  83  Linux



e questo lo spazio usato:

Code:


(chroot) livecd ~ # df -h
Filesystem            Size  Used Avail Use% Mounted on
tmpfs                 506M   20M  487M   4% /
/dev/hdb              683M  683M     0 100% /mnt/cdrom
/dev/loop0            647M  647M     0 100% /mnt/livecd
udev                  506M  264K  505M   1% /dev
cachedir              647M  647M     0 100% /mnt/livecd/lib/splash/cache
tmpfs                 506M  4.4M  501M   1% /mnt/livecd/lib/firmware
tmpfs                 506M  461M   45M  92% /mnt/livecd/usr/portage
/dev/hda3              76G  1.9G   70G   3% /mnt/gentoo
/dev/hda1              38M  5.2M   31M  15% /mnt/gentoo/boot



:?:
Back to top
View user's profile Send private message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Thu Mar 01, 2007 5:44 pm    Post subject: Reply with quote

lo spazio sembra esserci. prova da una live a dare una controllatina al disco con fsck. in base al file system hai opzioni diverse da usare ma io non l'ho mai neanche guardato quel tool quindi non posso esserti molto di aiuto.
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Thu Mar 01, 2007 8:57 pm    Post subject: Reply with quote

^Stefano^ wrote:
lo spazio sembra esserci. prova da una live a dare una controllatina al disco con fsck. in base al file system hai opzioni diverse da usare ma io non l'ho mai neanche guardato quel tool quindi non posso esserti molto di aiuto.


Scusa ho provato a capire come funziona il comando fsck, ma l'unica cosa che sono riuscito a capire e' che se sbagli parametro ti fa dei danni incredibili...
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Thu Mar 01, 2007 9:08 pm    Post subject: Reply with quote

gatto wrote:
Scusa ho provato a capire come funziona il comando fsck, ma l'unica cosa che sono riuscito a capire e' che se sbagli parametro ti fa dei danni incredibili...

fdisk fa danni se lo usi su un filesystem montato. se lo smonti non succede nulla
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Thu Mar 01, 2007 9:11 pm    Post subject: Reply with quote

.:chrome:. wrote:
gatto wrote:
Scusa ho provato a capire come funziona il comando fsck, ma l'unica cosa che sono riuscito a capire e' che se sbagli parametro ti fa dei danni incredibili...

fdisk fa danni se lo usi su un filesystem montato. se lo smonti non succede nulla


ma come si usa?
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Thu Mar 01, 2007 9:56 pm    Post subject: Reply with quote

gatto wrote:
ma come si usa?

fsck --help fornisce la sintassi completa. se hai bisogno di ulteriori informazioni puoi usare la man page: man fsck

questo genere di domande è fortemente sconsigliato, sul forum. una risposta esaudiente consisterebbe nel fare un copia & incolla da quello che si ottiene da quei due comandi
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Fri Mar 02, 2007 4:08 pm    Post subject: Reply with quote

Scen wrote:
gatto wrote:
1) esiste una guida per utenti davvero "idioti" come penso di essere io?

Tranquillo, :wink: nessuno mette in dubbio la tua buona volontà e attenzione nel seguire la guida, probabilmente hai commesso qualche errore (partizionamento, come suppone anche ^Stefano^) in uno dei tanti passaggi. Sapessi io quante volte ho rifatto l'installazione (a volte, avendo a disposizione un secondo pc da maltrattare, l'ho fatto solo per impararmela bene). :roll:

Pwe il partizionamento, se crei un'unica partizione, riservagli almeno 2-3 G, altrimenti corri il rischio di incorrere nuovamente in errori simili a quello che riscontri in fase di sync.


Ok, riparto da zero....

Prima di partire ho pero' una domanda:

Nel file /etc/make.conf e' presente il settaggio della variabile USE, posso non metterre niente?
Back to top
View user's profile Send private message
gatto
n00b
n00b


Joined: 12 Feb 2007
Posts: 24

PostPosted: Fri Mar 02, 2007 4:18 pm    Post subject: Reply with quote

gatto wrote:
Scen wrote:
gatto wrote:
1) esiste una guida per utenti davvero "idioti" come penso di essere io?

Tranquillo, :wink: nessuno mette in dubbio la tua buona volontà e attenzione nel seguire la guida, probabilmente hai commesso qualche errore (partizionamento, come suppone anche ^Stefano^) in uno dei tanti passaggi. Sapessi io quante volte ho rifatto l'installazione (a volte, avendo a disposizione un secondo pc da maltrattare, l'ho fatto solo per impararmela bene). :roll:

Pwe il partizionamento, se crei un'unica partizione, riservagli almeno 2-3 G, altrimenti corri il rischio di incorrere nuovamente in errori simili a quello che riscontri in fase di sync.


Ok, riparto da zero....

Prima di partire ho pero' una domanda:

Nel file /etc/make.conf e' presente il settaggio della variabile USE, posso non metterre niente?


Nella mia utima installazione l'avevo settata cosi:

Code:


USE="x86 oss apm arts avi berkdb crypt cups encode foomaticdb gdbm gif gpm
 gtk gtk2 imlib jpeg kde gnome libg++ libwww mad mikmod motif mpeg ncurses
 nls oggvorbis opengl pam pdflib png python qt quicktime readline sdl
 slang spell ssl svga tcpd truetype X xml2 xmms xv zlib"



Manca qualcosa secondo voi?
Back to top
View user's profile Send private message
Kind_of_blue
Guru
Guru


Joined: 10 Oct 2004
Posts: 485

PostPosted: Fri Mar 02, 2007 4:18 pm    Post subject: Reply with quote

se non metti nulla ... usa quelle di default
_________________
"I got off the concept of Progress, it's over-rated"
Arthur Dent
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum