Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]problema xorg-x11
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sat Feb 24, 2007 3:30 pm    Post subject: [RISOLTO]problema xorg-x11 Reply with quote

Allora ho riscontrato il seguente problema installando xorg-x11. Ho seguito questa guida (http://www.gentoo.org/doc/it/xorg-config.xml), sono arrivato a configurare xorg.conf dando
Code:
xorgconfig

e in seguito dando il comando
Code:
Xorg -config /etc/X11/xorg.conf

da errori del tipo
Code:
(EE) end of block range 0x1fffffff < begin 0xe0000000
(EE) Failed to load module "vga" (module does not esist, 0)
(EE) No drivers avaible.

Fatal server error:
no screen found

grazie in anticipo a chi mi vorra aiutare...


Last edited by simone-27 on Mon Feb 26, 2007 8:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Feb 24, 2007 3:39 pm    Post subject: Reply with quote

hai abilitato nel kernel il modulo per la tua scheda grafica ???
Back to top
View user's profile Send private message
richard77
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 275

PostPosted: Sat Feb 24, 2007 3:40 pm    Post subject: Reply with quote

Che scheda video hai?

Posta cosa ti restituisce il comando

Code:

grep "VIDEO_CARDS" /etc/make.conf

_________________
Fletto i muscoli e sono nel vuoto
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sat Feb 24, 2007 3:46 pm    Post subject: Reply with quote

mi restituisce VIDEO_CARDS="nv"....ho una geforce 6200 TurboCache...e non so se ho abilitato nel kernel il modulo...cos avrei dovuto fare?

Last edited by simone-27 on Sat Feb 24, 2007 3:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Feb 24, 2007 3:48 pm    Post subject: Reply with quote

simone-27 wrote:
mi restituisce VIDEO_CARDS="nv"....ho una geforce...e non so se ho abilitato nel kernel il modulo...cos avrei dovuto fare?


posta questo
Code:
cat /usr/src/linux/.config | grep NV
,
e segui questa guida http://www.gentoo.org/doc/it/nvidia-guide.xml
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sat Feb 24, 2007 3:55 pm    Post subject: Reply with quote

dici di installare i driver nvidia? avevo letto da qualche parte che era meglio cominciare con gli nv, per quello non l ho fatto!!L' output è:
Code:
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_SATA_NV=y
# CONFIG_NVRAM is not set
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Feb 24, 2007 3:56 pm    Post subject: Reply with quote

simone-27 wrote:
dici di installare i driver nvidia? avevo letto da qualche parte che era meglio cominciare con gli nv, per quello non l ho fatto!!L' output è:
Code:
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_SATA_NV=y
# CONFIG_NVRAM is not set


segui la guida che ti ho postato prima e vai tranquillo.
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sat Feb 24, 2007 3:57 pm    Post subject: Reply with quote

ok il kernel è a posto quindi?
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Feb 24, 2007 4:02 pm    Post subject: Reply with quote

simone-27 wrote:
ok il kernel è a posto quindi?


segui la guida c'è scritto tutto anke i controlli da fare sul kernel.

ciauz
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sun Feb 25, 2007 1:14 pm    Post subject: Reply with quote

Allora devo chiedere una cosa...la guida sopra citata dice di impostare questo valore cosi
Code:
Device Drivers --->
Character devices --->
<*> /dev/agpgart (AGP Support)

ma dando make menuconfig io lo ritrovo cosi
Code:
Device Drivers --->
Character devices --->
---- /dev/agpgart (AGP Support)

e non c'è la possibilita di cambiarlo...perche?cosa devo fare?una volta configurato il kernel è sufficento dare il comando make && make modules_install?grazie...
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Sun Feb 25, 2007 5:05 pm    Post subject: Reply with quote

per quanto riguardo AGP, devi selezionare il chipset corretto dalla lista che trovi sotto
Quote:
---- /dev/agpgart (AGP Support)
a seconda della tua scheda madre. Solitamente è gia' presente quindi non dovresti fare nulla :)
invece per la compilazione del kernel dopo aver dato i comandi make devi copiare l'immagine del kernel in /boot e modificare anche il grub. C'è anche la USE "symlink" che ti potrebbe aiutare..comunque trovi tutto sulla guida :wink:
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sun Feb 25, 2007 8:06 pm    Post subject: Reply with quote

ho seguito la guida passo passo, ma quando arrivo a dare
Code:
glxinfo | grep direct

mi restituisce
Code:
Error: unable to open display (null)

dove posso aver sbagliato?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Feb 25, 2007 8:42 pm    Post subject: Reply with quote

simone-27 wrote:
Allora devo chiedere una cosa...la guida sopra citata dice di impostare questo valore cosi
Code:

...
---- /dev/agpgart (AGP Support)

e non c'è la possibilita di cambiarlo...perche?cosa devo fare?

se usi l'opzione help di menuconfig, trovi alcune spiegazioni.
sul fondo, compaiono queste linee:
Code:

Depends on: (ALPHA || IA64 || PARISC || PPC || X86) && PCI
...
 Selected by: IOMMU && PCI || FB_I810 && FB && EXPERIMENTAL && PCI && X86_32 || FB_INTEL && FB && EXPERIMENTAL && PCI && X86

quelle sono le dipendenze che rendono accessibile o forzano la compilazione del modulo attuale.
Nel tuo caso, il modulo AGP è compilato forzosamente nel kernel.
Prova a dare `cat /usr/src/linux/.config |grep AGP` e ne avrai conferma.

per il tuo errore, cosa dice `eselect opengl list` ?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Sun Feb 25, 2007 11:24 pm    Post subject: Reply with quote

Allora nonostante l' errore dando startx parte una minina interfaccia grafica (credo sia twm), dopo aver dato
Code:
emerge kdebase-startkde

e
Code:
echo "exec startkde" > /.xinitrc

dando startx mi da il seguente errore
Code:
xsetroot: unable to open display ' '
xset: unable to open display ""
xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ' '
startkde: Starting up...
startkde: Running kpersonalizer...
kwin: cannot connect to X server
kpersonalizer: cannot connect to X server

dove può essere il problema?grazie in anticipo...



scusa non avevo visto il post...cmq l' output di cat /usr/src/linux/.config | grep AGP é
Code:
CONFIG_AGP=y
CONFIG_AGP_AMD64=y
CONFIG_AGP_INTEL=y
# CONFIG_AGP_SIS is not set
# CONFIG_AGP_VIA is not set

mentre l' output di eselect opengl list è
Code:
[1] nvidia
[2] xorg-x11
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Feb 26, 2007 2:29 am    Post subject: Reply with quote

AGP è a posto.
eselect da una risposta anomala.
forse non è l'unica causa di errore, ma di certo dovrebbe essere così:
Code:

cloc3@s939 ~ $ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11

da root, prova a dare: `eselect opengl set nvidia`
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 26, 2007 8:17 am    Post subject: Reply with quote

Per me non hai configurato la scheda video, in /etc/X11/xorg.conf.

Come lo hai creato questo file di configurazione? Io ti consiglio di utilizzare la procedura guidata tramite
Code:

xorgconfig

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Mon Feb 26, 2007 2:07 pm    Post subject: Reply with quote

Ho controllato ed effettivamente l' output di eselect opengl list è
Code:
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11

il file xorg.conf l' creato con xorgconfig, lo posto cosi puoi darci un occhiata...
Code:
Section "Module"
    Load        "dbe"     # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "freetype"
    Load       "glx"
#    Load       "dri"
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/75dpi/"
EndSection

Section "ServerFlags"

EndSection

Section "InputDevice"
    Identifier   "Keyboard1"
    Driver   "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"   "it"
EndSection

Section "InputDevice"
    Identifier   "Mouse1"
    Driver   "mouse"
    Option "Protocol"    "Auto"   # Auto detect
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"   "4 5 6 7"
    Option "Emulate3Buttons"
EndSection

Section "Monitor"
    Identifier  "My Monitor"
    HorizSync   31.5 - 64.3
    VertRefresh 76
EndSection

Section "Device"
    Identifier   "Standard VGA"
    VendorName   "Unknown"
    BoardName   "Unknown"
    Driver     "vga"
EndSection

Section "Device"
    Identifier  "NVIDIA GeForce"
    Driver      "nvidia"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA GeForce"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Grazie per gli aiuti e per la disponibilita!!


Last edited by simone-27 on Mon Feb 26, 2007 2:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 26, 2007 2:28 pm    Post subject: Reply with quote

Assicurati che il modulo del kernel per la tua scheda grafica sia abilitato:
Code:

lsmod | grep nvidia

dovrebbe restituirti qualcosa.

Altrimenti caricalo con
Code:

modprobe -v nvidia


Per farlo caricare in automatico ad ogni avvio del sistema, ti consiglio di aggiungere la voce nvidia al file /etc/modules.autoload/kernel-2.6.

Perchè vuoi avviare direttamente KDE? Ti consiglio di utilizzare un login manager, tipo kde-base/kdm.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Feb 26, 2007 2:39 pm    Post subject: Reply with quote

quando si postano file così lunghi sarebbe bene togliere i commenti... Altrimenti è illeggibile
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Mon Feb 26, 2007 2:49 pm    Post subject: Reply with quote

Ecco ho tolto i commenti scusate non ci avevo pensato...comunque dando
Code:
lsmod | grep nvidia

non restituisce niente, invece dopo aver dato
Code:
modprobe -v nvidia

restituisce
Code:
nvidia                  5431700     0
i2c_core                22271       1       nvidia

ma dando
Code:
exec startkde

da lo stesso errore di prima!!
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 26, 2007 2:57 pm    Post subject: Reply with quote

simone-27 wrote:
Ecco ho tolto i commenti scusate non ci avevo pensato...comunque dando
Code:
lsmod | grep nvidia

non restituisce niente, invece dopo aver dato
Code:
modprobe -v nvidia

restituisce
Code:
nvidia                  5431700     0
i2c_core                22271       1       nvidia


Ok, basta caricare il modulo (per cui configura il caricamento automatico come spiegato)

simone-27 wrote:

ma dando
Code:
exec startkde

da lo stesso errore di prima!!

Qui esuliamo dal problema "xorg-x11" :roll:

L'aggiunta di exec startkde a ~/.xinitrc devi farla come utente normale, non come root. Inoltre assicurati di aver aggiornato le variabili d'ambiente, dopo aver installato KDE:
Code:

env-update
source /etc/profile

Dopodichè prova con startx

P.S. ti rinnovo il consiglio di utilizzare un login manager :wink:
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Mon Feb 26, 2007 3:15 pm    Post subject: Reply with quote

ma come faccio ad aggiungere exec startkde in /.xinitrc da utente?Mi dice permission denied...comunque cosa intendi per login manager?
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 26, 2007 3:34 pm    Post subject: Reply with quote

simone-27 wrote:
ma come faccio ad aggiungere exec startkde in /.xinitrc da utente?Mi dice permission denied...

:?:
Hai creato un nuovo utente, e gli hai impostato la password?

Effettua il login con quell'utente, e dai il comando
Code:

echo "exec startkde" > ~/.xinitrc

serve per far eseguire in automatico lo script di avvio startkde quando lanci startx

simone-27 wrote:
comunque cosa intendi per login manager?

Spiegazione terra terra: un programma grafico che si avvia automaticamente all'avvio del computer, e che gestisce l'autenticazione dell'utente, oppure lo spegnimento/riavvio della macchina.

Immagine esplicativa a caso :P
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
simone-27
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2007
Posts: 118

PostPosted: Mon Feb 26, 2007 3:52 pm    Post subject: Reply with quote

Per il login manager mi sembra una buona idea, e non appena avro fatto andare kde lo installero, ma ho un problema, ho creato l' utente, ho creato la password, ma dando
Code:
echo "exec startkde" > ~/.xinitrc

da quell utente mi da
Code:
-bash: ~/.xinitrc: Permission denied

non ho i permessi necessari per modificarlo evidentemente!!
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 26, 2007 4:04 pm    Post subject: Reply with quote

Probabilmente c'è qualcosa che non va nel tuo filesystem, o nelle opzioni di mount delle partizioni. Posta il risultato dei seguenti comandi:

  • cat /etc/fstab
  • ls -l /home
  • mount

Per curiosità: se fai
Code:

touch .xinitrc

ti dà sempre lo stesso errore di permission denied?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum