Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg schermata nera
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Sat Jun 29, 2013 4:19 pm    Post subject: Xorg schermata nera Reply with quote

Ho un problema con Xorg: ho letto tutte le guide, seguito tutti i passaggi ma niente da fare. Nonostante Xorg apparentemente funzioni, quando lancio startx ottengo sempre una schermata nera nonostante abbia installato twm e xterm.

Successivamente ho installato kde ed ottengo lo stesso identico problema.

Questo è il mio xorg.conf

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 319.23 (buildmeister@swio-display-x86-rhel47-11) Thu May 16 20:17:21 PDT 2013


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
# Load "dri"
Load "glx"
EndSection

Section "InputDevice"

# generated from data in "/etc/conf.d/gpm"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nvidia"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


E questo il mio Xorg.o.log

Quote:
[ 457.503]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[ 457.503] X Protocol Version 11, Revision 0
[ 457.503] Build Operating System: Linux 3.8.13-gentoo x86_64 Gentoo
[ 457.503] Current Operating System: Linux Asus-A55VD 3.8.13-gentoo #1 SMP Fri Jun 28 04:40:01 CEST 2013 x86_64
[ 457.503] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.8.13-gentoo root=/dev/sda10
[ 457.503] Build Date: 28 June 2013 02:25:16PM
[ 457.503]
[ 457.503] Current version of pixman: 0.28.0
[ 457.503] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 457.503] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 457.503] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jun 29 20:06:40 2013
[ 457.503] (==) Using config file: "/etc/X11/xorg.conf"
[ 457.503] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 457.503] (==) ServerLayout "Layout0"
[ 457.503] (**) |-->Screen "Screen0" (0)
[ 457.503] (**) | |-->Monitor "Monitor0"
[ 457.503] (==) No device specified for screen "Screen0".
Using the first device section listed.
[ 457.503] (**) | |-->Device "Device0"
[ 457.503] (**) |-->Input Device "Keyboard0"
[ 457.503] (**) |-->Input Device "Mouse0"
[ 457.503] (==) Automatically adding devices
[ 457.503] (==) Automatically enabling devices
[ 457.503] (==) Automatically adding GPU devices
[ 457.503] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 457.503] Entry deleted from font path.
[ 457.503] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 457.503] Entry deleted from font path.
[ 457.503] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 457.503] Entry deleted from font path.
[ 457.503] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 457.503] Entry deleted from font path.
[ 457.503] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 457.503] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 457.503] Entry deleted from font path.
[ 457.503] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 457.503] (==) FontPath set to:
/usr/share/fonts/misc/
[ 457.503] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 457.503] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 457.503] (WW) Disabling Keyboard0
[ 457.503] (WW) Disabling Mouse0
[ 457.503] (II) Loader magic: 0x806be0
[ 457.503] (II) Module ABI versions:
[ 457.503] X.Org ANSI C Emulation: 0.4
[ 457.503] X.Org Video Driver: 13.1
[ 457.503] X.Org XInput driver : 18.0
[ 457.503] X.Org Server Extension : 7.0
[ 457.504] (--) PCI:*(0:0:2:0) 8086:0166:1043:1457 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[ 457.504] (--) PCI: (0:1:0:0) 10de:1058:1043:1457 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/134217728, 0xe8000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 457.504] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 457.518] Initializing built-in extension Generic Event Extension
[ 457.518] Initializing built-in extension SHAPE
[ 457.518] Initializing built-in extension MIT-SHM
[ 457.518] Initializing built-in extension XInputExtension
[ 457.518] Initializing built-in extension XTEST
[ 457.518] Initializing built-in extension BIG-REQUESTS
[ 457.518] Initializing built-in extension SYNC
[ 457.518] Initializing built-in extension XKEYBOARD
[ 457.518] Initializing built-in extension XC-MISC
[ 457.518] Initializing built-in extension XINERAMA
[ 457.518] Initializing built-in extension XFIXES
[ 457.518] Initializing built-in extension RENDER
[ 457.518] Initializing built-in extension RANDR
[ 457.518] Initializing built-in extension COMPOSITE
[ 457.518] Initializing built-in extension DAMAGE
[ 457.518] Initializing built-in extension MIT-SCREEN-SAVER
[ 457.518] Initializing built-in extension DOUBLE-BUFFER
[ 457.518] Initializing built-in extension RECORD
[ 457.518] Initializing built-in extension DPMS
[ 457.518] Initializing built-in extension X-Resource
[ 457.518] Initializing built-in extension XVideo
[ 457.518] Initializing built-in extension XVideo-MotionCompensation
[ 457.518] Initializing built-in extension XFree86-VidModeExtension
[ 457.518] Initializing built-in extension XFree86-DGA
[ 457.518] Initializing built-in extension XFree86-DRI
[ 457.518] Initializing built-in extension DRI2
[ 457.518] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 457.518] (II) LoadModule: "glx"
[ 457.518] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 457.524] (II) Module glx: vendor="NVIDIA Corporation"
[ 457.524] compiled for 4.0.2, module version = 1.0.0
[ 457.524] Module class: X.Org Server Extension
[ 457.524] (II) NVIDIA GLX Module 319.23 Thu May 16 19:23:10 PDT 2013
[ 457.524] Loading extension GLX
[ 457.524] (II) LoadModule: "nvidia"
[ 457.525] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 457.525] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 457.525] compiled for 4.0.2, module version = 1.0.0
[ 457.525] Module class: X.Org Video Driver
[ 457.525] (II) NVIDIA dlloader X Driver 319.23 Thu May 16 19:02:20 PDT 2013
[ 457.525] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 457.525] (++) using VT number 7

[ 457.527] (II) Loading sub module "fb"
[ 457.527] (II) LoadModule: "fb"
[ 457.527] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 457.527] (II) Module fb: vendor="X.Org Foundation"
[ 457.527] compiled for 1.13.4, module version = 1.0.0
[ 457.527] ABI class: X.Org ANSI C Emulation, version 0.4
[ 457.527] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 457.527] (II) Loading sub module "wfb"
[ 457.527] (II) LoadModule: "wfb"
[ 457.527] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 457.527] (II) Module wfb: vendor="X.Org Foundation"
[ 457.527] compiled for 1.13.4, module version = 1.0.0
[ 457.527] ABI class: X.Org ANSI C Emulation, version 0.4
[ 457.527] (II) Loading sub module "shadow"
[ 457.527] (II) LoadModule: "shadow"
[ 457.527] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 457.527] (II) Module shadow: vendor="X.Org Foundation"
[ 457.527] compiled for 1.13.4, module version = 1.1.0
[ 457.527] ABI class: X.Org ANSI C Emulation, version 0.4
[ 457.527] (II) Loading sub module "ramdac"
[ 457.527] (II) LoadModule: "ramdac"
[ 457.527] (II) Module "ramdac" already built-in
[ 457.527] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 457.527] (==) NVIDIA(0): RGB weight 888
[ 457.527] (==) NVIDIA(0): Default visual is TrueColor
[ 457.527] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 457.527] (**) NVIDIA(0): Enabling 2D acceleration
[ 457.622] (--) NVIDIA(0): No display subsystem found
[ 457.622] (II) NVIDIA(0): Implicitly enabling NoScanout
[ 457.622] (WW) NVIDIA(0): Failed to enable display hotplug notification
[ 457.689] (II) NVIDIA(0): NVIDIA GPU GeForce 610M (GF119) at PCI:1:0:0 (GPU-0)
[ 457.689] (--) NVIDIA(0): Memory: 2097152 kBytes
[ 457.689] (--) NVIDIA(0): VideoBIOS: 75.19.59.00.19
[ 457.689] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 457.689] (--) NVIDIA(0): Valid display device(s) on GeForce 610M at PCI:1:0:0
[ 457.689] (--) NVIDIA(0): none
[ 457.689] (II) NVIDIA(0): Validated MetaModes:
[ 457.689] (II) NVIDIA(0): "nvidia-auto-select"
[ 457.689] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[ 457.689] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[ 457.689] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 457.689] (--) Depth 24 pixmap format is 32 bpp
[ 457.689] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 457.689] (II) NVIDIA: access.
[ 457.691] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 457.691] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 457.691] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 457.691] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 457.691] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 457.691] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 457.691] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 457.691] (II) NVIDIA(0): Config Options in the README.
[ 457.691] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 457.691] (EE) NVIDIA(0): Failed to initiate mode change.
[ 457.691] (EE) NVIDIA(0): Failed to complete mode change
[ 457.693] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[ 457.693] Loading extension NV-GLX
[ 457.697] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 457.697] (==) NVIDIA(0): Backing store disabled
[ 457.697] (==) NVIDIA(0): Silken mouse enabled
[ 457.697] (**) NVIDIA(0): DPMS enabled
[ 457.697] Loading extension NV-CONTROL
[ 457.697] (II) Loading sub module "dri2"
[ 457.697] (II) LoadModule: "dri2"
[ 457.697] (II) Module "dri2" already built-in
[ 457.697] (II) NVIDIA(0): [DRI2] Setup complete
[ 457.697] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 457.697] (--) RandR disabled
[ 457.700] (II) Initializing extension GLX
[ 457.720] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[ 457.720] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 457.720] (II) LoadModule: "evdev"
[ 457.720] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 457.720] (II) Module evdev: vendor="X.Org Foundation"
[ 457.720] compiled for 1.13.4, module version = 2.7.3
[ 457.720] Module class: X.Org XInput Driver
[ 457.720] ABI class: X.Org XInput driver, version 18.0
[ 457.720] (II) Using input driver 'evdev' for 'Power Button'
[ 457.720] (**) Power Button: always reports core events
[ 457.720] (**) evdev: Power Button: Device: "/dev/input/event5"
[ 457.720] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 457.720] (--) evdev: Power Button: Found keys
[ 457.720] (II) evdev: Power Button: Configuring as keyboard
[ 457.720] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event5"
[ 457.720] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 457.720] (**) Option "xkb_rules" "evdev"
[ 457.720] (**) Option "xkb_model" "evdev"
[ 457.720] (**) Option "xkb_layout" "us"
[ 457.732] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[ 457.732] (II) No input driver specified, ignoring this device.
[ 457.732] (II) This device may have been added with another device file.
[ 457.732] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
[ 457.732] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 457.732] (II) Using input driver 'evdev' for 'Sleep Button'
[ 457.732] (**) Sleep Button: always reports core events
[ 457.732] (**) evdev: Sleep Button: Device: "/dev/input/event4"
[ 457.732] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[ 457.732] (--) evdev: Sleep Button: Found keys
[ 457.732] (II) evdev: Sleep Button: Configuring as keyboard
[ 457.732] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input4/event4"
[ 457.732] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
[ 457.732] (**) Option "xkb_rules" "evdev"
[ 457.732] (**) Option "xkb_model" "evdev"
[ 457.732] (**) Option "xkb_layout" "us"
[ 457.732] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[ 457.732] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 457.732] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 457.732] (**) AT Translated Set 2 keyboard: always reports core events
[ 457.732] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[ 457.732] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 457.733] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 457.733] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 457.733] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[ 457.733] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 8)
[ 457.733] (**) Option "xkb_rules" "evdev"
[ 457.733] (**) Option "xkb_model" "evdev"
[ 457.733] (**) Option "xkb_layout" "us"
[ 457.733] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event1)
[ 457.733] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[ 457.733] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
[ 457.733] (**) PS/2 Generic Mouse: always reports core events
[ 457.733] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/event1"
[ 457.733] (--) evdev: PS/2 Generic Mouse: Vendor 0x2 Product 0x1
[ 457.733] (--) evdev: PS/2 Generic Mouse: Found 3 mouse buttons
[ 457.733] (--) evdev: PS/2 Generic Mouse: Found relative axes
[ 457.733] (--) evdev: PS/2 Generic Mouse: Found x and y relative axes
[ 457.733] (II) evdev: PS/2 Generic Mouse: Configuring as mouse
[ 457.733] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[ 457.733] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 457.733] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input1/event1"
[ 457.733] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 9)
[ 457.733] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
[ 457.733] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[ 457.733] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[ 457.733] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[ 457.733] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[ 457.733] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[ 457.733] (II) No input driver specified, ignoring this device.
[ 457.733] (II) This device may have been added with another device file.
[ 457.733] (II) config/udev: Adding input device PC Speaker (/dev/input/event2)
[ 457.733] (II) No input driver specified, ignoring this device.
[ 457.733] (II) This device may have been added with another device file.
[ 517.877] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 517.877] (EE) NVIDIA(0): Failed to initiate mode change.
[ 517.877] (EE) NVIDIA(0): Failed to complete mode change
[ 517.881] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 517.881] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 517.881] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 517.881] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 517.881] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 517.881] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 517.881] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 517.881] (II) NVIDIA(0): Config Options in the README.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1486
Location: Cosenza, Italy

PostPosted: Sat Jun 29, 2013 7:35 pm    Post subject: Reply with quote

Apparentemente potrebbe essere legato al driver nvidia. Hai provato nouveau?

Se hai kde non startare con startx, usa il servizio xdm
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Sun Jun 30, 2013 9:23 pm    Post subject: Reply with quote

Problema risolto. Ho scoperto che era dovuto al fatto che ho sia una scheda video integrata della intel (HD 4000) che una una nvidia-geforce optimus dedicata. Ho provato a risolvere il problema utilizzando bumblebee ma nulla da fare. Continuavo ad avere anche con KDE la solita schermata nera senza mouse e tastiera.

Disperato, dopo giorni di tentativi, ho deciso di utilizzare solamente i driver intel per xorg. Ho ricompilato il tutto ed ora funziona tutto senza problemi.
Back to top
View user's profile Send private message
matchcase
n00b
n00b


Joined: 11 Jul 2013
Posts: 1

PostPosted: Thu Jul 11, 2013 2:27 am    Post subject: Reply with quote

Quote:
ho deciso di utilizzare solamente i driver intel per xor


How are you doing that? Do you also use nvidia driver? Or are you just entirely using intel?


Can you post your xorg.conf?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum