Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Rianimazione vecchia gentoo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Feb 19, 2007 6:13 pm    Post subject: Rianimazione vecchia gentoo Reply with quote

Ciao a tutti
ho rimesso mano ad una mia vecchia installazione che nn tocco da un bel po' (più di un anno di inattività) solo che nei piccoli aggiornamenti che sto facendo sono incappato in un piccolo problemino:

Code:
# emerge -av  baselayout

These are the packages that would be merged, in order:

Calculating dependencies 
Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r1'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'
                                                                                          ... done!
[blocks B     ] sys-apps/sysvinit (is blocking sys-apps/baselayout-1.9.4-r6)
[ebuild  N    ] sys-apps/sysvinit-2.86-r6  USE="(-ibm) (-selinux) -static" 0 kB
[ebuild  N    ] virtual/init-0  0 kB
[ebuild     U ] sys-apps/baselayout-1.12.9 [1.9.4-r6] USE="unicode%* -bootstrap -build -static (-debug%) (-livecd%) (-selinux%) (-uclibc%)" 214 kB
[ebuild     U ] sys-apps/module-init-tools-3.2.2-r2 [3.0-r2] USE="-no-old-linux% (-debug%)" 395 kB

Total: 4 packages (2 upgrades, 2 new, 1 block), Size of downloads: 609 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


apparte l'errore di dipendenze di xorg (Che non ho ancora aggiornato), il fatto è che sysvinit non è installato (ho anche provato a forzarlo con --nodeps e poi disinstallandolo non cambia nulla):
Code:
# emerge --unmerge sysvinit

Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r1'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'


--- Couldn't find 'sysvinit' to unmerge.

>>> No packages selected for removal by unmerge


quindi chiedo lumi per trovare dove va a leggere questa informazione e segarla alla nascita per permettere l'update di baselayout.

grazie
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Feb 19, 2007 6:44 pm    Post subject: Reply with quote

ma non è che l'ebuild è stato rimosso?
In tal caso nel passaggio dalla prima installazione all'aggiornamento (dopo appena 6 mesi) risolsi cancellando manualmente /var/db/pkg/pacchetto (più che altro un mv) ma non so fino a che punto un simile approccio brutale sia valido.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Feb 19, 2007 6:50 pm    Post subject: Reply with quote

djinnZ wrote:
ma non è che l'ebuild è stato rimosso?
In tal caso nel passaggio dalla prima installazione all'aggiornamento (dopo appena 6 mesi) risolsi cancellando manualmente /var/db/pkg/pacchetto (più che altro un mv) ma non so fino a che punto un simile approccio brutale sia valido.


si l'ebuild non è più in portage.
e non c'è nemmeno /var/db/pkg/sys-apps/sysvinit
l'unica cosa che c'è è: /var/cache/edb/dep/usr/portage/sys-apps/sysvinit-2.86-r5~r6~r7. ma si riferiscono all'ultima versione di sysvinit.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Feb 19, 2007 6:55 pm    Post subject: Reply with quote

hai provato -C virtual/init-0? ed a muovere var...
ormai non dovrebbe più accorgersene che è installato.
Dimenticavo che devi toglierlo da world se c'è.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Mon Feb 19, 2007 6:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Feb 19, 2007 6:57 pm    Post subject: Reply with quote

djinnZ wrote:
hai provato -C virtual/init-0?
ormai non dovrebbe più accorgersene che è installato.
Dimenticavo che devi toglierlo da world se c'è.


no, come vedi nel primo blocco di codice da me postato è marchiato come [N] :-\
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
GiRa
l33t
l33t


Joined: 07 Apr 2005
Posts: 717

PostPosted: Mon Feb 19, 2007 7:49 pm    Post subject: Reply with quote

Usa l'opzione -t e vedi chi lo vuole, elimina l'incomodo e riparti.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Feb 19, 2007 8:02 pm    Post subject: Reply with quote

prova a vedere quale pacchetto richiede sysinit, forse module-tools.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Feb 19, 2007 8:38 pm    Post subject: Reply with quote

GiRa wrote:
Usa l'opzione -t e vedi chi lo vuole, elimina l'incomodo e riparti.


Code:
# emerge -tav  baselayout

These are the packages that would be merged, in order:

Calculating dependencies
Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r1'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'
                                                                                          ... done!
[blocks B     ] sys-apps/sysvinit (is blocking sys-apps/baselayout-1.9.4-r6)
[ebuild     U ] sys-apps/module-init-tools-3.2.2-r2 [3.0-r2] USE="-no-old-linux% (-debug%)" 395 kB
[ebuild     U ]  sys-apps/baselayout-1.12.9 [1.9.4-r6] USE="unicode%* -bootstrap -build -static (-debug%) (-livecd%) (-selinux%) (-uclibc%)" 214 kB
[ebuild  N    ]   virtual/init-0  0 kB
[ebuild  N    ]    sys-apps/sysvinit-2.86-r6  USE="(-ibm) (-selinux) -static" 0 kB

Total: 4 packages (2 upgrades, 2 new, 1 block), Size of downloads: 609 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


resta il fatto che sysvinit NON è installato.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Feb 19, 2007 8:48 pm    Post subject: Reply with quote

Peach wrote:
resta il fatto che sysvinit NON è installato.

Ok, si vede che emerge fa qualche casino nel calcolo delle dipendenze: baselayout-1.9, attualmente installato, NON vuole sysvinit, mentre la versione 1.12 a cui aggiornare sì.

Ti consiglio di procedere così:
Code:

emerge --nodeps baselayout

[aggiornamento file di configurazione]

emerge --oneshot sysvinit module-init-tools

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Feb 19, 2007 8:58 pm    Post subject: Reply with quote

Sicuro che sia conveniente aggiornare tramite portage? Dovrai passare anche attraverso la ricompilazione con gcc4.1... Io aspetterei marzo e aggiornerei tramite il livecd 2007.0.
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Feb 19, 2007 11:10 pm    Post subject: Reply with quote

Scen wrote:
Ti consiglio di procedere così:
Code:

emerge --nodeps baselayout

[aggiornamento file di configurazione]

emerge --oneshot sysvinit module-init-tools


ma, guarda, sono rimasto perplesso, perché non ha fatto una piega: aggiornato forzatamente così non l'avevo pensata, pensavo piuttosto alla causa di tale malessere.
in ogni caso l'unica cosa che ho provato a fare (devo ancora riavviare) è stato provare a ridare emerge di baselayout.
direi che mi ha solo avvertito di emergere init-0
per il resto tutto ok.
aspetto a riavviare prima di mettere un punto qui.


@riverdragon: non mi interessa l'aggiornamento di gcc. Piuttosto del sistema gentoo la sua funzionalità è l'unica cosa preoccupante qui.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum